Fedora Linux Support Community & Resources Center
  #1  
Old 9th November 2010, 09:56 PM
HMSS013 Offline
Registered User
 
Join Date: Nov 2006
Posts: 510
linuxfedorafirefox
Error With Python / Python-Twisted-Web

i'm having an error when running a python script that uses the python-twisted-web components...

...not sure if it matters but i get the impression that this program was developed and tested in a debian environment.

heres the readout:

Quote:
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/twisted/internet/base.py", line 1165, in run
self.mainLoop()
File "/usr/lib/python2.7/site-packages/twisted/internet/base.py", line 1177, in mainLoop
self.doIteration(t)
File "/usr/lib/python2.7/site-packages/twisted/internet/selectreactor.py", line 140, in doSelect
_logrun(selectable, _drdw, selectable, method, dict)
--- <exception caught here> ---
File "/usr/lib/python2.7/site-packages/twisted/python/log.py", line 84, in callWithLogger
return callWithContext({"system": lp}, func, *args, **kw)
File "/usr/lib/python2.7/site-packages/twisted/python/log.py", line 69, in callWithContext
return context.call({ILogContext: newCtx}, func, *args, **kw)
File "/usr/lib/python2.7/site-packages/twisted/python/context.py", line 59, in callWithContext
return self.currentContext().callWithContext(ctx, func, *args, **kw)
File "/usr/lib/python2.7/site-packages/twisted/python/context.py", line 37, in callWithContext
return func(*args,**kw)
File "/usr/lib/python2.7/site-packages/twisted/internet/selectreactor.py", line 156, in _doReadOrWrite
self._disconnectSelectable(selectable, why, method=="doRead")
File "/usr/lib/python2.7/site-packages/twisted/internet/posixbase.py", line 250, in _disconnectSelectable
selectable.readConnectionLost(f)
File "/usr/lib/python2.7/site-packages/twisted/internet/tcp.py", line 508, in readConnectionLost
self.connectionLost(reason)
File "/usr/lib/python2.7/site-packages/twisted/internet/tcp.py", line 677, in connectionLost
Connection.connectionLost(self, reason)
File "/usr/lib/python2.7/site-packages/twisted/internet/tcp.py", line 519, in connectionLost
protocol.connectionLost(reason)
File "/usr/lib/python2.7/site-packages/twisted/web/http.py", line 489, in connectionLost
self.handleResponseEnd()
File "/usr/lib/python2.7/site-packages/twisted/web/http.py", line 500, in handleResponseEnd
self.handleResponse(b)
exceptions.AttributeError: 'NoneType' object has no attribute 'transport'
Reply With Quote
  #2  
Old 9th November 2010, 10:17 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,291
linuxkonqueror
Re: Error With Python / Python-Twisted-Web

F14? 32-bit or 64-bit?

You could try the build here, see if it makes any difference: http://www.city-fan.org/ftp/contrib/yum-repo/fc14/i386/ (32-bit)
or here http://www.city-fan.org/ftp/contrib/...o/fc14/x86_64/ (64-bit)

You may also need City-Fan.Org version of python-twisted-core or other deps, but beware of mixing 3rd-party repos.

V
Reply With Quote
  #3  
Old 10th November 2010, 08:40 AM
HMSS013 Offline
Registered User
 
Join Date: Nov 2006
Posts: 510
linuxfedorafirefox
Re: Error With Python / Python-Twisted-Web

Quote:
Originally Posted by Hlingler View Post
F14? 32-bit or 64-bit?

You could try the build here, see if it makes any difference: http://www.city-fan.org/ftp/contrib/yum-repo/fc14/i386/ (32-bit)
or here http://www.city-fan.org/ftp/contrib/...o/fc14/x86_64/ (64-bit)

You may also need City-Fan.Org version of python-twisted-core or other deps, but beware of mixing 3rd-party repos.

V
14...32 bit... what exactly is the difference between the original F14 packages and those as this repository you've suggested?
Reply With Quote
  #4  
Old 10th November 2010, 09:43 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,291
linuxkonqueror
Re: Error With Python / Python-Twisted-Web

Code:
rpm -qp --changelog http://www.city-fan.org/ftp/contrib/yum-repo/fc14/i386/python-twisted-web-10.1.0-1.1.cf.fc14.i686.rpm
rpm -q --changelog python-twisted-web
V
Reply With Quote
  #5  
Old 10th November 2010, 10:03 PM
HMSS013 Offline
Registered User
 
Join Date: Nov 2006
Posts: 510
linuxfedorafirefox
Re: Error With Python / Python-Twisted-Web

Quote:
Originally Posted by Hlingler View Post
Code:
rpm -qp --changelog http://www.city-fan.org/ftp/contrib/yum-repo/fc14/i386/python-twisted-web-10.1.0-1.1.cf.fc14.i686.rpm
rpm -qp --changelog http://kojipkgs.fedoraproject.org/packages/python-twisted-web/10.1.0/1.fc14/i686/python-twisted-web-10.1.0-1.fc14.i686.rpm
V
i'm still not sure if i understand the difference between this package and the fedora package of the exact same name.
Reply With Quote
  #6  
Old 10th November 2010, 10:11 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,291
linuxkonqueror
Re: Error With Python / Python-Twisted-Web

Quote:
i'm still not sure if i understand the difference between this package and the fedora package of the exact same name.
The existing one fails. The other one might work.

V
Reply With Quote
  #7  
Old 11th November 2010, 04:07 AM
HMSS013 Offline
Registered User
 
Join Date: Nov 2006
Posts: 510
windows_xp_2003firefox
Re: Error With Python / Python-Twisted-Web

Quote:
Originally Posted by Hlingler View Post
The existing one fails. The other one might work.

V
oo0o ...i see whatcha mean...i thought you might have an understanding that i was not grasping.

worth a shot
Reply With Quote
Reply

Tags
error, python, pythontwistedweb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Python, IDLE, Python-tools Gnome. Deonis Using Fedora 2 12th March 2009 03:44 AM
python and python-irclib problem LostSon Programming & Packaging 3 6th March 2008 11:12 PM
Processing Conflict: python-devel conflicts python< 2.3.4-13.1 guarriman Using Fedora 0 15th September 2005 05:53 PM
/etc/cron.daily/yum.cron: Error: python-devel conflicts with python < 2.3.4-13.1 productive Servers & Networking 0 20th April 2005 08:51 PM


Current GMT-time: 03:22 (Friday, 18-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat