Fedora Linux Support Community & Resources Center
  #1  
Old 11th November 2010, 11:46 PM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Back to nouveau driver

Fedora 13, x86_64, up to date. Trying to get nVidia Quadro NVS 140M to display on a projector the same as it does on the laptop screen, which is 1680 x 1050. I failed to do so with the nVidia driver (latest version), so I want to go back to the nouveau driver and try with xrandr.

I have always used the nouveau driver with Fedora without an issue, but in my former life in Ubuntu I sometimes switched back and forth between the "nv" driver and the nVidia driver. Doing so was trivially easy - just edit xorg.conf replacing "nv" with "nvidia" or vice-versa, then restart X. However, after installing the nVidia driver via Yumex and using the nVidia config utility, I find that now I have an xorg.conf file that is loaded with stuff I don't understand, except that at the top it says it was created by nVidia, and there are two places where it says the driver is "nvidia."

I have searched the forums for the past hour, and previously I googled for an hour, and all I can find is instructions for installing the nVidia driver. Apparently that is meant to be a one-way ticket, because I can't find any instructions for how to return to the nouveau driver, except stuff that is over a year old, and complaints from users whose systems failed to start X where no one ever posted a solution.

What would happen if I just replace "nvidia" with "nouveau" in the xorg.conf file and restart X? I know if it won't start X I can boot to rescue mode and re-edit xorg.conf, but I'd rather ask first and do it the right way than have to repair a broken system.
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #2  
Old 12th November 2010, 12:46 AM
macemoneta Offline
Registered User
 
Join Date: May 2004
Location: NJ
Posts: 913
linuxchrome
Re: Back to nouveau driver

Simply erase the xorg.conf (nouveau doesn't use one), and run the nvidia installer with the "--uninstall" option. If you blacklisted nouveau in grub.conf or /etc/modprobe.d, undo that as well.
Reply With Quote
  #3  
Old 12th November 2010, 02:29 AM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Re: Back to nouveau driver

Quote:
Originally Posted by macemoneta View Post
Simply erase the xorg.conf (nouveau doesn't use one), and run the nvidia installer with the "--uninstall" option. If you blacklisted nouveau in grub.conf or /etc/modprobe.d, undo that as well.
I renamed xorg.conf to xorg.conf.old, also appended .old to the blacklist file in /etc/modprobe.d, also checked /boot/grub/grub.conf and it contained no reference to nVidia. Then I tried to uninstall, but apparently I don't have the nvidia-installer package:

Code:
[root@Devil8 /]# nvidia-installer --uninstall
bash: nvidia-installer: command not found
[root@Devil8 /]# locate nvidia-installer
/var/log/nvidia-installer.log
[root@Devil8 /]#
Checking in Yumex, there exists no package nvidia-installer. Note that I installed the nVidia driver using Yumex. This installed the nvidia-settings utility as well, and when I tried to launch it I got a popup telling me I had to run nvidia-xconfig to enable the nVidia driver. I did so, and the nVidia driver has been working ever since.

According to nVidia the package is nvidia-installer:

http://us.download.nvidia.com/XFree8...alldriver.html

I could uninstall the nVidia package with Yumex, but I'd rather just disable the nVidia driver so I can switch back to it later if I want to.

Any idea how to get the nvidia-installer package?
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #4  
Old 12th November 2010, 03:56 AM
macemoneta Offline
Registered User
 
Join Date: May 2004
Location: NJ
Posts: 913
linuxchrome
Re: Back to nouveau driver

You don't want to just rename the blacklist file; put it back. If you haven't blacklisted nouveau, there's nothing to do. In grub.conf, typically people add 'nomodeset' on the kernel line to allow the nvidia driver to load. You may also have added a 'rdblacklist=nouveau'. If you did either or both, remove them.

If you didn't install with the nvidia installer, you don't have to '--uninstall' it. Just remove the nvidia-kmod or -akmod (whichever packages you installed). If you don't remember what method you used to install the nvidia driver, look through /var/log/yum.log to see which packages with 'nvidia' in the name that you installed
Reply With Quote
  #5  
Old 12th November 2010, 04:24 AM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Re: Back to nouveau driver

OK, I removed the kmod* file with Yumex, which also uninstalled a couple other packages. Now I'm going to restart X. Cross your fingers for me.

---------- Post added at 08:24 PM GMT ---------- Previous post was at 08:07 PM GMT ----------

Well, that didn't go well.

I logged out and back in again to restart X (rather than do it from the command line). But when the login screen tried to come back up the screen just flashed and flashed. That is, X wouldn't start. So I rebooted, but again, the progress bar just flashed and flashed at the point where it tried to start X.

Fortunately there was a previous kernel in the Grub menu, so I selected it to boot to. And here I am, back again. And apparently the nVidia driver didn't load. That is, clicking on System > Administration > nVidia Xserver Settings pops up a message that I should run nvidia-xconfig to enable the driver, and there was no nVidia logo when X started.

I hate fixing broken systems. How do I get the most recent kernel working again?
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #6  
Old 12th November 2010, 06:35 AM
macemoneta Offline
Registered User
 
Join Date: May 2004
Location: NJ
Posts: 913
linuxchrome
Re: Back to nouveau driver

When you say you are back again, what video driver are you using (check /var/log/Xorg.0.log)?
Reply With Quote
  #7  
Old 12th November 2010, 06:57 AM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Re: Back to nouveau driver

Quote:
Originally Posted by macemoneta View Post
When you say you are back again, what video driver are you using (check /var/log/Xorg.0.log)?
After doing everything I wrote about above, I tried to log out and back in again as a means to restart X. The login screen would not come up. The login screen appeared, but was flashing and it was not possible to log in.

I shut down the computer with the power button. When I rebooted the progress bar got almost to the very end, then it started flashing and hung. I used the power switch again to shut the computer down.

When I restarted the computer I hit Esc as the Grub menu appeared. I selected the older kernel. This time the boot progressed correctly. I got a normal login screen and was able to log in properly.

I am using the nouveau driver. I checked /var/log/Xorg.0.log, but couldn't make heads or tails of it. But when I try to launch System > Administraition > NVidia X Server Settings I am prompted to run nvidia-xconfig to enable the nVidia driver. Also, after rebooting the nVidia splash screen never appeared.

I just want to fix it so the newer kernel in the Grub menu also boots with the same configuration and does not hang.
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #8  
Old 12th November 2010, 02:40 PM
macemoneta Offline
Registered User
 
Join Date: May 2004
Location: NJ
Posts: 913
linuxchrome
Re: Back to nouveau driver

From the working kernel, just reinstall the kernel. As root in a terminal:

Code:
yum reinstall kernel
This will rebuild the initial ramdisk with the correct drivers.
Reply With Quote
  #9  
Old 12th November 2010, 06:00 PM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Re: Back to nouveau driver

Quote:
Originally Posted by macemoneta View Post
From the working kernel, just reinstall the kernel. As root in a terminal:

Code:
yum reinstall kernel
This will rebuild the initial ramdisk with the correct drivers.
Are you sure this will work? From the yum man page:

reinstall
Will reinstall the identically versioned package as is currently installed. This does not work for "install-only" packages, like Kernels. reinstall operates on groups, files, provides and filelists just like the "install" command.

To clarify, my Grub menu lists:

2.6.34.7-61.fc13.x86_64
2.6.33.3-85.fc13.x86_64

If I boot to the newer one above X will hang with the progress bar flashing when it gets to the point where it tries to start X. If I boot to the older one X starts correctly. As I type this I am using the older kernel, as it is the only way to get X to start.

As a side question, the above two kernels are the only choices when I view the Grub boot choices, i.e., when I hit Esc instead of letting it boot to the default. Back when I used Ubuntu each choice would also have a rescue choice below it which would boot me to command line without X. How do I boot Fedora to a command line without X?
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
  #10  
Old 12th November 2010, 06:15 PM
macemoneta Offline
Registered User
 
Join Date: May 2004
Location: NJ
Posts: 913
linuxchrome
Re: Back to nouveau driver

Yes, yum has special processing for the running kernel (it will automatically skip it). Since the other kernel is newer, it will be reinstalled. You will be given the opportunity to confirm, and you can verify that the correct kernel will be reinstalled.

See section 18.1.3 in the installation documentation for instructions on booting to single user mode. You'll need to hit a key (e.g., up-arrow) repeatedly as your machine BIOS completes self-test to interrupt the boot process and get to a grub screen.
Reply With Quote
  #11  
Old 13th November 2010, 12:42 AM
JohnJasonJordan Offline
Registered User
 
Join Date: Mar 2007
Location: Portland USA left coast
Posts: 254
linuxfedorafirefox
Re: Back to nouveau driver

Quote:
Originally Posted by macemoneta View Post
Yes, yum has special processing for the running kernel (it will automatically skip it). Since the other kernel is newer, it will be reinstalled. You will be given the opportunity to confirm, and you can verify that the correct kernel will be reinstalled.

See section 18.1.3 in the installation documentation for instructions on booting to single user mode. You'll need to hit a key (e.g., up-arrow) repeatedly as your machine BIOS completes self-test to interrupt the boot process and get to a grub screen.
I am happy to report that the yum command worked exactly as you said it would. I apologize for doubting you!

However, after reinstalling the newer kernel I still can't boot to it. It still hangs when X tries to start.

To clarify how this came about, I started by installing the nVidia driver with Yumex, as the latest one is in the rpmfusion repository. But, although that installed it fine, it did not install the nvidia-install utility, so I could not use nvidia-install --uninstall. Therefore, I uninstalled by uninstalling the kmod package with Yumex, which also uninstalled a couple other packages. And I renamed xorg.conf and the nouveau blacklist file that the nVidia installer created. Upon rebooting with the default newer kernel it hangs as X tries to start. It boots fine if I boot to the older kernel. And just now I double checked the grub.conf file to make sure there wasn't anything in it that would cause the problem. I didn't see anything that might related to X. More importantly, the menu items are identical except for the name of the kernel. If one works, so should the other.

I wonder what would happen if I reinstall the nVidia driver, but this time download it and run the install script instead of installing it with Yumex.

And one more thing, when I rebooted I used the up arrows and they gave me the Grub boot menu. But it's the same boot menu that I got by hitting Esc over and over - that is, there are just two entries, one for each kernel. And that is what the grub.conf file has as well. I still can't figure out how to boot to a command line, but I'll go read 18.1.3 now and see what it says.

---------- Post added at 04:42 PM GMT ---------- Previous post was at 11:47 AM GMT ----------

SUCCESS!

It turns out I didn't need to boot to single mode (run level 1). If I waited the progress bar eventually stopped flashing. X still didn't start and it was hung, but at least I was able to get to a command line with Ctrl-Alt-F2.

Once there I read through boot.log and the xorg.0.log. The boot.log had nothing, but xorg.0.log had a number of references to blacklist-nouveau.old. I had appended the .old rather than remove it completely, but apparently something was still trying to use it. So I used nano and added a # in front of "blacklist nouveau."

After saving it I tried startx, but still got references to the blacklist-nouveau file. So I nuked it completely. Afterwards startx no longer gave me references to the blacklist-nouveau file, but X still wouldn't start. The error was that it could not find any screens.

Reading through the messages after the startx command I noticed that it said it was using xorg.conf. I had renamed the one created by nVidia, but apparently something had created a new one. I read through it and it was very short and clean, and it said to use the nouveau driver. Nevertheless, knowing that the nouveau driver does not need an xorg.conf file I renamed it. Afterwards X started!

I am now booted normally with the new kernel. The only problem remaining is that after the login screen the screen flashes several times before settling down to a normal Gnome desktop. It never used to flash like that. I suspect something else is trying to run right after I log in. I'll check xorg.o.log and see if I can figure out what it is. Meantime, at least things are more or less back to normal.

Thanks for all the help.
__________________
I like things that start with "lin*," so I use Linux and my major is linguistics.
Reply With Quote
Reply

Tags
dual screens, nvidia, xorg.conf

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rescue after failed nvidia driver install? restore nouveau or basic video driver? Icm76 Using Fedora 11 14th January 2012 03:23 AM
Should we enable nouveau back after installing NVIDIA driver? kimsieng Installation, Upgrades and Live Media 2 17th October 2010 04:05 PM
[SOLVED] Borked my sound messing with Nouveau driver: How do I get it back? nyjetshead Hardware & Laptops 1 15th May 2010 01:54 PM
Nouveau in F12 or back to nvidia? Demz Fedora Focus 10 13th June 2009 02:02 AM
Nouveau driver iamroot Using Fedora 16 3rd August 2007 11:45 PM


Current GMT-time: 00:04 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat