Fedora Linux Support Community & Resources Center
  #1  
Old 20th November 2010, 08:59 AM
piopio Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Unhappy GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Problem: Failed to start GNOME Shell. Reverting to previous settings.

this happened right after i installed this through root user terminal.

i can't seem to open it. at all.

Confused, i am a beginner.

So any help will be greatly welcomed!!
Reply With Quote
  #2  
Old 20th November 2010, 09:29 AM
ElderSnake Offline
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 810
windows_7chrome
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Were you perhaps trying to activate Gnome-Shell through the Desktop Effects menu?

I know you can do it that way but I wasn't even aware of it the first time so I used the old terminal command "gnome-shell --replace &" and it worked fine for me (and then after that I can switch between the desktops using the Desktop Effects menu without any issues I might add).
__________________
OS': Arch Linux (Xfce + Kwin) - Debian Testing (Xfce) - Fedora 20 - now Windows-free thanks Valve!
Reply With Quote
  #3  
Old 21st November 2010, 05:40 AM
piopio Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

I tried activating it through desktop effects. INITIALLY

but it gave me that message.

so i tried to manually enter as i read in your reply...i tried different variations you see...:


[-@localhost ~]$ gnome-shell--replace&
[1] 2787
[-@localhost ~]$ bash: gnome-shell--replace: command not found
gnome-shell
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
super(Connection, self).__init__(*args, **kwargs)
Starting dconf-service...
Failed to start /usr/libexec/dconf-service: [Errno 2] No such file or directory
[1]+ Exit 127 gnome-shell--replace
[-@localhost ~]$ gnome-shell--replace
bash: gnome-shell--replace: command not found
[-@localhost ~]$

What did i do wrong? Please lead me!!!!

Last edited by piopio; 21st November 2010 at 05:46 AM.
Reply With Quote
  #4  
Old 21st November 2010, 05:54 AM
ElderSnake Offline
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 810
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Unless my eyes are deceiving me, it looks like you have no space between 'gnome-shell' and '--replace'.

Type it exactly as 'gnome-shell --replace' and see what happens.
__________________
OS': Arch Linux (Xfce + Kwin) - Debian Testing (Xfce) - Fedora 20 - now Windows-free thanks Valve!
Reply With Quote
  #5  
Old 21st November 2010, 06:02 AM
piopio Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

[@localhost ~]$ gnome-shell --replac
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
super(Connection, self).__init__(*args, **kwargs)
Starting dconf-service...
Failed to start /usr/libexec/dconf-service: [Errno 2] No such file or directory
[@localhost ~]$

i did as you told me and this resulted from the terminal. I am not doing this from root.

Tried with root
[root@localhost ]# gnome-shell --replace
Traceback (most recent call last):
File "/usr/bin/gnome-shell", line 753, in <module>
start_dconf_await_service()
File "/usr/bin/gnome-shell", line 129, in start_dconf_await_service
bus = dbus.SessionBus(mainloop=dbus_loop)
File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 219, in __new__
mainloop=mainloop)
File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 108, in __new__
bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 125, in __new__
bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[root@localhost]#

So what is the next step?
Reply With Quote
  #6  
Old 21st November 2010, 06:17 AM
ElderSnake Offline
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 810
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Well I just tested, and it seems you cant start gnome-shell in root. I get the same error if I try in root.

However running gnome-shell --replace works fine. I noticed you missed an 'e' on your first attempt there, perhaps retry the command again. Unless that is just a copy paste typo.

If that doesn't work I am unsure exactly where to go next.
__________________
OS': Arch Linux (Xfce + Kwin) - Debian Testing (Xfce) - Fedora 20 - now Windows-free thanks Valve!
Reply With Quote
  #7  
Old 21st November 2010, 06:22 AM
piopio Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

i tried it with the "e"

and nothing. its the same, i think i just had a message typo.

[@localhost ~]$ gnome-shell --replace
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
super(Connection, self).__init__(*args, **kwargs)
Starting dconf-service...
Failed to start /usr/libexec/dconf-service: [Errno 2] No such file or directory
[@localhost ~]$
Reply With Quote
  #8  
Old 21st November 2010, 06:25 AM
ElderSnake Offline
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 810
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Hmm that's unfortunate. The only other thing I can suggest at the moment is going to the package manager and making sure 'pyGNOME' and its extensions are installed.
__________________
OS': Arch Linux (Xfce + Kwin) - Debian Testing (Xfce) - Fedora 20 - now Windows-free thanks Valve!
Reply With Quote
  #9  
Old 21st November 2010, 06:41 AM
piopio Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

yes, it is installed.

I went into package manager to verify 'pyGNOME' was installed.
Reply With Quote
  #10  
Old 21st November 2010, 06:52 AM
ElderSnake Offline
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 810
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Damn, then I am unsure what else to do

Hopefully someone has a better idea than me, but in the meantime, you said you installed (gnome-shell) in a root user terminal. Did you mean you built it manually (compiled) or did you install it using YUM? If it's just the YUM repo package you could always remove it and reinstall just to be sure, but I'm unsure what all this dconf error is all about.
__________________
OS': Arch Linux (Xfce + Kwin) - Debian Testing (Xfce) - Fedora 20 - now Windows-free thanks Valve!

Last edited by ElderSnake; 21st November 2010 at 06:55 AM.
Reply With Quote
  #11  
Old 21st November 2010, 07:07 AM
piopio Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Yes, it was compiled manually without using yum.
--also--
Thank you, for your time!
------------
I have an idea. What about uninstalling GNOME and Reinstalling it again?!?! or will it damage my system?
Reply With Quote
  #12  
Old 21st November 2010, 07:36 AM
ElderSnake Offline
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 810
linuxfedorafirefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

No problem, though I think I read somewhere compiling it as root can lead to problems. I would at least try reinstalling gnome-shell itself as user.
__________________
OS': Arch Linux (Xfce + Kwin) - Debian Testing (Xfce) - Fedora 20 - now Windows-free thanks Valve!
Reply With Quote
  #13  
Old 21st November 2010, 08:00 AM
tox
Guest
 
Posts: n/a
windows_7firefox
Re: GNOME problem: Failed to start GNOME Shell. Reverting to previous settings.

Quote:
Originally Posted by piopio View Post
Yes, it was compiled manually without using yum.
--also--
Thank you, for your time!
------------
I have an idea. What about uninstalling GNOME and Reinstalling it again?!?! or will it damage my system?
did you get the building instructions from jhbuild over on gnome-shell site? if so i believe a few in the Ubuntu forum are having the same issue by building it.

---------- Post added at 06:58 PM GMT ---------- Previous post was at 06:57 PM GMT ----------

http://ubuntuforums.org/showthread.p...603874&page=21 you might get some ideas from that thread

---------- Post added at 07:00 PM GMT ---------- Previous post was at 06:58 PM GMT ----------

particularly look at this guys posts xtoudi
Reply With Quote
Reply

Tags
failed, gnome, previous, problem, reverting, settings, shell, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F12 gnome-shell problem ris81ryu Using Fedora 3 26th March 2010 03:44 AM
problem with gnome-shell in fedora 12 calanor Using Fedora 3 20th January 2010 03:03 PM
GNOME Shell - Preview of GNOME 3 - Accelerated 3D graphics is not available flokip Fedora 12 Alpha, Beta & Release Candidates 14 29th October 2009 06:21 PM
GNOME 3.0 To Get GNOME Shell Zeitgeist Demz Linux Chat 0 3rd April 2009 12:59 AM
Problem with gnome-settings-daemon brunoadm Using Fedora 0 4th December 2008 06:19 PM


Current GMT-time: 17:13 (Wednesday, 30-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat