Fedora Linux Support Community & Resources Center
  #1  
Old 24th November 2010, 06:01 PM
a_small_cake Offline
Registered User
 
Join Date: Jun 2007
Location: Poland
Posts: 249
linuxfedorafirefox
Virtualbox, no network in Windows 7

Hello,

I'm having problems with setting up network connection inside guest machine. Fedora 14 32 bit is host machine. Windows 7 Enterprise 32 bit is guest machine. I'm virtualizing system with Virtualbox "non-free" edition.

So, Guest Additions are already installed and Windows 7 recognizes network cards (there is no error related to driver etc.). Everything should have worked fine. But it doesn't. I can't manage to establish connection with internet on guest machine and I'm lost.

Have you got any tips for me? Thanks
Reply With Quote
  #2  
Old 24th November 2010, 06:34 PM
kurzer Offline
Registered User
 
Join Date: Jun 2004
Location: Ulm, Germany
Age: 32
Posts: 129
linuxfedorafirefox
Re: Virtualbox, no network in Windows 7

Which type of network did you choose in the VirtualBox configuration? Options are NAT, Networkbridge, internal Network and Host only (names are probably different as I don't use english version).

The easiest way to the internet is using NAT. Usually the guest automatically connects and gets its IP from DHCP.
Reply With Quote
  #3  
Old 24th November 2010, 06:46 PM
a_small_cake Offline
Registered User
 
Join Date: Jun 2007
Location: Poland
Posts: 249
linuxfedorafirefox
Re: Virtualbox, no network in Windows 7

I'm using NAT. I have also tried other configurations but without success. I see icon with yellow triangle saying "no internet access". I remember that about year ago or so, when I had RC version of Windows 7 installed in Virtualbox, I could use internet connection. I have no idea why can't I connect to internet today.

Somebody had posted a message here but it got deleted (don't know why). Here is my lsmod | grep vbox output:

Code:
Module                  Size  Used by
vboxnetadp              5406  0 
vboxnetflt             12993  0 
vboxdrv               153590  2 vboxnetadp,vboxnetflt
I have just installed Ubuntu 10.10 on the very same Virtualbox. Network works "out-of-the-box". So, is it some issue with kernel, maybe? At least I'm sure that my Virtualbox installation and configuration is valid. But still I have no idea why network in Windows 7 would not work.

My bad. It doesn't work in any system

This is how it looks like:
http://img52.imageshack.us/img52/7973/zrzutekranu0.png

Help? Anyone?

Last edited by a_small_cake; 28th November 2010 at 01:22 PM.
Reply With Quote
Reply

Tags
network, virtualbox, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VirtualBox Network Bridge (Windows XP Host) m@! Servers & Networking 3 15th August 2010 11:11 PM
Virtualbox with Windows 7 Shaggakhanz Using Fedora 3 29th July 2010 02:29 PM
iNSTALL FEDORA12 IN WINDOWS USING SUN VIRTUALBOX tharmen Installation, Upgrades and Live Media 0 28th January 2010 04:40 PM
How to access Windows on VirtualBox from Fedora htdat Using Fedora 6 12th August 2009 01:44 AM
virtualbox ose and network shabakeh Using Fedora 1 1st July 2009 05:53 AM


Current GMT-time: 04:20 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat