Fedora Linux Support Community & Resources Center
  #1  
Old 26th November 2010, 07:19 AM
kideltn Offline
Registered User
 
Join Date: Nov 2010
Posts: 4
linuxchrome
Can't ping on Fedora 10 affer config NAT iptables

Currently,i use Fedora 10 and get a follow trouble :
My network:
route(10.11.10.2/24)----eth0----(10.11.10.105/24)Fedora10(172.16.239.1/24)----vmnet0----(172.16.239.2/24)Virtual Machine XP2.
I used : Vmware 6.5.1,Virtual Machine : Window XP SP2.
, iptable 1.4.1.1
I set up static ip on the machines:
Fedora:
NIC eth0: IP:10.11.10.105/24
GW:10.11.10.2
DNS:8.8.8.8
NIC vmnet0:
IP:172.16.239.1/24
On Fedora,i connected Internet ok !
Virtual machine XP:
NIC vmnet0:
IP:172.16.239.2/24
GW:172.16.239.1
DNS:8.8.8.8


Next,I have configured iptables as follows:
#delete all rules in nat,filter table
iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
#build nat rules
iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
iptables --append FORWARD --in-interface vmnet0 -j ACCEPT
# Enables packet forwarding by kernel
echo 1 > /proc/sys/net/ipv4/ip_forward
# restart iptables
service iptables restart

Finally,I proceed test from Virtual machine :
ping 172.16.239.1 --->OK
ping 10.11.10.2 --->failed

Please helped me ! I delayed here for a long time...
Thanks in advanced !
Reply With Quote
  #2  
Old 26th November 2010, 09:10 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,698
linuxredhatfirefox
Re: Can't ping on Fedora 10 affer config NAT iptables

Moved to EOL (End Of Life) Versions.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
Reply

Tags
affer, config, fedora, iptables, nat, ping

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables masquerade, can ping but no http access... ACiD GRiM Security and Privacy 17 15th December 2009 02:13 AM
trying to set iptables to deny ping requests Thaidog Security and Privacy 1 4th February 2009 11:29 PM
GUI iptables "apply" differes from boot config - iptables config files load order? anocelot Security and Privacy 3 23rd August 2008 06:06 AM
command #service iptables save changed the original config of iptables kesavulur Security and Privacy 0 28th November 2007 06:33 AM
nothing but ping when using iptables and nat tkw_fo Security and Privacy 1 22nd May 2005 04:50 AM


Current GMT-time: 18:40 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat