Fedora Linux Support Community & Resources Center
  #1  
Old 12th December 2010, 08:51 PM
kyuso Offline
Registered User
 
Join Date: Jul 2004
Posts: 212
linuxfedorafirefox
controlling audio front and back ports

My system:
Fedora 14 x86_64
kernel 2.6.35.9-64.fc14.x86_64
built-in audio ATI HDA-Intel SB in ASUS AM3VM2-HDMI MB
Two sets of speakers, one in back audio port (call it BS), one in front audio jack (call it FS)

My problem:
No sound from left of BS (BS_L), and no sound from right of FS (FS_R).
Only BS_R and FS_L have sound, and they are in stereo, so correct sound from the appropriate sides, but not in same pair.

Observation:
BIOS setting has front panel audio set as AC97, not HD-Audio. I tried both and no difference.

I tested both speakers in other PCs and other speakers on this PC, so no problem with speakers or wires.

I suspect some internal audio hardware mixer control needs setting. I tried pavucontrol, alsamixer -c 0, but none of them shows any way of controlling the front and back ports separately.

When selecting 'Analog headphone' from pavucontrol or gnome-volume-control, no sound comes out of either ports. Only 'Analog output' creates any sound.

So the question:
  1. Is there a way to fix this using software?
  2. Is my internal audio mixing circuitry broken?
  3. Jack auto-detect not working (the manual says it can auto-detect what is being connected)?
  4. Does the kernel not support this?

I don't use this PC often, and I only remember having it working in Fedora 11. Probably worked in Fedora 14 before, but not sure.

Another observation if that helps:
If I disconnect BS a little while, and reconnect, BS_L also has sound, although slitghty lower volume than BS_R. The moment I connect FS, or after a while, then BS_L goes out (there is a little very faint cracking as if trying to come out, but sound never materializes). The FS_L has no such short-term luck in any way.
No solution if I disconnect the internal wires from motherboard to front audio jack either.

Last edited by kyuso; 12th December 2010 at 09:02 PM.
Reply With Quote
  #2  
Old 13th December 2010, 10:30 PM
Tweedle Offline
Registered User
 
Join Date: Dec 2010
Posts: 1
linuxfedorafirefox
Re: controlling audio front and back ports

PulseAudio is what's causing the problem. I have an ATI IXP onboard chipset that gives me a Radeon Xpress 200M/G and a Realtek -something or another- surround sound card. I have been testing out A LOT of linux distros just to find one that works correct and suites my needs. I've been through ubuntu, ubuntu studio w/ realtime kernel, openMamba 1.1 and 2, puredyne, 64studio, and a few others that gave me the same type of problems. Either no surround channels, or center/lfe, a bunch of interference, or completly wrong channels routed. EVERY single time I was to make any progress, it wasn't until after I set linux to use ALSA instead of Pulse, or complete disabled pulse (which was the best results)

This I'm working on right now in Fedora. From what I can tell, this is going to be the keeper for me. Not only is it running smoothly right after a fresh install (most distros don't run this well) but right off the bat pulse allowed me to hear my center channel and subwoofer. The weren't in the right place though (center came from rear left) So I am going to remove pulse, because it sux IMO, and go with straight alsa for now.

I have done this once before successfully in ubuntu, but that guided you towards OSS instead of alsa. But the basic principle is the same: kill pulseaudio with beaver's tail!!

I will start the process now, which is a little more than just removing pulse - don't do that! You have to disable it while keeping some basic stuff intact. I will post on my progress in a few and let you know how it's going in fedora
Reply With Quote
  #3  
Old 21st December 2010, 10:18 AM
kyuso Offline
Registered User
 
Join Date: Jul 2004
Posts: 212
linuxfedorafirefox
Re: controlling audio front and back ports

Thank you for the info. I hate to do away with pulseaudio though. It's so promising and has worked fine so far, except for the wrong channels.

I guess I'll just listen to one speaker until it improves then.
Reply With Quote
Reply

Tags
audio, controlling, ports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MythTV front/back end video card KirkD Using Fedora 0 4th December 2010 11:43 PM
Dual audio output ports, only one seen. donk64 Hardware & Laptops 0 16th February 2010 02:42 AM
HP Pavilion front & back jack sound combined Minnek Hardware & Laptops 0 3rd August 2009 12:33 PM
Audio, Front output is always muted Lazze2k5 Using Fedora 5 23rd June 2009 06:50 AM


Current GMT-time: 04:31 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram