Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Other Versions > EOL (End Of Life) Versions
FedoraForum Search

Forgot Password? Join Us!

EOL (End Of Life) Versions This is a Forum to discuss problems and workarounds for versions of Fedora that have passed End of Life.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 23rd January 2011, 04:28 AM
igotadose Offline
Registered User
 
Join Date: Sep 2009
Posts: 3
linuxfedorafirefox
Printing from FC11 to Windows7: SPNEGO login failed invalid parameter

I am running FC11. Samba config as follows:
samba-client-3.4.7-0.50.fc11.i586
samba-common-3.4.7-0.50.fc11.i586
system-config-samba-1.2.76-1.fc11.noarch
samba-3.4.7-0.50.fc11.i586
samba-winbind-3.4.7-0.50.fc11.i586
system-config-samba-docs-1.0.6-1.fc11.noarch
smbd and nmbd are working, though they weren't auto started. I don' know if that matters, but I started them manually.

I want to print to an HP directly attached to a windows 7 system.

I am using KDE and attempts to use the 'add printer' via 'windows network printer via samba' get me to the windows 7 client, which prompts me for a password.

I have an account on the windows 7 system, and have enabled the guest account there as well.

However, login attempts failed no matter what account I use or passwords.

Here is the output from 'smbclient' when I try to list the config as 'matt' (my login on the windows7 box):
#smbclient -L //sphene
Enter matt's password:
session setup failed: SUCCESS - 0

If I try this without entering a password, I do get some information:

#smbclient -L //sphene
Enter matt's password:
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows 7 Professional 7600] Server=[Windows 7 Professional 6.1]

Sharename Type Comment
--------- ---- -------
Error returning browse list: NT_STATUS_ACCESS_DENIED
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows 7 Professional 7600] Server=[Windows 7 Professional 6.1]

Server Comment
--------- -------
SPHENE

Workgroup Master
--------- -------
MYGROUP FAFNIR
WORKGROUP SPHENE


If I run smbclient with a higher debug level, there's some interesting message about SPNEGO in the output
Doing spnego session setup (blob length=336)
SPNEGO login failed: Invalid parameter
session setup failed: SUCCESS - 0
So, my question is:

What account should I use when trying to add the printer via System->Administration->Printers?

matt doesn't work (with or without a password)
I tried guest with no password, still no luck.

It seems like the FC11 system (Fafnir) and the win7 system are communicating, but the invalid parameter might be the crux of the problem.


Thanks
Reply With Quote
  #2  
Old 23rd January 2011, 04:40 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Re: Printing from FC11 to Windows7: SPNEGO login failed invalid parameter

Moved to EOL (End Of Life) Versions
Reply With Quote
Reply

Tags
failed, fc11, invalid, login, parameter, printing, spnego, windows7

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC11 in a Windows7 Virtual PC? slimedog1 Installation, Upgrades and Live Media 8 20th October 2009 02:18 PM
device-mapper: reload ioctl failed: Invalid argument Failed to suspend LogVol00 HughB Using Fedora 3 15th October 2009 09:12 PM
FC11: Invalid VPN secrets... Emittim3 Servers & Networking 0 20th July 2009 03:33 PM
firmware failed to load after modifying some kernel parameter thaiha Servers & Networking 3 11th July 2006 01:06 AM


Current GMT-time: 05:54 (Friday, 22-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat