Fedora Linux Support Community & Resources Center
  #1  
Old 14th March 2011, 10:19 AM
libregeek Offline
Registered User
 
Join Date: Oct 2005
Posts: 22
linuxfedorafirefox
Preupgrade fails to install

I tried to upgrade F14 to F15(alpha) through preupgrade. After rebooting the machine, I got the following error message and installation aborted abnormally:

No method given for cmdline mode, aborting.
Press CTRL+C ....

I'm using Intel 64 bit processor and F14 is running on LVM. Please help.
__________________
http://libregeek.blogspot.com
  #2  
Old 14th March 2011, 11:03 AM
tsorvoja Offline
Registered User
 
Join Date: Jul 2004
Location: Finland
Age: 34
Posts: 380
windows_7firefox
Re: Preupgrade fails to install

I don't recommend upgrading to F15 yet if planning to use it in everyday desktop use. Try it after official release. 2 weeks ago F15 was quite "alpha" (at least for me).
  #3  
Old 14th March 2011, 11:10 AM
tox
Guest
 
Posts: n/a
linuxfirefox
Re: Preupgrade fails to install

Quote:
Originally Posted by libregeek View Post
I tried to upgrade F14 to F15(alpha) through preupgrade. After rebooting the machine, I got the following error message and installation aborted abnormally:

No method given for cmdline mode, aborting.
Press CTRL+C ....

I'm using Intel 64 bit processor and F14 is running on LVM. Please help.
if i were you i'd wait for the Beta, it has some quirks in it which should be fixed by beta if not final , dont be surprised if the beta is delayed though
  #4  
Old 14th March 2011, 11:15 AM
libregeek Offline
Registered User
 
Join Date: Oct 2005
Posts: 22
linuxfedorafirefox
Re: Preupgrade fails to install

It's just a test drive. Curious about the new features and I would like to participate in testing F15.
__________________
http://libregeek.blogspot.com

Last edited by libregeek; 14th March 2011 at 11:18 AM.
  #5  
Old 14th March 2011, 11:31 AM
tox
Guest
 
Posts: n/a
linuxfirefox
Re: Preupgrade fails to install

Quote:
Originally Posted by libregeek View Post
It's just a test drive. Curious about the new features and I would like to participate in testing F15.
well i would make a New partition and install F15 on that and dualboot between F14 an F15 , but i would be making a New clean install of F15, do not use preUpGrade
  #6  
Old 14th March 2011, 11:34 AM
tsorvoja Offline
Registered User
 
Join Date: Jul 2004
Location: Finland
Age: 34
Posts: 380
windows_7firefox
Re: Preupgrade fails to install

I suggest that you wait for test release and install it from there (also do the testing with it). Testing should be always done with clean test version to get "coherent" test results.
  #7  
Old 14th March 2011, 12:13 PM
libregeek Offline
Registered User
 
Join Date: Oct 2005
Posts: 22
linuxfedorafirefox
Re: Preupgrade fails to install

Thanks for the advise. But I think we are going off the track. PreUpgrade is also a part of Fedora, so it should also be tried, right?
__________________
http://libregeek.blogspot.com
  #8  
Old 14th March 2011, 12:45 PM
pforsell Offline
Registered User
 
Join Date: Mar 2011
Posts: 39
linuxchrome
Re: Preupgrade fails to install

Quote:
Originally Posted by tsorvoja View Post
Yes, of course. But for F15 testing e.g. http://forums.fedoraforum.org/showthread.php?t=259893 the livecd version is recommended. This is to make sure that the F15 under test is similar in every test. For your own personal tests preupgrade is ok.
And exactly how you test the working of preupgrade with a livecd?
__________________
My posts are a work of fiction. Everything I write is an opinion, a joke, or both. Do not follow my advice.

F14: Dell Latitude D630 Core2Duo 2GHz 4GB
F14 x64: HP i7 3GHz 12GB
#317797
  #9  
Old 14th March 2011, 02:19 PM
tsorvoja Offline
Registered User
 
Join Date: Jul 2004
Location: Finland
Age: 34
Posts: 380
windows_7firefox
Re: Preupgrade fails to install

Yes, of course. But for F15 testing e.g. http://forums.fedoraforum.org/showthread.php?t=259893 the livecd version is recommended. This is to make sure that the F15 under test is similar in every test. For your own personal tests preupgrade is ok.

---------- Post added at 03:53 PM ---------- Previous post was at 03:37 PM ----------

But back to the issue. F15 might be broken that way that pre-upgrade won't work properly. I'd wait till Beta or final. Or just use LiveCD in VM.

---------- Post added at 05:19 PM ---------- Previous post was at 03:53 PM ----------

pforsell: you don't.
  #10  
Old 15th March 2011, 09:09 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfirefox
Re: Preupgrade fails to install

We have a preupgrade test day coming up Thursday - https://fedoraproject.org/wiki/Test_...-17_Preupgrade

if you could come along to that and help test it'd be great, thanks. I hope we'll have something that's a bit closer to working available for test at that point...
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
  #11  
Old 17th March 2011, 07:56 PM
roger Offline
Registered User
 
Join Date: Aug 2004
Posts: 105
linuxfedorafirefox
Re: Preupgrade fails to install

googling around, i found this bug already existed on preupgrade from f10 to f11?

Roger

---------- Post added at 07:56 PM ---------- Previous post was at 07:56 PM ----------

sorry, forgot the link:

http://lists.fedoraproject.org/piper...er/086977.html
 

Tags
fails, install, preupgrade

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade F12 to F14 fails using preupgrade holdea Installation, Upgrades and Live Media 5 27th November 2010 12:32 AM
preupgrade F11->F12 fails? mps2006 Installation, Upgrades and Live Media 1 2nd April 2010 09:20 AM
Preupgrade F9 -> F12 fails with Parsing primary.xml error ttoth Installation, Upgrades and Live Media 5 16th December 2009 12:10 AM
Preupgrade to F12 fails Shielder Installation, Upgrades and Live Media 2 19th November 2009 08:29 PM
preupgrade reboot to rawhide from F10 fails to recognize / FS marko Alpha, Beta & Snapshots Discussions (Fedora 11 Only) 2 28th January 2009 10:10 PM


Current GMT-time: 18:55 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat