Fedora Linux Support Community & Resources Center
  #1  
Old 16th April 2011, 03:48 AM
Doug Hutcheson Offline
Registered User
 
Join Date: Jun 2009
Location: Queensland
Posts: 164
linuxfedorafirefox
Internal modem Lenovo T61 FC14 x86_64

Folks,

I am keen to get the internal modem working on my notebook, so I can set up faxing and dial-up internet access.

I have failed to get it working by using the Linuxant alsa-driver-linuxant and hsfmodem packages, but that may be because I am doing something wrong.

alsamixer on my system tells me I have CARD: HDA Intel and CHIP: Analog Devices AD1984.

I have these devices in /dev, which appear to be candidates for modem operation:
Code:
[doug@cardraeh Modem]$ ls -l /dev/ttyS*
crw-rw---- 1 root dialout 4, 64 Apr 16 11:40 /dev/ttyS0
crw-rw---- 1 root dialout 4, 65 Apr 16 11:40 /dev/ttyS1
crw-rw---- 1 root dialout 4, 66 Apr 16 11:40 /dev/ttyS2
crw-rw---- 1 root dialout 4, 67 Apr 16 11:40 /dev/ttyS3
[doug@cardraeh Modem]$
scanModem (a modem detection script by Marv Stodolsky) reports
Code:
 Potentially useful modem drivers now loaded are:
       snd_hda_intel
and
Code:
Candidate PCI devices with modem chips are:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
High Definition Audio cards can host modem chips.

For candidate card in slot 00:1b.0, firmware information and bootup diagnostics are:
 PCI slot       PCI ID          SubsystemID     Name
 ----------     ---------       ---------       --------------
 00:1b.0        8086:284b       17aa:20ac       Audio device: Intel Corporation 82801H 

 Modem interrupt assignment and sharing: 
 48:        556        536   PCI-MSI-edge      hda_intel
 --- Bootup diagnostics for card in PCI slot 00:1b.0 ----
[    0.194623] pci 0000:00:1b.0: reg 10: [mem 0xfe220000-0xfe223fff 64bit]
[    0.194696] pci 0000:00:1b.0: PME# supported from D0 D3hot D3cold
[    0.194702] pci 0000:00:1b.0: PME# disabled
[   17.630630] HDA Intel 0000:00:1b.0: PCI INT B -> GSI 17 (level, low) -> IRQ 17
[   17.630841] HDA Intel 0000:00:1b.0: irq 48 for MSI/MSI-X
[   17.630881] HDA Intel 0000:00:1b.0: setting latency timer to 64
This does not mean a whole lot to me, but I think it indicates that FC14 has recognised that I have modem capability.

My question is: how do I go about setting up dial-out functionality on my system? I thought wvdialconf would recognise if a modem existed, but it reports:
Code:
[doug@cardraeh Modem]$ wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<Info>: Device or resource busy
Modem Port Scan<*1>: S0   
ttyS1<Info>: Device or resource busy
Modem Port Scan<*1>: S1   
ttyS2<Info>: Device or resource busy
Modem Port Scan<*1>: S2   
ttyS3<Info>: Device or resource busy
Modem Port Scan<*1>: S3   


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?
setserial warns:
Code:
CAUTION: Using an invalid port can lock up your machine!
Not wanting to lock up my machine <grin>, I have come here for help before I start mucking around with anything.

Cheers,
Doug
Reply With Quote
  #2  
Old 16th April 2011, 04:18 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,799
linuxfedorafirefox
Re: Internal modem Lenovo T61 FC14 x86_64

Here,
http://www.thinkwiki.org/wiki/ThinkP..._%28MDC-1.5%29
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #3  
Old 16th April 2011, 06:12 AM
Doug Hutcheson Offline
Registered User
 
Join Date: Jun 2009
Location: Queensland
Posts: 164
linuxfedorafirefox
Re: Internal modem Lenovo T61 FC14 x86_64

Quote:
Originally Posted by stevea View Post
That is interesting. The module listed is for SUSE Linux and is described as useful for the T60, which is not exactly my configuration. On the other hand, the module is, at heart, hsfmodem from Linuxant. For that reason, I installed the latest copy of hsfmodem which I downloaded yesterday. Now, I have /dev/modem and /dev/ttySHSF0 to SHSF7.

Now, 'sudo minicom' fires up the comms package and appears to initialise the modem ok:
Code:
Welcome to minicom 2.5                                                                                 
                                                                                                       
OPTIONS: I18n                                                                                          
Compiled on Feb 24 2011, 11:25:53.                                                                     
Port /dev/modem                                                                                        
                                                                                                       
Press CTRL-A Z for help on special keys
However, wvdialconf is not happy:
Code:
[doug@cardraeh Modem]$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: Scanning ttySHSF0 first, /dev/modem is a link to it.
Modem Port Scan<*1>: SHSF0 S0   S1   S2   S3   SHSF1 SHSF2 SHSF3 
Modem Port Scan<*1>: SHSF4 SHSF5 SHSF6 SHSF7 


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://alumnit.ca/wiki/?WvDial
[doug@cardraeh Modem]$
I have not run setserial, as I am not sure of the appropriate settings for a soft-modem. I will try connecting the telephone jack to my phone line and see if that improves matters: perhaps the modem driver needs to 'hear' a dial tone before it works.

I am not happy with running these things as root, but they don't work when run as a user.
Code:
[doug@cardraeh Modem]$ minicom
Device /dev/modem access failed: Permission denied.
[doug@cardraeh Modem]$ wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: Scanning ttySHSF0 first, /dev/modem is a link to it.
ttySHSF0<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF0 
ttyS0<Info>: Device or resource busy
Modem Port Scan<*1>: S0   
ttyS1<Info>: Device or resource busy
Modem Port Scan<*1>: S1   
ttyS2<Info>: Device or resource busy
Modem Port Scan<*1>: S2   
ttyS3<Info>: Device or resource busy
Modem Port Scan<*1>: S3   
ttySHSF1<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF1 
ttySHSF2<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF2 
ttySHSF3<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF3 
ttySHSF4<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF4 
ttySHSF5<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF5 
ttySHSF6<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF6 
ttySHSF7<Info>: Device or resource busy
Modem Port Scan<*1>: SHSF7 


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://alumnit.ca/wiki/?WvDial
[doug@cardraeh Modem]$
Anyway, your input has caused me to get further than I have before, in that I do at least have a /dev/modem and some ttySHFS devices, so I am getting somewhere. I will keep plugging away ... "8-\

Cheers,
Doug
Reply With Quote
  #4  
Old 16th April 2011, 06:51 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,799
linuxfedorafirefox
Re: Internal modem Lenovo T61 FC14 x86_64

When you connect with minicom, and you type an "AT" command does the modem respond with "OK" ?


Quote:
The Linuxant hsf driver

The commercial Conexant HSF driver from Linuxant supports these modem and work also on ICH6 models (e.g., ThinkPad R52, R51, T43, and Z60m).

It offers free limited evaluation at 14.4kbps,
So the free version is slow.

I suggest you follow the Suse link back to the Lenovo site and get the rpm file.

sudo yum --nogpgcheck localinstall ./l7km01us.rpm

It installs and *seems* to work under F14.
You'll want the install the 'kernel-devel' package since hfsconfig builds the driver.

Read ... /usr/share/doc/hsfmodem-7.68.00.01oem/FAQ for more info
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe

Last edited by stevea; 16th April 2011 at 06:54 AM.
Reply With Quote
  #5  
Old 16th April 2011, 07:55 AM
Doug Hutcheson Offline
Registered User
 
Join Date: Jun 2009
Location: Queensland
Posts: 164
linuxfedorafirefox
Re: Internal modem Lenovo T61 FC14 x86_64

Quote:
Originally Posted by stevea View Post
When you connect with minicom, and you type an "AT" command does the modem respond with "OK" ?
No - I am getting no response at all. Even with local echo toggled on, I see no keystrokes.

Quote:
So the free version is slow.
Yes - 14400. I assumed the SUSE package to be the same - silly me!

Quote:
I suggest you follow the Suse link back to the Lenovo site and get the rpm file.
Will do and thanks for the heads-up.

Later: The module is, apparently, for the 386 architecture, which may be the source of my problem, Also, the yum install reported:
Code:
Transaction Test Succeeded
Running Transaction
  Installing     : hsfmodem-7.68.00.01oem-1.i386                                                                                       1/1 
Non-fatal POSTIN scriptlet failure in rpm package hsfmodem-7.68.00.01oem-1.i386
Removing old /etc/hsfmodem
Conexant HSF softmodem driver, version 7.68.00.01oem

If you need assistance or more information, please go to:
	http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Fedora-14 linux-2.6.35.12-88.fc14.x86_64 x86_64-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

WARNING: the kernel version () defined in
/lib/modules/2.6.35.12-88.fc14.x86_64/build/include/linux/version.h
does not match the currently running kernel (2.6.35.12-88.fc14.x86_64)
The cause of this problem is an incorrect kernel source path.
Please check that /lib/modules/2.6.35.12-88.fc14.x86_64/build points to the right tree.
The cause of this is usually a missing or unconfigured
kernel source tree (and sometimes an incorrect directory or symbolic link).

However, proper /boot/config-2.6.35.12-88.fc14.x86_64 was found.

Unable to prepare temporary kernel tree

First, ensure that the proper kernel source and compiler packages
from your distribution vendor and/or the community are installed.

The Linux kernel can then be reconfigured by running "make menuconfig"
under the kernel source directory (usually /usr/src/linux).

Verify that the proper options for your system are selected.

Then compile and install your new kernel (for more information about
this procedure, see the README file under the kernel source directory),
reboot the system using the new kernel, and re-run "hsfconfig".
warning: %post(hsfmodem-7.68.00.01oem-1.i386) scriptlet failed, exit status 124

Installed:
  hsfmodem.i386 0:7.68.00.01oem-1                                                                                                          

Complete!
[doug@cardraeh Downloads]$
The install failed and I had no /dev/modem or /dev/ttySHSF* devices.

I uninstalled this and reinstalled the package I got from Linuxant, which may be speed limited but does correctly identify my architecture and gives me /dev/modem and /dev/ttySHSF[0-7] devices. Still doesn't get any response under minicom, which initialises at 115200/n/8/1. Plugging in the telephone cord does not help either. hsfconfig reports:
Code:
[doug@cardraeh Downloads]$ sudo hsfconfig
Conexant HSF softmodem driver, version 7.80.02.06x86_64full

If you need license keys, assistance or more information, please go to:
	http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

Warning: existing driver modules found under:
	/lib/modules/2.6.35.12-88.fc14.x86_64/
Would you like to keep using them? [no] y

Warning: no device detected by hsf driver - HDA modems may require reboot

Note: HDA support not compiled in the driver

Note: kernel module snd-via82xx-modem overridden by hsfmc97via
Note: kernel module snd-intel8x0m overridden by hsfmc97ich hsfmc97sis
Note: kernel module snd-atiixp-modem overridden by hsfmc97ati
Is there anything else I need to be doing?

Cheers,
Doug

Last edited by Doug Hutcheson; 17th April 2011 at 12:09 AM. Reason: Corrected initialisation speed
Reply With Quote
  #6  
Old 15th September 2011, 08:49 AM
Doug Hutcheson Offline
Registered User
 
Join Date: Jun 2009
Location: Queensland
Posts: 164
linuxfirefox
Re: Internal modem Lenovo T61 FC14 x86_64

Problem passed to Linuxant support.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] nVidia driver for new kernel 2.6.35.12-88.fc14.x86_64 ? Doug Hutcheson Using Fedora 4 12th April 2011 11:51 PM
Lenovo Thinkpad T410 + FC14 go3mon Hardware & Laptops 4 31st March 2011 09:17 PM
An advice on Partitioning Scheme FC14 x86_64 wprauchholz Installation, Upgrades and Live Media 5 22nd December 2010 05:42 PM
[SOLVED] FC14 x86_64 Happauge DVB-T not recognised g8jvm Hardware & Laptops 4 7th November 2010 09:05 PM
Fedora x86_64 on a Lenovo T61 ciphermonk Hardware & Laptops 102 15th March 2009 12:01 AM


Current GMT-time: 10:27 (Saturday, 30-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat