Fedora Linux Support Community & Resources Center
  #1  
Old 26th May 2011, 03:37 AM
Jay See II Offline
Registered User
 
Join Date: Oct 2009
Posts: 12
linuxfirefox
Connecting Wired Connection Fedora 15

Everyone,
Figured out a straight shot at connecting to the Internet in Fedora 15. Follow these commands.

1.)****** SWITCH TO ROOT USER if you don't have privileges*******

2.) cd /etc/sysconfig/network-scripts
3.) rm ifcfg-XXXXX (DO NOT REMOVE THE IFCFG-LO)
4.) system-config-network
-> Once in this screen, press the enter key on "Device configuration"
-> Configure your network statically. ( I did the following.)
Name: leave as default
Device: Leave as default
DESELECT "Use DHCP"
Set Static IP as 192.168.2.117 (or 192.168.1.117)
Set NetMask as 255.255.255.0
Set "Default Gateway IP" AND "Primary DNS Server" to 192.168.2.1 (or 192.168.1.1)

tab through and click "OK"
tab through on the next screen and select "Save."
tab through on the next screen and select "Save and Quit."

type ifconfig, and take notice of the information for the p13p1 section, PARTICULARLY the HWaddr!!!!

5.) Minimize the terminal

6.) In the upper left hand corner, click Applications>Other>NetworkConnections

Once the pop-up has opened, type in your MAC address in the "Device MAC Address" field. You got this information when you typed in "ifconfig" in the terminal CLICK SAVE.


In the upper left hand corner of the desktop, click Applications>Internet>Firefox.

Happy Surfing at this point.

I really hope this helps all of you trying to get through this debacle!

Jay See II
Reply With Quote
  #2  
Old 26th May 2011, 01:29 PM
December Offline
Registered User
 
Join Date: Mar 2005
Posts: 138
linuxfedorafirefox
Re: Connecting Wired Connection Fedora 15

Err..? These instructions are very specifically for your network, and are highly unlikely to work for anyone else.

How can it be 192.168.2.x OR 192.168.1.X, wouldn't that depend on the local network (ie. How the router is configure). On virtually every home router and many direct modem connections, STATIC IP is not the correct settings, but DHCP is.

If I was to follow your instructions, my computer would absolutely not be able to connect to the internet any longer.

In addition, it's shouldn't be necessary to delete system files from a root-privileged terminal in order to get onto the internet, that's never a good idea!
Reply With Quote
  #3  
Old 26th May 2011, 05:28 PM
Jay See II Offline
Registered User
 
Join Date: Oct 2009
Posts: 12
windows_7firefox
Re: Connecting Wired Connection Fedora 15

"These instructions are very specifically for your network, and are highly unlikely to work for anyone else."

December,

You are right, I should have clarified a bit. In the U.S., most routers and/or modems fit a 192.168.x.x scheme.

In my case, my modem is 192.168.1.x. My router is 192.168.2.x. I chose 192.168.2.117 just by random chance because my network has only five machines connected. As far as the file I had said to delete, I found in my case this was the roadblock that was stopping me from connecting. (I actually got this info from another forum. Unfortunately I do not have the URL.) Right "out of the box", my Qosmio would not connect and I needed to take these measures to connect.

Can anyone else verify that these instructions work or is there another workaround?

Thanks, Jay See II
Reply With Quote
  #4  
Old 27th May 2011, 12:04 AM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
linuxfirefox
Re: Connecting Wired Connection Fedora 15

Deleting the ifcfg-xxx files in network-scripts is not a good idea for a fairly new user. Like December mentioned most routers are set up for DHCP to allow minimum configuration on the users part. If for some reason NM is causing issues i.e not recognizing a device and isn't shown under "network settings" then use the "network connections" applet under applications / other. Check the wired and wireless tabs and verify if the devices are listed. If they are click the edit button and double check the settings. If they are not listed click the add button and put in the mac address and see if they are found. If Fedora can not find them, then you have a driver issue and might have to hunt for linux driver for the device.
Reply With Quote
  #5  
Old 24th July 2011, 04:29 AM
oktubre Offline
Registered User
 
Join Date: Jan 2011
Posts: 1
linuxsafari
Re: Connecting Wired Connection Fedora 15

Quote:
Originally Posted by Jay See II View Post
[FONT="Impact"]
Can anyone else verify that these instructions work or is there another workaround?
It works!

Thanks!!!
Reply With Quote
Reply

Tags
connecting, connection, fedora, wired

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wired networking not connecting in Fedora 12 with Windows Internet Connection Sharing LinuxLearner123 Servers & Networking 7 16th January 2011 10:01 PM
DHCP lease renewal failing on Fedora 12 wired ethernet connection JohnP789 Servers & Networking 5 11th August 2010 01:22 AM
HowTo:Install Fedora 12 on PS3 without a wired connection stikboy73 Mac Chat 2 21st March 2010 10:37 PM
Wired connection eth0 problem on fedora core 10 naveed784 EOL (End Of Life) Versions 1 14th February 2010 07:19 PM
problems connecting to 'wired' network grandpa2390 Servers & Networking 6 17th June 2008 07:52 PM


Current GMT-time: 08:27 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Crawfordsville Photos on Instagram - Damoh - Novovolynsk Travel Photos on Instagram