Fedora Linux Support Community & Resources Center
  #1  
Old 28th June 2011, 05:05 AM
andyzhu35 Offline
Registered User
 
Join Date: May 2011
Posts: 26
linuxfirefox
F15 Gnome 3: disable top right corner effect

Really get annoyed when mouse is moved to the top right corner then the window is switched to the application view/chooser. I want to get rid of this effect and modified following key in gconf-editor as suggested in http://www.fedoraforum.org/forum/sho....php?t=217693:

apps/compiz/plugins/scale/allscreens/option, change initiate_edge from TopRight to None. but nothing happens on the effect. The top right corner effect still there.

How to disable this top right corner effect?

Thank you.
Reply With Quote
  #2  
Old 28th June 2011, 09:43 PM
cymbaline42 Offline
Registered User
 
Join Date: May 2011
Posts: 165
linuxopera
Re: F15 Gnome 3: disable top right corner effect

There is an extension that does this.

Open 'Add/Remove software' and search for 'gnome-shell-extension-noripple' and install it. You may have to log out and log back in for it to take effect.
Reply With Quote
  #3  
Old 28th June 2011, 09:50 PM
ElderSnake Offline
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 818
windows_7chrome
Re: F15 Gnome 3: disable top right corner effect

Hi, yes you'll have to use the aforementioned extension.

Gnome 3/Gnome-Shell doesn't use Compiz so the gconf-editor fixes won't work
__________________
OS': Arch Linux (Xfce + Kwin) - Debian Testing (Xfce) - Fedora 20 - now Windows-free thanks Valve!
Reply With Quote
  #4  
Old 28th June 2011, 10:19 PM
andyzhu35 Offline
Registered User
 
Join Date: May 2011
Posts: 26
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

yes, thanks.

Yum install and reboot. But the corner effect is still there. Is there any configuration to twist around?

Last edited by andyzhu35; 28th June 2011 at 11:46 PM.
Reply With Quote
  #5  
Old 30th June 2011, 09:45 AM
alfatal Offline
Registered User
 
Join Date: Oct 2007
Location: Nazareth
Posts: 46
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

gnome-shell-extension-noripple only disables the ripple animation yet the "top right corner effect" is still active...
Reply With Quote
  #6  
Old 30th June 2011, 11:00 AM
mightymouse2045 Offline
Registered User
 
Join Date: Dec 2010
Posts: 124
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

Quote:
Originally Posted by andyzhu35 View Post
Really get annoyed when mouse is moved to the top right corner then the window is switched to the application view/chooser. I want to get rid of this effect and modified following key in gconf-editor as suggested in http://www.fedoraforum.org/forum/sho....php?t=217693:

apps/compiz/plugins/scale/allscreens/option, change initiate_edge from TopRight to None. but nothing happens on the effect. The top right corner effect still there.

How to disable this top right corner effect?

Thank you.
Um are you talking about the top left corner effect or definitely the top right corner?
Reply With Quote
  #7  
Old 30th June 2011, 12:25 PM
alfatal Offline
Registered User
 
Join Date: Oct 2007
Location: Nazareth
Posts: 46
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

I assume he's talking about the top left corner... else ripples wouldn't make any sense..
Reply With Quote
  #8  
Old 30th June 2011, 12:57 PM
mightymouse2045 Offline
Registered User
 
Join Date: Dec 2010
Posts: 124
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

Quote:
Originally Posted by alfatal View Post
I assume he's talking about the top left corner... else ripples wouldn't make any sense..
Yet he seems adamant about it being in the top right - the reason i ask is perhaps he has the extension to add a hotspot in the right corner, although I don't think there is a ripple effect for the top right corner extension hotspot :P
Reply With Quote
  #9  
Old 30th June 2011, 02:33 PM
fpmurphy Offline
Registered User
 
Join Date: May 2009
Location: /dev/ph
Posts: 314
windows_7firefox
Re: F15 Gnome 3: disable top right corner effect

Quote:
Yet he seems adamant about it being in the top right - the reason i ask is perhaps he has the extension to add a hotspot in the right corner, although I don't think there is a ripple effect for the top right corner extension hotspot
If the OP is using my extension, there is an option (SHOW_RIPPLE) to either show a ripple effect or not.
Reply With Quote
  #10  
Old 30th June 2011, 03:30 PM
andyzhu35 Offline
Registered User
 
Join Date: May 2011
Posts: 26
windows_vistafirefox
Re: F15 Gnome 3: disable top right corner effect

Hi, All:

Thank you for helping me. first I am not sure if this is called ripple effect. The symptom I have is: if I have 2 apps open, say terminal and firefox and is viewing in firefox with the browser in full window; now if I move mouse to the very upper RIGHT corner of the screen, then the window will display these 2 open apps with smaller windows for each and waiting for mouse to click one of them to activate. I am not sure if this is ripple or not. But I don't want to have this effect since most of time the mouse movement in this case is accidental.

From suggestion, I installed noripple extension and hope it will remove the undesirable effect. but it doesn't work. So I am asking again for help.

Thank you again.
Reply With Quote
  #11  
Old 30th June 2011, 04:25 PM
mightymouse2045 Offline
Registered User
 
Join Date: Dec 2010
Posts: 124
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

Quote:
Originally Posted by fpmurphy View Post
If the OP is using my extension, there is an option (SHOW_RIPPLE) to either show a ripple effect or not.
There you go
Reply With Quote
  #12  
Old 30th June 2011, 04:25 PM
alfatal Offline
Registered User
 
Join Date: Oct 2007
Location: Nazareth
Posts: 46
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

I only know this effect in top LEFT... are you using a RTL language maybe?
Reply With Quote
  #13  
Old 30th June 2011, 04:29 PM
mightymouse2045 Offline
Registered User
 
Join Date: Dec 2010
Posts: 124
linuxfirefox
Re: F15 Gnome 3: disable top right corner effect

Quote:
Originally Posted by andyzhu35 View Post
now if I move mouse to the very upper RIGHT corner of the screen, then the window will display these 2 open apps with smaller windows for each and waiting for mouse to click one of them to activate. I am not sure if this is ripple or not.
Ok no that's not a ripple effect - that sort of sounds like the app alt tab up in the right corner?! ummm are you sure your running Fedora 15 with gnome shell?

Does anyone know of an app or extension that is doing something like this in F15? I'm a bit stumped on this one dude.

Have you done a fresh install of F15 or an upgrade? Perhaps if it's an upgrade from a previous version of fedora you could have some app leftover? can you post some screenshots that could be helpful.
Reply With Quote
  #14  
Old 30th June 2011, 04:38 PM
cymbaline42 Offline
Registered User
 
Join Date: May 2011
Posts: 165
linuxopera
Re: F15 Gnome 3: disable top right corner effect

Quote:
Originally Posted by andyzhu35 View Post
Hi, All:

Thank you for helping me. first I am not sure if this is called ripple effect. The symptom I have is: if I have 2 apps open, say terminal and firefox and is viewing in firefox with the browser in full window; now if I move mouse to the very upper RIGHT corner of the screen, then the window will display these 2 open apps with smaller windows for each and waiting for mouse to click one of them to activate. I am not sure if this is ripple or not. But I don't want to have this effect since most of time the mouse movement in this case is accidental.

From suggestion, I installed noripple extension and hope it will remove the undesirable effect. but it doesn't work. So I am asking again for help.

Thank you again.

The default action on Fedora 15 is to have the ripple effect on the left. Since you're sure that it's on the right, it means you must have installed the aforementioned extension (righthotcorner from here: http://www.fpmurphy.com/gnome-shell-extensions/)

To disable that, just remove the extension, i.e. delete the folder from /home/.local/share/gnome-shell/extensions and restart the shell (Alt+F2, press r and Enter).
Reply With Quote
  #15  
Old 30th June 2011, 06:16 PM
fpmurphy Offline
Registered User
 
Join Date: May 2009
Location: /dev/ph
Posts: 314
windows_7firefox
Re: F15 Gnome 3: disable top right corner effect

Quote:
Does anyone know of an app or extension that is doing something like this in F15? I'm a bit stumped on this one dude.
I have never come across such an extension.

Suggest that you remove ALL extensions and see what happens.
Reply With Quote
Reply

Tags
corner, disable, effect, f15, gnome

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
f15 - gnome shell - remove username from top right corner linuzzz Using Fedora 14 30th May 2011 04:58 PM
Get rid of name in top right corner of Gnome 3 sillav F15 Development 13 11th May 2011 09:39 AM
Disable the active corner RocketRanger Using Fedora 5 30th April 2011 03:54 PM
[SOLVED] What is the Window Effect when moving the cursor to top right corner in Fedora 14? amayatheworld Using Fedora 5 25th November 2010 11:13 AM


Current GMT-time: 03:39 (Sunday, 26-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Novotroitsk Photos - Guarapuava Instagram Photos - Adapazari Travel Photos on Instagram