Fedora Linux Support Community & Resources Center
  #1  
Old 9th July 2011, 08:28 AM
vasanthakumar Offline
Registered User
 
Join Date: Jul 2011
Posts: 9
windows_98_nt_2000firefox
Send Mail Problem

hi, Happy morning to all,

im using linux fedora as my mail server in my organization, im very much new to this. now i am facing a problem i.e all my user are unable to send mails. it shows "Outlook is unable to contact your outgoing SMPT email server."

i checked in the terimal using service sendmail staus it shows
"Send mail stopped
sm-client dead but pid file exits "

i tried service sendmail start,restart but no use.

kindly help me plz...
Reply With Quote
  #2  
Old 9th July 2011, 09:30 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,553
linuxfedorafirefox
Re: Send Mail Problem

When a service "dies" like that it usually leaves a message in the logs.

You need to look through these log files at /var/log/message, /var/log/bootlog and /var/log/maillog for example.

Check for the BASICS on that system too.
Is port 25 (or other SMPT port) open on the firewall ?
Are and of your disk partitions filled ? "df -h"
Is the network correctly functioning ?

If you need more detailed help you will need to post your Fedora version, and also which mailserver you are using , postfix, sendmail, other ..
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #3  
Old 9th July 2011, 10:52 AM
vasanthakumar Offline
Registered User
 
Join Date: Jul 2011
Posts: 9
windows_98_nt_2000firefox
Re: Send Mail Problem

Thanks for your reply,

and i cant find nothing in var/log files, i m using fedora 7 as my mail server

[root@aloha ]# service sendmail start
Starting sendmail: [ OK ]
[root@aloha ]# postfix/postfix-script: starting the Postfix mail system

[root@aloha ]# service sendmail status
sendmail is stopped
sm-client dead but pid file exists
[root@aloha ]#

this is wat im getting ...
Reply With Quote
  #4  
Old 12th July 2011, 01:59 PM
vasanthakumar Offline
Registered User
 
Join Date: Jul 2011
Posts: 9
windows_98_nt_2000firefox
Re: Send Mail Problem

can any one help me to sort out the problem.
Reply With Quote
  #5  
Old 12th July 2011, 03:34 PM
William Haller Online
Registered User
 
Join Date: Jul 2005
Age: 53
Posts: 1,077
linuxfedorakonqueror
Re: Send Mail Problem

Although sendmail itself hasn't changed drastically over the years, Fedora 7 is ancient. If you're running an outward facing service for an organization, you owe it to that organization to keep your Fedora system updated to at least a level where security updates are still being released. I'd also seriously suggest CentOS as an option if funds are limited.

Regardless, don't necessarily rely on the service command - use ps -elf and see what is running. Clean up the pid files that are being reported as present and then try service sendmail start again (or check the dates to see if they are recent). Please verify and post back that you have checked the items stevea has mentioned. Check ownership issues in directories like /var/spool/mqueue and the like. There really should be something in /var/log/messages or /var/log/maillog as to what is the problem. If all else fails, start it from the command line and see what is reported. Perhaps a library it needs has gone AWOL and this will show up from the command line quickly.
Reply With Quote
  #6  
Old 15th July 2011, 06:02 AM
DAKSH Offline
Registered User
 
Join Date: Oct 2009
Location: In the Rain
Posts: 134
linuxchrome
Re: Send Mail Problem

Quote:
Originally Posted by vasanthakumar View Post
can any one help me to sort out the problem.
have tried to telnet like
Code:
telnet localhost smtp
or
Code:
 
telnet yourdomain.tld smtp
you can use port 25 instead of smtp
like
Code:
telnet localhost 25
Check if you are getting any error or not

Second thing have you turned on smtp service on your firewall? If not then you have to. I could not remember the real path but assumed it will be like that go to your menu option- administration -firewall
turn on check smtp option and apply it before you close the window.

And last thing is for a server which is directly connected trough internet and serving or about to server something to user no matter what whether it is website or mail should be updated. Else you will have many security issues like bug fix, advanced option etc.
I assumed from your id you are Indian. If you are using low bandwidth connection or have download limit or and if you are in kolkata then I can provide you latest fedora version in dvd on 64 bit architecture. If you want feel free to contact me.
__________________
Live and let live bla bla bla I hate it.
My words: Eat and let me Eat some delicious menu:p
Reply With Quote
  #7  
Old 19th July 2011, 08:06 AM
vasanthakumar Offline
Registered User
 
Join Date: Jul 2011
Posts: 9
windows_98_nt_2000firefox
Re: Send Mail Problem

hi daksh,

i have tried as you said , please refer below


Code:
[root@aloha ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 aloha.com ESMTP Postfix
this is wat im getting. and i have enabled all the port in firewall.

and in my fedora mail server they have configured in MailScanner for sending and receiving mails. they have not configured in postfix. but when ever we start the service mail scanner it shows

Code:
 [root@aloha ~]# service MailScanner start
Starting MailScanner daemons:
         incoming sendmail:                                [  OK  ]
         outgoing sendmail:                                [  OK  ]
         MailScanner:       postfix/postfix-script: fatal: the Postfix mail system is already running
                                                           [  OK  ]
[root@aloha ~]#

can u get what is the problem, or else do u need any more information.

thanks in advance...
Reply With Quote
  #8  
Old 19th July 2011, 08:28 AM
DAKSH Offline
Registered User
 
Join Date: Oct 2009
Location: In the Rain
Posts: 134
linuxfirefox
Re: Send Mail Problem

vasant at first I want to tell you you are running very insecure mail server.I just telnet your server it's seems ok. There are no authentication process. Any one can relay spam through your mail server and if it happens then your website's static ip will be banned and most mail server will not accept your relay. Second your ssl smtp port open 587 but it's not ssl configured you can try by this
Code:
openssl s_client -starttls smtp -connect aloha.com:587
If mail client try to connect ssl port and do not found some times get cranky like my thunder bird shows insecured server if you cant afford ssl certificate you can generate one by open ssl or get one from cacert.org.

I will suggest you try your mail client to connect port 25. If that dose not happen then check the log.

Another thing you have posted postfix's welcome message but your mail server running on sendmail.

you can post the log if you want to excluding mail address and ip address I will try.[COLOR="Silver"]
__________________
Live and let live bla bla bla I hate it.
My words: Eat and let me Eat some delicious menu:p

Last edited by DAKSH; 19th July 2011 at 08:29 AM. Reason: Oops dual posted :D
Reply With Quote
  #9  
Old 19th July 2011, 10:20 AM
vasanthakumar Offline
Registered User
 
Join Date: Jul 2011
Posts: 9
windows_98_nt_2000firefox
Re: Send Mail Problem

ya daksh,

when i tried that code it shows,

Code:
[root@alohaindia ~]# openssl s_client -starttls smtp -connect alohaindia.com:587
socket: Connection refused
connect:errno=29
here with i have attached the log file , hope you could solve my problem.

thanks in advance..

Last edited by vasanthakumar; 20th July 2011 at 04:42 AM.
Reply With Quote
  #10  
Old 20th July 2011, 01:13 AM
DAKSH Offline
Registered User
 
Join Date: Oct 2009
Location: In the Rain
Posts: 134
linuxfirefox
Re: Send Mail Problem

It seems you are making a big mess. You are trying to run postfix mail server but send mail is configured to run
run this command
Code:
yum install system-switch-mail
system-switch-mail
and switch the mail server to postfix. a good example for postfix configuration is here. If you have further problem you can post with main.cf. Remember always remove your domain, host and ip as well as mail id.
__________________
Live and let live bla bla bla I hate it.
My words: Eat and let me Eat some delicious menu:p

Last edited by DAKSH; 20th July 2011 at 01:15 AM.
Reply With Quote
  #11  
Old 20th July 2011, 12:17 PM
vasanthakumar Offline
Registered User
 
Join Date: Jul 2011
Posts: 9
windows_98_nt_2000firefox
Re: Send Mail Problem

hi daksh ,

Thanks for your replay, Hope this could solve my problem.
If any issues ill get back u for help..
Reply With Quote
Reply

Tags
mail, problem, send

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 18:07 (Thursday, 24-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat