Fedora Linux Support Community & Resources Center
  #1  
Old 27th September 2011, 10:35 AM
ltodd2 Offline
Registered User
 
Join Date: Nov 2004
Posts: 125
linuxfirefox
modem config

Morning
I am trying to get the modem working in the dell 5520 laptop I have but cant find out what device it is. I dont have /dev/modem but do have ttyS0, S1, S2 and S3 but have no idea how to test if one is the modem or not.
I've also got this usb dongle thing that came with some other laptops and that is detected as:

Sep 27 10:28:37 zeus kernel: [16233.289446] usb 2-1.3: new full speed USB device number 7 using ehci_hcd
Sep 27 10:28:40 zeus kernel: [16235.819219] usb 2-1.3: New USB device found, idVendor=0572, idProduct=1324
Sep 27 10:28:40 zeus kernel: [16235.819229] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Sep 27 10:28:40 zeus kernel: [16235.819235] usb 2-1.3: Product: USB Modem
Sep 27 10:28:40 zeus kernel: [16235.819240] usb 2-1.3: Manufacturer: Conexant
Sep 27 10:28:40 zeus kernel: [16235.819245] usb 2-1.3: SerialNumber: 24680246
Sep 27 10:28:40 zeus kernel: [16235.819790] cdc_acm 2-1.3:1.0: ttyACM0: USB ACM device
Sep 27 10:28:40 zeus mtp-probe: checking bus 2, device 7: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Sep 27 10:28:40 zeus mtp-probe: bus: 2, device: 7 was not an MTP device

It shows as dev/ttyACM0 but I dont know how to talk to it. Tried kppp and when querying the modem I get this in the console:
error opening modem device !

Can anyone help
Reply With Quote
  #2  
Old 29th September 2011, 08:20 PM
assen Offline
Registered User
 
Join Date: Oct 2008
Posts: 492
linuxfedorafirefox
Re: modem config

Hi,

If it is an AT-compliant modem, then launch minicom, set the port to /dev/ttyS0 and speed to 9600, port settings to 8N1, then type "atz" (software reset of the modem). If you get "OK", you have the correct port; if not, try next one.

WWell,
Reply With Quote
  #3  
Old 29th September 2011, 08:42 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,318
linuxfirefox
Re: modem config

the device is /dev/ttyACM0

/dev/ttyS0 will not point you to the correct device.

you send the commands to /dev/ttyACM0 just the same as you would any other device.

in kppp where it asks you what device, you point it to /dev/ttyACM0

(you set this in the kppp global settings on the device tab.)

if it's set up to use /dev/modem, and you can't change it to /dev/ttyACM0, you could also create a symlink to direct /dev/modem to /dev/ttyACM0, but this really isn't the preferred way to do it.
Reply With Quote
  #4  
Old 4th October 2011, 03:33 PM
ltodd2 Offline
Registered User
 
Join Date: Nov 2004
Posts: 125
linuxfirefox
Re: modem config

DBelton

Thanks for that will give it ago and let you know.
Reply With Quote
Reply

Tags
config, modem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
bluetooth modem config rajamoni Using Fedora 8 7th August 2008 07:30 PM
USB modem config to internet connection jrpi Servers & Networking 1 28th March 2006 04:54 PM
modem config fleidnourxa Hardware & Laptops 1 25th December 2005 09:43 PM
modem wont connect using config wizard rswitzer Using Fedora 0 13th October 2005 12:23 AM
modem config problems dirramu Using Fedora 3 16th April 2005 11:48 PM


Current GMT-time: 04:02 (Friday, 25-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat