Fedora Linux Support Community & Resources Center
  #1  
Old 14th October 2011, 04:25 AM
m6aUdS Offline
Registered User
 
Join Date: Jul 2011
Posts: 13
linuxchrome
Clock problem vs. filesystem problem

Hello!

I got kind of a stupid problem. My clock is f*cked up (it advances 4 hours each time I reboot). I did not care so I left it that way for a couple of days. Got tired of it, set it back to normal, and on the next reboot, the computer whined that last mount time was in the future.

It told me to run fsck with a command prompt, which worked. But on the next reboot, the boot jammed on the fedora logo. I do Shift+F1 to see where it hanged, and it was when trying to mount my /home/username with the same error. But this time I was not given any command prompt to run fsck.

The only way I found to get in my filesystem was to advance my BIOS clock a couple of days.

Any ideas How I can get things back to normal?
Reply With Quote
  #2  
Old 14th October 2011, 07:26 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
linuxfirefox
Re: Clock problem vs. filesystem problem

Boot up and leave your BIOS date where it is.

Once the OS is up, disable UTC and enable NTP for your OS clock.

No idea which DE you are using. Gnome/KDE/???

I think the following should work to change from UTC to NTP

From a terminal

Code:
system-config-date


exit and then from a terminal logged in as root

Code:
# chkconfig ntpd on
# ntpdate pool.ntp.org
# service ntpd start
Reboot, set your BIOS clock to the current date and time and see what happens.
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #3  
Old 14th October 2011, 06:27 PM
m6aUdS Offline
Registered User
 
Join Date: Jul 2011
Posts: 13
windows_xp_2003ie
Re: Clock problem vs. filesystem problem

Thank you, I will try that and post the result here!
Reply With Quote
  #4  
Old 14th October 2011, 06:41 PM
lightman47 Offline
Registered User
 
Join Date: Apr 2009
Location: central NY, USA
Posts: 558
linuxchrome
Re: Clock problem vs. filesystem problem

This also happens on dual-boot machines with Windows - and UTC is selected in Fedora during install. Windows keeps setting the time back (or forward, or whatever). If you dual-boot: no UTC.
Reply With Quote
Reply

Tags
clock, filesystem, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Clock DachaArh Using Fedora 6 28th July 2009 02:08 AM
screensaver and/or clock problem imperia Using Fedora 1 12th March 2008 07:36 PM
a different clock problem StevenMedley Using Fedora 5 6th July 2007 01:18 PM
the problem about clock liu4gre Using Fedora 2 9th February 2007 01:06 AM


Current GMT-time: 10:20 (Monday, 28-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat