Fedora Linux Support Community & Resources Center
  #1  
Old 25th October 2011, 12:08 PM
jbasko Offline
Registered User
 
Join Date: Jun 2011
Location: Czech Republic
Posts: 13
linuxfirefox
repo updates - problems with newer versions, dependencies

Hello,

i have a problem which takes me a lot of time and i would like you ask about some hints about it... I hope that this type of problem is ok for this mailing list.

My experienced friend advice me repo "updates", i updated system (i use fedora 15 + xfce) and it kicked off this problem... If i want to compile or install some sw, im globally blocked by this type of problem - any libs or dependeces are newer than a compilation want...

---> Package libXi-devel.i686 0:1.4.2-1.fc15 will be installed
--> Processing Dependency: libXi = 1.4.2-1.fc15 for package:
libXi-devel-1.4.2-1.fc15.i686
--> Finished Dependency Resolution
Error: Package: libXi-devel-1.4.2-1.fc15.i686 (fedora)
Requires: libXi = 1.4.2-1.fc15
Installed: libXi-1.4.3-2.fc15.i686 (@updates)
libXi = 1.4.3-2.fc15
Available: libXi-1.4.2-1.fc15.i686 (fedora)
libXi = 1.4.2-1.fc15

Note: rows Requires, Installed and Avilable - this is a shot from installing g++ for compiling.

My question is - i disabled repo updates, no problem, but i need remove newer versions gave by updates repo...

Could you give me some advice or help, please... It stops me in another using of linux... Thanx

Honza

Last edited by jbasko; 25th October 2011 at 02:28 PM. Reason: add yum
Reply With Quote
  #2  
Old 25th October 2011, 03:33 PM
jbasko Offline
Registered User
 
Join Date: Jun 2011
Location: Czech Republic
Posts: 13
linuxfirefox
Re: repo updates - problems with newer versions, dependencies

add all yum log report
Attached Files
File Type: txt log_yum.txt (40.0 KB, 79 views)
Reply With Quote
  #3  
Old 25th October 2011, 03:50 PM
kurtdriver Offline
Registered User
 
Join Date: Jul 2005
Location: Vancouver, Canada
Posts: 1,588
linuxfirefox
Re: repo updates - problems with newer versions, dependencies

This happens now and then, a package will be updated that lists another package as a dependency and the second one is not yet available. Usually if you wait a couple of days the problem resolves itself.
Reply With Quote
  #4  
Old 26th October 2011, 12:56 PM
jbasko Offline
Registered User
 
Join Date: Jun 2011
Location: Czech Republic
Posts: 13
linuxfirefox
Re: repo updates - problems with newer versions, dependencies

ok, thanx, i hope that i will be wait "couple of days", no couple of months do you have experience?
Reply With Quote
  #5  
Old 26th October 2011, 04:23 PM
kurtdriver Offline
Registered User
 
Join Date: Jul 2005
Location: Vancouver, Canada
Posts: 1,588
linuxfirefox
Re: repo updates - problems with newer versions, dependencies

That has been my experience, yes, usually it works that way. Several of those packages were "broken" ie, a package they require isn't quite ready. For instance, rpm-devel-4.9.0-6.fc15.i686 requires rpm-libs(x86-32) = 4.9.0-6.fc15, but can't get it because that version of rpm-libs isn't yet in the repos. It may be by now, though, have you tried it with "--skip-broken" as suggested at the end of your error message?
One thing I've done in this situation was to exclude the broken packages like this,
Code:
su -c "yum groupinstall  "Development Tools" "Development Libraries" --skip-broken -x rpm-devel -x pam-devel"
That way you get most of the stuff you want and the rest will be ready in a couple of days.
Reply With Quote
  #6  
Old 27th October 2011, 08:33 AM
jbasko Offline
Registered User
 
Join Date: Jun 2011
Location: Czech Republic
Posts: 13
linuxfirefox
Re: repo updates - problems with newer versions, dependencies

Perfect, it helps me to be more experience and cautios about that.
Thanx for command - it fixed my problem partially ...

I have to wait still some days especially for gcc++ etc. Thanx. I hope that it will takes only couple of days. I will try yum update every day

Honza

PS: typical maurphy law - needed dependencies are in "Skipped" group )

log output after applying command from you:

Installed:
autoconf.noarch 0:2.68-2.fc15 automake.noarch 0:1.11.1-5.fc14 automake14.noarch 0:1.4p6-21.fc15 automake15.noarch 0:1.5-29.fc13.1 automake16.noarch 0:1.6.3-18.fc13.1
automake17.noarch 0:1.7.9-14.fc15.1 binutils-devel.i686 0:2.21.51.0.6-2.fc15 bison.i686 0:2.4.3-2.fc15 boost-devel.i686 0:1.46.0-1.fc15 byacc.i686 0:1.9.20101229-2.fc15
bzip2-devel.i686 0:1.0.6-3.fc15 ccache.i686 0:3.1.4-4.fc15 coolkey-devel.i686 0:1.1.0-19.fc15 cscope.i686 0:15.7a-3.fc15 ctags.i686 0:5.8-3.fc15
db4-devel.i686 0:4.8.30-3.fc15 dbus-cxx-doc.noarch 0:0.7.0-2.fc14.1 dbus-cxx-tools.i686 0:0.7.0-2.fc14.1 diffstat.i686 0:1.54-2.fc15 doxygen.i686 1:1.7.4-1.fc15
expat-devel.i686 0:2.0.1-11.fc15 flex.i686 0:2.5.35-13.fc15 gdbm-devel.i686 0:1.8.3-9.fc15 git.i686 0:1.7.5.1-1.fc15 gmp-devel.i686 1:4.3.2-3.fc15
gpm-devel.i686 0:1.20.6-16.fc15 hesiod-devel.i686 0:3.1.0-20.fc15 indent.i686 0:2.2.11-3.fc15 intltool.noarch 0:0.41.1-2.fc15 libattr-devel.i686 0:2.4.44-7.fc15
libogg-devel.i686 2:1.2.2-3.fc15 libselinux-devel.i686 0:2.0.99-4.fc15 libvorbis-devel.i686 1:1.3.2-1.fc15 libxml2-devel.i686 0:2.7.8-6.fc15 lockdev-devel.i686 0:1.0.3-10.fc15
ltrace.i686 0:0.5-19.45svn.fc15 ncurses-devel.i686 0:5.8-2.20110319.fc15 newt-devel.i686 0:0.52.12-3.fc15 oprofile.i686 0:0.9.6-20.fc15 oprofile-gui.i686 0:0.9.6-20.fc15
patchutils.i686 0:0.3.2-1.fc15 pciutils-devel.i686 0:3.1.7-5.fc15 python-devel.i686 0:2.7.1-7.fc15 python-ldap.i686 0:2.3.12-2.fc15 rcs.i686 0:5.7-37.fc15
readline-devel.i686 0:6.2-2.fc15 redhat-rpm-config.noarch 0:9.1.0-5.fc14 slang-devel.i686 0:2.2.3-2.fc15 subversion.i686 0:1.6.16-1.fc15 swig.i686 0:2.0.3-1.fc15
sysprof.i686 0:1.1.6-2.fc15 texinfo.i686 0:4.13a-15.fc15 valgrind.i686 1:3.6.1-1.fc15 zlib-devel.i686 0:1.2.5-3.fc15

Dependency Installed:
boost.i686 0:1.46.0-1.fc15 boost-date-time.i686 0:1.46.0-1.fc15 boost-graph.i686 0:1.46.0-1.fc15 boost-python.i686 0:1.46.0-1.fc15 boost-random.i686 0:1.46.0-1.fc15
boost-regex.i686 0:1.46.0-1.fc15 boost-signals.i686 0:1.46.0-1.fc15 boost-test.i686 0:1.46.0-1.fc15 boost-thread.i686 0:1.46.0-1.fc15 boost-wave.i686 0:1.46.0-1.fc15
cmake.i686 0:2.8.4-1.fc15 db4-cxx.i686 0:4.8.30-3.fc15 dbus-cxx.i686 0:0.7.0-2.fc14.1 devhelp.i686 1:3.0.0-2.fc15 docbook-style-dsssl.noarch 0:1.79-12.fc15
docbook-utils.noarch 0:0.6.14-27.fc15 gettext-common-devel.noarch 0:0.18.1.1-7.fc15 gettext-devel.i686 0:0.18.1.1-7.fc15 gpm.i686 0:1.20.6-16.fc15 gtk-doc.noarch 0:1.17-1.fc15
libsepol-devel.i686 0:2.0.42-2.fc15 openjade.i686 0:1.3.2-36.fc13 opensp.i686 0:1.5.2-13.fc15 perl-Error.noarch 1:0.17016-5.fc15 perl-Git.noarch 0:1.7.5.1-1.fc15
perl-SGMLSpm.noarch 0:1.03ii-24.fc15 source-highlight.i686 0:3.1.4-3.fc15 subversion-libs.i686 0:1.6.16-1.fc15

Skipped (dependency problems):
cyrus-sasl-devel.i686 0:2.1.23-16.fc15 dbus-cxx.i686 0:0.7.0-2.fc14.1 dbus-cxx-devel.i686 0:0.7.0-2.fc14.1 dbus-cxx-glibmm.i686 0:0.7.0-2.fc14.1 dbus-cxx-glibmm-devel.i686 0:0.7.0-2.fc14.1
dbus-devel.i686 1:1.4.6-4.fc15 dbus-devel.i686 1:1.4.6-4.fc15 dbus-glib-devel.i686 0:0.92-2.fc15 dbus-glib-devel.i686 0:0.92-2.fc15 gcc.i686 0:4.6.0-6.fc15
gcc-c++.i686 0:4.6.0-6.fc15 gcc-gfortran.i686 0:4.6.0-6.fc15 geoclue-devel.i686 0:0.12.0-7.fc15 glib2-devel.i686 0:2.28.6-2.fc15 glib2-devel.i686 0:2.28.6-2.fc15
glibmm24-devel.i686 0:2.28.0-1.fc15 gnutls-devel.i686 0:2.10.5-1.fc15 gssdp-devel.i686 0:0.10.0-1.fc15 gupnp-devel.i686 0:0.16.1-1.fc15 gypsy.i686 0:0.8-2.fc15
gypsy-devel.i686 0:0.8-2.fc15 keyutils-libs-devel.i686 0:1.2-7.fc15 krb5-devel.i686 0:1.9-7.fc15 libacl-devel.i686 0:2.2.49-9.fc15 libcap-devel.i686 0:2.17-2.fc15
libcom_err-devel.i686 0:1.41.14-2.fc15 libcurl-devel.i686 0:7.21.3-6.fc15 libgcrypt-devel.i686 0:1.4.6-1.fc15 libgpg-error-devel.i686 0:1.9-2.fc15 libquadmath-devel.i686 0:4.6.0-6.fc15
libsigc++20-devel.i686 0:2.2.9-1.fc15 libsoup-devel.i686 0:2.34.1-1.fc15 libstdc++-devel.i686 0:4.6.0-6.fc15 libtasn1-devel.i686 0:2.7-2.fc15 libtool.i686 0:2.4-4.fc15
libuser-devel.i686 0:0.57.2-1.fc15 libuuid-devel.i686 0:2.19.1-1.fc15 openldap-devel.i686 0:2.4.24-2.fc15 openssl-devel.i686 0:1.0.0d-1.fc15 pcsc-lite-devel.i686 0:1.7.2-1.fc15
systemtap.i686 0:1.4-3.fc15 systemtap-runtime.i686 0:1.4-3.fc15
Reply With Quote
  #7  
Old 29th October 2011, 10:59 AM
jbasko Offline
Registered User
 
Join Date: Jun 2011
Location: Czech Republic
Posts: 13
linuxfirefox
Re: repo updates - problems with newer versions, dependencies

kurtdriver: it was my fault - i had to edit resp add updates repo from fedora and now, everything is ok... Many thanx! H
Reply With Quote
Reply

Tags
dependency problem, repo, updates, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to have newer versions placed on repo? Wayne Hammond Using Fedora 1 27th February 2007 11:37 PM
how to download only newer updates with rsync? shams Servers & Networking 1 19th May 2006 10:53 PM
Easiest way to install newer versions of MySQL, PHP, and Apache on FC3 ? Terence Servers & Networking 11 15th March 2006 05:05 PM


Current GMT-time: 04:06 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Sheki - Beersheba Photos - Bedele