Fedora Linux Support Community & Resources Center
  #16  
Old 9th November 2011, 10:15 AM
Geval Offline
Registered User
 
Join Date: Nov 2011
Posts: 6
windows_7firefox
Re: Fedora 16 Upgrade Disaster

Same issue here, gdm just won't start, any idea on how to fix this? using nvidia original drivers btw.
Reply With Quote
  #17  
Old 9th November 2011, 10:24 AM
kindofautomatic Offline
Registered User
 
Join Date: Nov 2011
Posts: 1
linuxfirefox
Re: Fedora 16 Upgrade Disaster

I think this problem is related to selinux and its policies regarding nvidia. You can now either wait for the update to selinux-policy-3.10.0-55 or temporarily set selinux to permissive mode (edit /etc/selinux/config), which has resolved the problem for me.

As soon as the update happens, though, I'd recommend resetting selinux to enforce mode or use setenforce 1 as soon as the system has passed gdm. Better yet: use the NVIDIA installation guide MrMarcus has posted down below to install the selinux updates directly from koji.

Last edited by kindofautomatic; 9th November 2011 at 10:46 AM.
Reply With Quote
  #18  
Old 9th November 2011, 10:31 AM
MrMarcus Offline
Registered User
 
Join Date: Nov 2009
Posts: 13
windows_xp_2003ie
Re: Fedora 16 Upgrade Disaster

If you are using the NVIDIA propietary drivers, make sure that you have add the selinux policy regarding the GDM.

And don't forget to add nomodeset to the /boot/grub2/grub.cfg

See Leigh's guide for NVIDIA installation on Fedora 16. (escpecialy point nr. 4)

http://www.fedoraforum.org/forum/sho...d.php?t=204752
Reply With Quote
  #19  
Old 9th November 2011, 11:17 AM
Geval Offline
Registered User
 
Join Date: Nov 2011
Posts: 6
linuxfirefox
Re: Fedora 16 Upgrade Disaster

Ok i didn't notice, new Nvidia drivers were available on nvidia.org for linux 64 bit, downloading and mounting the windows partition on the file system let me download and install this new driver, which fixed gdm for me.
Well personal note, redownload driver before each update. Ty for your help.

Possible solution: get updated drivers.
Reply With Quote
  #20  
Old 9th November 2011, 11:17 AM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Fedora 16 Upgrade Disaster

Quote:
Originally Posted by MrMarcus View Post
If you are using the NVIDIA propietary drivers, make sure that you have add the selinux policy regarding the GDM.

And don't forget to add nomodeset to the /boot/grub2/grub.cfg

See Leigh's guide for NVIDIA installation on Fedora 16. (escpecialy point nr. 4)

http://www.fedoraforum.org/forum/sho...d.php?t=204752

The updated policy should be in updates soon.

https://bugzilla.redhat.com/show_bug.cgi?id=748069

https://admin.fedoraproject.org/upda...3.10.0-55.fc16
Reply With Quote
  #21  
Old 9th November 2011, 06:11 PM
grunch Offline
Registered User
 
Join Date: Nov 2011
Posts: 2
linuxchrome
Re: Fedora 16 Upgrade Disaster

I've deleted .gnome2, .gnome2_private, .config, .gconf, and .gconfd in $HOME. GNOME still presents the "unhappy computer" screen.

There are several errors in /var/log/Xorg.0.log and in $HOME/.xsession_errors, but I haven't made it through all of them to see which one is causing GNOME to crash.
Reply With Quote
  #22  
Old 9th November 2011, 06:16 PM
sea Online
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,621
linuxfirefox
Re: Fedora 16 Upgrade Disaster

(optional: Rename the logs, then restart.)
After the failure, switch to VC (ctrl+alt+f2) and run for example:
Code:
cat /var/log/Xorg.0.log | grep "(EE)"
to show only errors.
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Guide: Windows 8+ & Fedora 20+ Dualboot
Repo (sea-devel) :: Text User Interface (TUI), Video Handler Script (VHS), efi-helper, grub2-circled-nasa-themes, Essentials (blame, p, rmtf, rnd, siggen, screenshot...), (BETA) Dev-Scripts, (BETA) Fedora Account Scripts (FAS)
Reply With Quote
  #23  
Old 9th November 2011, 06:19 PM
bbehnam Offline
Registered User
 
Join Date: Jan 2007
Posts: 49
windows_7firefox
Re: Fedora 16 Upgrade Disaster

Quote:
Originally Posted by Finalzone View Post
How about resetting gnome session?
From File Manager (Nautilus),
- press Ctrl+H to reveal hidden files and folders.
- Delete folders like .gnome .gnome2 .gconf .gconfd .metacity (or back up if you want to keep custom setting)
- Log out

From terminal as user
Code:
rm -fr .gnome .gnome2 .gconf .gconfd .metacity
I never get as far as a user login. I believe these are in the user's home directories. They are not accessed until you are actually authenticated. If you used something like automount (I.E. like a university lab setup would) The filesystem containing "/home/someusername" might not be even mounted or accessible at this point.

So I don't think it's pertinent to the problem. Removing them should not cause any problems that I can think of (they should just be rebuilt on the next successful login); but, not sure it helps in this case.

But, please keep on suggesting. I had not even considered these files and had to think why or why not this suggestion may or may not work Many heads are a lot better than mine
Reply With Quote
  #24  
Old 9th November 2011, 06:26 PM
grunch Offline
Registered User
 
Join Date: Nov 2011
Posts: 2
linuxchrome
Re: Fedora 16 Upgrade Disaster

Quote:
Originally Posted by leigh123linux View Post
I'm not sure which (if either) of these is the problem. But disabling selinux (in /etc/selinux/config) allowed me to successfully log in. I look forward to being able to re-enable selinux.

Interestingly, 'yum distro-sync' Downgraded several packages.
Reply With Quote
  #25  
Old 9th November 2011, 06:34 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: Fedora 16 Upgrade Disaster

Did you install the updated selinux policy to solve the issues with the nvidia drivers and gnome?

Code:
su
yum --nogpgcheck update libsepol http://kojipkgs.fedoraproject.org/packages/selinux-policy/3.10.0/53.fc16/noarch/selinux-policy-3.10.0-53.fc16.noarch.rpm \
http://kojipkgs.fedoraproject.org/packages/selinux-policy/3.10.0/53.fc16/noarch/selinux-policy-targeted-3.10.0-53.fc16.noarch.rpm --enablerepo=u*g
look in Leigh123linux's thread on the nvidia drivers...

http://forums.fedoraforum.org/showthread.php?t=204752
Reply With Quote
  #26  
Old 9th November 2011, 06:39 PM
bbehnam Offline
Registered User
 
Join Date: Jan 2007
Posts: 49
windows_7firefox
Re: Fedora 16 Upgrade Disaster, SOLVED the problem, somewhat

Quote:
Originally Posted by harshad1 View Post
Reverted to nouveau drivers. This let me boot into and use gnome-shell.

However power management is a disaster. Suspend doesn't work, the power button doesn't work and neither dconf nor gconf seem to have any settings that might affect a thing....

Don't know if reinstalling the nvidia drivers again will break things again or fix them.
Hi there,

I think you may be on to something. I was able to force an X-session by the following method:

1- Login to another virtual console via CTL+ALT+F2 (any Function Key should work unless it's being used)
2- login as root
3- Rm the x-session lock file from the tmp directory ( rm /tmp/X0-lock )
4- try to login as user by su - yourusername
5- startx

At this point the despised Gnome shell started; but, the networking did not work. Also, sometimes it hung completely.

By trial and error I found out that if I started startx as root I get a working xsession; however, that's useless because it's really stupid to do things like browsing as root.

Next I will see what driver is being used when I startx manually
Reply With Quote
  #27  
Old 9th November 2011, 08:33 PM
Salamandra Offline
Registered User
 
Join Date: Sep 2004
Location: Spain
Posts: 325
linuxfirefox
Re: Fedora 16 Upgrade Disaster

I've had the same problem and solved it by:

ctrl+alt+f2

login as root

Code:
yum remove selinux-policy selinux-policy-targeted
yum update libsepol
yum --nogpgcheck install libsepol http://kojipkgs.fedoraproject.org/packages/selinux-policy/3.10.0/55.fc16/noarch/selinux-policy-3.10.0-55.fc16.noarch.rpm --enablerepo=u*g
yum --nogpgcheck install http://kojipkgs.fedoraproject.org/packages/selinux-policy/3.10.0/55.fc16/noarch/selinux-policy-targeted-3.10.0-55.fc16.noarch.rpm --enablerepo=u*g
And reboot.
__________________
Linux User #365705

Last edited by Salamandra; 9th November 2011 at 08:35 PM.
Reply With Quote
  #28  
Old 9th November 2011, 09:32 PM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
linuxfirefox
Re: Fedora 16 Upgrade Disaster

Same issue here with KDE.
I can login level 3 and startx and I get up and running with a doggy X.
If I just run just xterms and nothing else, CPU usage is normal. If I start any graphical app X takes 98-99% of the CPU.
I'm using the kmod-nvidia (which did get updated) and I have NO nomodset in my grub and there is no rdblacklist=neuveau. Is that line also still required?
__________________
Mark N.

Perpetual Newbie
--
I wanted to proclaim myself "The Typo King" but there's way too much competion. :p

411874 Get Counted
Reply With Quote
  #29  
Old 9th November 2011, 09:50 PM
Ex_Soft Offline
Registered User
 
Join Date: Feb 2007
Posts: 76
linuxfirefox
Re: Fedora 16 Upgrade Disaster

Quote:
Originally Posted by Salamandra View Post
I've had the same problem and solved it by:

ctrl+alt+f2

login as root

Code:
yum remove selinux-policy selinux-policy-targeted
yum update libsepol
yum --nogpgcheck install libsepol http://kojipkgs.fedoraproject.org/packages/selinux-policy/3.10.0/55.fc16/noarch/selinux-policy-3.10.0-55.fc16.noarch.rpm --enablerepo=u*g
yum --nogpgcheck install http://kojipkgs.fedoraproject.org/packages/selinux-policy/3.10.0/55.fc16/noarch/selinux-policy-targeted-3.10.0-55.fc16.noarch.rpm --enablerepo=u*g
And reboot.
Many thanks. This has resolved my same problem.
Reply With Quote
  #30  
Old 10th November 2011, 04:04 AM
ogradye Offline
Registered User
 
Join Date: Nov 2011
Posts: 1
windows_xp_2003firefox
Re: Fedora 16 Upgrade Disaster

An older thread
http://www.fedoraforum.org/forum/sho...d.php?t=266030

Selinux seems to be prohibiting the startup of something on the desktop.

---------- Post added at 03:04 AM ---------- Previous post was at 02:55 AM ----------

I found an old thread that can be fixed by

1. turning off selinux
or
2. touch /.autorelabel as root and then reboot.


autolabel worked for me from Fedora 15 upgrading to Fedora 16.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disaster after trying preupgrade to Fedora 13 Wywern Hardware & Laptops 16 15th June 2010 03:28 PM
FC9 Disaster GaJim Installation, Upgrades and Live Media 8 5th July 2008 05:47 PM
Why is Fedora a multimedia disaster? - Here is why. Valent Using Fedora 15 18th April 2007 02:06 PM


Current GMT-time: 18:21 (Wednesday, 26-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Korydallos Travel Photos - Denia Photos on Instagram - Bar Bigha Travel Photos