Fedora Linux Support Community & Resources Center
  #1  
Old 15th November 2011, 02:22 AM
HawkBoy Offline
Registered User
 
Join Date: Sep 2005
Posts: 125
linuxfirefox
What is wrong with pulseaudio in F16!?

==== Rant begin ====

Ok... a bit of a rant before I explode: WHY CAN'T FEDORA GET SOUND RIGHT?
It was fine 5 versions ago (it even worked perfectly with PA for a version or two), since then, it's NEVER been consistent... WTF? I'm a programmer myself. I appreciate the work these guys put into things and I've never worked on drivers, etc., but I have a lot of trouble believing it would take more than 2.5 years to get sound working when it was working to begin with. Why the hell is this thing still broken!?

sigh... I'm seriously considering mint right now. Like Torvalds said, I just want my OS to work, so I can do my own work. Tweaking things for hours every time is getting really old...

==== Rant end ====

Now then...
What is wrong with PA on f16? Sound (usually) doesn't work, phonon (I'm on KDE) can't seem to make sense of things, and I can't kill the pulseaudio server; "pulseaudio -k" kills it, but it seems to come right back (my speakers make a cracking noise and a new pulseaudio process is launched). Since I can't kill PA, I can't launch it with vvvv to see its debug output.

I looked at /var/log/messages but don't see anything too interesting.

Any thoughts? I'm getting really homicidal over here...
Reply With Quote
  #2  
Old 26th January 2012, 02:04 PM
nils06 Offline
Registered User
 
Join Date: Feb 2009
Posts: 22
linuxfedorafirefox
Re: What is wrong with pulseaudio in F16!?

I'm afraid I have to agree. Linux is great, Fedora is great, sound on Fedora is not that great.

I'm using KDE as well and since F10 I've had so much problems with sound, especially pulseaudio. I'm currently using F15 and recently I tried the Live Fedora 16 KDE x86_64. Of course I had no sound as usual (no surprise any more) but I wanted to use aplay to test my webcam mic. So when I lauched alsamixer to check and raise the levels, it crashed. Then I removed pulseaudio (yum erase pulseaudio) and after that, alsamixer didn't crash anymore...

OK, I have 2 soundcards that might be a 'very' uncommon configuration but when I installed a fresh F16 Fedora KDE on another brand new 'standard' PC (i5 CPU and a MSI MB with integrated sound), I ended up with no sound!

I also have a minimal custom audio (RT kernel) config of Fedora (without PA) where I'm using XFCE, alsa and jack. With this config I have much less hazzle to get the sound work perfectly.

Before, I encouraged everyone to use Linux and Fedora but with this situation I can't, when it takes hours for a non-beginner to get the sound to work properly. No one wants a freshly installed system without sound.

True that complaining doesn't help anyone, better be to propose something. Well, investigate in pulseaudio problems could be a way to get it work better but I don't want to, because I've already lost far too much time on that. The only proposition I can contribute with is (as I mentioned in another post) to remove pulseaudio. After that you might want to have a dmix entry in Phonon (System Settings -> Multimedia). Create (or add to) a file ~/.asoundrc the following:

Code:
pcm.dmixplug {
  type plug
  slave {
    pcm "dmix"
  }
  hint {
    show on
    description "DMix"
  }
}
You will find a "DMix" entry in System Settings -> Multimedia. Move it to top in Audio Ouput.

What else could be done to stop this annoyance? A non-pulseaudio KDE spin?
Reply With Quote
  #3  
Old 26th January 2012, 02:36 PM
CronoCloud Offline
Registered User
 
Join Date: May 2010
Location: Midwest USA
Posts: 452
linuxfirefox
Re: What is wrong with pulseaudio in F16!?

Quote:
Originally Posted by HawkBoy View Post

(it even worked perfectly with PA for a version or two), Why the hell is this thing still broken!?
Yes, I had minimal issues with Pulseaudio till F16. As of now I still can't get combined sink to work, and no matter what it makes Analog audio the default, rather than the HDMI I want. Then again, unlike previous versions, I can change sound output on the fly, which didn't work for me before.

Quote:
and I can't kill the pulseaudio server; "pulseaudio -k" kills it, but it seems to come right back (my speakers make a cracking noise and a new pulseaudio process is launched). Since I can't kill PA, I can't launch it with vvvv to see its debug output.
Pulse's default behavior is to restart when it dies, but it's easy to fix. in ~/.pulse/client.conf put

Code:
autospawn = no
CronoCloud
Reply With Quote
  #4  
Old 26th January 2012, 04:48 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,514
linuxopera
Re: What is wrong with pulseaudio in F16!?

Yes, I've started having issues again too--fixes seem to vary between installations, but, especially if one doesn't install a desktop environment, I have to fiddle around and restart a few times before it will work.

However, I have always been able to fix it so far, without even having to google--or, to be more accurate, googling never gives me an answer that works.
Reply With Quote
  #5  
Old 26th January 2012, 05:36 PM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,652
linuxfedorafirefox
Re: What is wrong with pulseaudio in F16!?

Quote:
Originally Posted by HawkBoy View Post
What is wrong with PA on f16?
s/on f16//

I've never liked PulseAudio, which is why that's the first thing I uninstall in Fedora if it somehow gets installed. The only PA-related package I have installed is pulseaudio-libs -- which is required by too many other packages for me to uninstall -- but it never gets used. I just use plain ALSA for everything. Every sound application I use allows you to pick which sound system to use, and ALSA is always one of the choices. So I haven't had any problems being PulseAudio-free in Fedora.
__________________
"I'm not glad he's dead, but I'm glad he's gone."
-- Richard M. Stallman, on the death of Steve Jobs
Reply With Quote
  #6  
Old 17th August 2012, 04:06 PM
boazharrosh Offline
Registered User
 
Join Date: May 2010
Posts: 2
linuxfirefox
Re: What is wrong with pulseaudio in F16!?

Quote:
Originally Posted by HawkBoy View Post
==== Rant begin ====

Ok... a bit of a rant before I explode: WHY CAN'T FEDORA GET SOUND RIGHT?
It was fine 5 versions ago (it even worked perfectly with PA for a version or two), since then, it's NEVER been consistent... WTF? I'm a programmer myself. I appreciate the work these guys put into things and I've never worked on drivers, etc., but I have a lot of trouble believing it would take more than 2.5 years to get sound working when it was working to begin with. Why the hell is this thing still broken!?

sigh... I'm seriously considering mint right now. Like Torvalds said, I just want my OS to work, so I can do my own work. Tweaking things for hours every time is getting really old...

==== Rant end ====

Now then...
What is wrong with PA on f16? Sound (usually) doesn't work, phonon (I'm on KDE) can't seem to make sense of things, and I can't kill the pulseaudio server; "pulseaudio -k" kills it, but it seems to come right back (my speakers make a cracking noise and a new pulseaudio process is launched). Since I can't kill PA, I can't launch it with vvvv to see its debug output.

I looked at /var/log/messages but don't see anything too interesting.

Any thoughts? I'm getting really homicidal over here...
Problem solved

Hy hy I hear you brother Fedoras QA is totally broken in regard to sound, that is they just don't test for it. Hence it's brokenness. This time it was just a plain setup bug.

Me too what I searched for on google was : "what's wrong with Fedora 16 pulseaudio" and surely hit this place. so I got interested and started investigating.

After putting "autospawn = no" in /etc/pulse/client.conf and after "pulseaudio --kill" running "pulseaudio -vvvv" showed a suspicious:
"module-udev-detect.c: /dev/snd/controlC0 is accessible: no"
So after detecting my 3 audio devices module-udev-detect could not access them for inclusion and the system was left with the stupid null_device.

Solving this is easy you need to add your user to the audio and pulse groups. (As I said an installation problem)

The easiest way to do that with a GUI in Fedora KDE is with KDE-MENU/Applications/Administration/"Users and Groups". Run that, select your user, press properties, and in the groups tab check the "audio" and "pulse" groups.
Note that you must completely logout of your user account for the changes to actually take effect. And for the pulseaudio server to restart.

While at it I found that with the proper tools pulseaudio does a very good job. Install the following:
Code:
      []$ sudo yum install paman pavumeter pavucontrol padevchooser
And run "
Code:
padevchooser &
" you will see a little audio-card icon in your taskbar. Click on it, press Preferences and check the "start on session login" checkbox.
It will be your friend from now on. Specially the "Volume Control ..." option will give you a window with all the controls you need.

Now pulse audio is working, very very nice with full control on all my devices. And shared by all of my application. (In Skype choose pulse device)

Cheers
Boaz

Last edited by boazharrosh; 17th August 2012 at 04:12 PM.
Reply With Quote
Reply

Tags
f16, pulseaudio, wrong

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora says the password is wrong but it is not wrong at all birdwatcher Using Fedora 7 19th October 2011 12:08 AM
Sound stops working, somethings wrong with the oss/alsa/pulseaudio(?) soundsystems psipot Using Fedora 0 21st March 2010 05:05 AM
PulseAudio USB device default behavior wrong! Am I right? doctorpacket Using Fedora 4 11th February 2010 07:48 PM
wrong output channel (front:0) after upgrading to pulseaudio 0.9.8-4 alarm9k Using Fedora 4 7th February 2008 08:20 PM
Up2date icon: You are at wrong place at the wrong time. tonytiger Using Fedora 2 28th May 2005 11:39 AM


Current GMT-time: 13:44 (Thursday, 18-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat