Fedora Linux Support Community & Resources Center
  #1  
Old 21st November 2011, 11:47 AM
akvasu Offline
Registered User
 
Join Date: Feb 2005
Posts: 61
linuxfirefox
Ghost Monitor....

Hi

When we disconnect the external monitor from the Laptop, F16 (or Gnome 3 or Graphics driver) does not disconnect the monitor i.e. the windows that were on the Monitor do not come back into the Laptop Screen...

If I reconnect the Monitor, then those old windows that were on the Monitor come back up....

Its like a ghost Monitor stays connected even though its been cut off!

Have you seen this behavior? And how to fix this?

I don´t recall seeing this in F13 (which was the last release I used with external Monitor actually)

Thanks
Anup

---------- Post added at 02:47 PM ---------- Previous post was at 02:15 PM ----------

Ubuntu folk have a tool called disper - But I am not sure if its available for F16 yet, I found a F15 package and not too sure if its safe...

I can open the Displays settings and then, the system wakes up and kills the Ghost monitor... but not automatically...
Reply With Quote
  #2  
Old 21st November 2011, 10:50 PM
angryfirelord Offline
Registered User
 
Join Date: Dec 2006
Location: Pennsylvania
Posts: 356
windows_xp_2003firefox
Re: Ghost Monitor....

A ghost monitor? That's not good. I'm afraid your only course of action is to perform one of these: http://en.wikipedia.org/wiki/Exorcism



Actually, what's probably happening is that your desktop has been extended, so what happens is that you've opened up windows onto the second display, but they still remain there even when the other monitor has been disconnected. What you can do is go to the Display utility and see if Fedora is still attempting to display to a second monitor. Turning it off might fix the problem.

Otherwise, the goat sacrifice might come in handy.
Reply With Quote
  #3  
Old 22nd November 2011, 03:54 AM
akvasu Offline
Registered User
 
Join Date: Feb 2005
Posts: 61
linuxfirefox
Re: Ghost Monitor....

I know how to recover - Restarting Shell OR going to the Display tool fixes the extended Display - Like i put in the post above too...

But this is a basic functionality - Suppose we switch to only External monitor and still see the same problem? That means when I need to carry my laptop to a meeting, I have NO display....

I´m looking on how to fix.... Opening the settings is not the right approach... this switch should be seamless....
Reply With Quote
  #4  
Old 22nd November 2011, 04:08 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,927
linuxfirefox
Re: Ghost Monitor....

...and when all else fails: Ctrl-Alt-Backspace
Reply With Quote
  #5  
Old 22nd November 2011, 04:47 AM
akvasu Offline
Registered User
 
Join Date: Feb 2005
Posts: 61
linuxfirefox
Re: Ghost Monitor....

Hi angryfirelord....

What would be the solution to a ¨Headless Laptop¨

I tried what I was talking about just now -- I connected the external monitor and then Switched OFF the laptop screen in Displays.... Now if I disconnect the monitor, the Laptop screen doesn´t come back on.... And if I reconnect the External Monitor, and Open Displays and Switch on the Laptop Monitor, Its unable to bring up the monitor back....

I need to reboot and disconnect the external monitor to get the laptop screen back....

This is la crappy software bug that should be fixed in ´pre-alpha´ stages... Bugzilla is not going to help probably

So now my question is - How to I renable the dual Displays? - If I connect the external monitor I just lose the Laptop Display!

Thanks

---------- Post added at 07:47 AM ---------- Previous post was at 07:09 AM ----------

Hi

I switched to Mirror Displays, and then back to dual displays and things look okay now - But my Gnome top panel and the ´Hot Corner´ have moved to the external Monitor - With the ´ghost monitor´ problem this automatically means I cannot remove my monitor at all How can I move the panel back to the Laptop Monitor ? I pored over all the gnome settings.... I can´t figure out which one to set....

Thanks
Anup
Reply With Quote
  #6  
Old 22nd November 2011, 05:11 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,927
linuxfirefox
Re: Ghost Monitor....

Restarting X should work and bring your laptop display back. Log out, log in again. Or press Ctrl-Alt-Backspace.

I run into these problems all the time when I go to a meeting and use a projector or big TV display and have taken to logging out before leaving the meeting room to prevent problems when I get back to my desk.
Reply With Quote
  #7  
Old 22nd November 2011, 06:20 AM
akvasu Offline
Registered User
 
Join Date: Feb 2005
Posts: 61
windows_7firefox
Re: Ghost Monitor....

I did this for resetting the Panel - edit /home/<username>/.config/monitors/xml - and set the LCD as primary and then restarted gnome 3

Looks okay now... but my laptops's ghost limb (monitor) still exists.... yeah will be logging off from now on...

I stopped using a Laptop Dock cuz of similar problems with Windoze...
Reply With Quote
Reply

Tags
ghost, monitor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How To Ghost Linux G4L vs Acronis vs Symantec Ghost vs Other mrbios Guides & Solutions (No Questions) 39 28th February 2010 10:19 PM


Current GMT-time: 11:03 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Avtury Travel Photos - Yen Bai - Queen Creek