Fedora Linux Support Community & Resources Center
  #1  
Old 27th November 2011, 07:15 PM
Linisth Offline
Registered User
 
Join Date: Nov 2011
Posts: 5
linuxfirefox
Question Fedora 16 and ATI help

I installed F16 (clean installation) on my laptop (Lenovo IdeaPad Y560)with 2 GPUs, Fedora seems to get my Intel card just fine, but when I install any (Propertary or RPM Fusion KMOD or AKMOD) X wont start, I did a lspci -nn | grep VGA and I can see both video cards. What am I doing wrong? Could anyone please help me or point me in the right direction?

Thanks in advance.

EDIT:

New information, after a further googling... I found out that my "xorg.conf" might be set up wrong, The only way to log into X after installing drivers is by removing my xorg.conf, then reboot into VESA mode, so now I did a lspci and got this"
Quote:
$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18)
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Madison [Mobility Radeon HD 5000 Series] [1002:68c0]
Now here is my actual xorg.conf...
Quote:
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
With this file I can NOT log into X at all... What am I doing wrong?

Last edited by Linisth; 28th November 2011 at 10:02 AM. Reason: UPDATE
Reply With Quote
  #2  
Old 28th November 2011, 05:57 PM
Linisth Offline
Registered User
 
Join Date: Nov 2011
Posts: 5
linuxfirefox
Re: Fedora 16 and ATI help

Yes, I think it is the "xorg.conf" file thats not setup properly I think... I belive that Linux took both video cards, but I can not still boot into X unless its on VESA mode....

...Any ideas?
Reply With Quote
  #3  
Old 10th April 2012, 07:54 PM
Don Colleone Offline
Registered User
 
Join Date: Mar 2011
Posts: 2
windows_7firefox
Re: Fedora 16 and ATI help

I know that Fedora 16 have some trouble with the proprietary driver from ATI. I wrote a little workaround for this bug. Unfortunately it is in german but maybe it will help you:

http://dc-zone.de/?p=314

Greetings
Reply With Quote
  #4  
Old 12th April 2012, 07:27 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,078
linuxfirefox
Re: Fedora 16 and ATI help

What the heck? All you have to do to install the ati driver is to enable rpmfusion repository and then

Code:
yum install kmod-catalyst
But this doesn't solve his problems with the two GPUs now, does it?
Reply With Quote
  #5  
Old 12th April 2012, 04:11 PM
Don Colleone Offline
Registered User
 
Join Date: Mar 2011
Posts: 2
windows_7firefox
Re: Fedora 16 and ATI help

Quote:
What the heck? All you have to do to install the ati driver is to enable rpmfusion repository and then
I think this not right. When you need better performance of your card, you have to use the original driver and not the kmod, because I think they are based on older drivers.

@Linisth: Another idea: If you doesn't need the Integrated Graphics Controller, I think you can deactivate it in your bios. Maybe this solves the problem.

PS: Oh my god, my english is so bad!
Reply With Quote
Reply

Tags
ati, fedora, x wont start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 21:34 (Tuesday, 21-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Hinckley Photos - Tarnaveni Instagram Photos - Konnur Photos