Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11th February 2012, 10:33 PM
Kaya Saman Offline
Registered User
 
Join Date: Dec 2004
Posts: 114
linuxfirefox
Gnome3 GDM user list not showing - would like to enable libfprint auth

Hi,

I am not sure if this is because my user doesn't show or if it's something else but am having difficulties in finding a solution.


Am running Fedora 16 x64 and up till just now was running it in runlevel mode 3 (init3) and using startx to start the X server.


Now, for whatever reason HW video acceleration was not enabled so in order to be able to make the most of my machine I had to make the switch.


Upon changing the /etc/systemd/system/default.target to runlevel5 I discovered that I don't have any users listed within the GDM greater so I have to manually enter the name. This is not an issue!


I do however want to enable the fingerprint reader for login authentication but it seems that without any users System Settings don't allow for ANY fingers to be 'scanned'.

My other boot is Fedora 15 x64 and was able to create scanned finger print images no problem. There doesn't seem to be a PAM module with that though so I was unable to login using the finger reader.


My concern right now is not F15 but F16 so to not get distracted and stay on track I need to be able to get the finger print reader working somehow.


I did discover this: http://miltus31.blogspot.com/2011/03...n-in-gdm3.html

which lead me to the /etc/pam.d directory, of which the contents are below (libfprint is installed on the system):

Code:
chfn                 gdm-welcome        poweroff           sshd
chsh                 gnome-screensaver  ppp                su
config-util          halt               reboot             sudo
crond                login              remote             sudo-i
fingerprint-auth     other              run_init           su-l
fingerprint-auth-ac  passwd             runuser            system-auth
gdm                  password-auth      runuser-l          system-auth-ac
gdm-autologin        password-auth-ac   smartcard-auth     v4l-conf
gdm-fingerprint      polkit-1           smartcard-auth-ac  xserver
gdm-password         postlogin          smtp
gdm-smartcard        postlogin-ac       smtp.sendmail

Can anyone help?


Thanks!

Last edited by Kaya Saman; 11th February 2012 at 10:35 PM.
Reply With Quote
  #2  
Old 4th April 2012, 08:39 AM
hmaarrfk Offline
Registered User
 
Join Date: Oct 2011
Posts: 220
linuxchrome
Re: Gnome3 GDM user list not showing - would like to enable libfprint auth

What is the make and model of your laptop?

You should be ale to go to the User Account settings, select your users and then find an entry with fingerprint login, then follow the on screen instructions for it.

(Press super/menu/windows key then type "user accounts")
Reply With Quote
  #3  
Old 8th April 2012, 01:49 PM
Kaya Saman Offline
Registered User
 
Join Date: Dec 2004
Posts: 114
linuxfirefox
Re: Gnome3 GDM user list not showing - would like to enable libfprint auth

Thanks for the response and sorry for the delay in getting back!

I managed to solve this.


I have a Lenovo X220 notebook; but my issue wasn't the system but infact the install. I did a minimal install which meant that Gnome3 wasn't really setup properly as unlike installing a full system some scripts or other internal components don't get run so bits go missing.


I can't remember exactly what I did but hopefully this will be a rundown:


fingerprint-auth file:

Code:
#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth        required      pam_env.so
auth        sufficient    pam_fprintd.so
auth        required      pam_deny.so

account     required      pam_unix.so
account     sufficient    pam_localuser.so
account     sufficient    pam_succeed_if.so uid < 1000 quiet
account     required      pam_permit.so

password    required      pam_deny.so

session     optional      pam_keyinit.so revoke
session     required      pam_limits.so
-session     optional      pam_systemd.so
session     [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session     required      pam_unix.so

fingerprint-auth-ac:


Code:
#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth        required      pam_env.so
auth        sufficient    pam_fprintd.so
auth        required      pam_deny.so

account     required      pam_unix.so
account     sufficient    pam_localuser.so
account     sufficient    pam_succeed_if.so uid < 1000 quiet
account     required      pam_permit.so

password    required      pam_deny.so

session     optional      pam_keyinit.so revoke
session     required      pam_limits.so
-session     optional      pam_systemd.so
session     [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session     required      pam_unix.so

system-auth:


Code:
#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth        required      pam_env.so
auth        sufficient    pam_fprintd.so
auth        sufficient    pam_unix.so nullok try_first_pass
auth        requisite     pam_succeed_if.so uid >= 1000 quiet
auth        required      pam_deny.so

account     required      pam_unix.so
account     sufficient    pam_localuser.so
account     sufficient    pam_succeed_if.so uid < 1000 quiet
account     required      pam_permit.so

password    requisite     pam_cracklib.so try_first_pass retry=3 type=
password    sufficient    pam_unix.so sha512 shadow nullok try_first_pass use_authtok
password    required      pam_deny.so

session     optional      pam_keyinit.so revoke
session     required      pam_limits.so
-session     optional      pam_systemd.so
session     [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session     required      pam_unix.so

Hopefully this will be sufficient for anyone else with the same issues or as an illustration (to the best of my recolection) as to what was added/changed within the setup.
Reply With Quote
Reply

Tags
auth, enable, gdm, gnome3, libfprint, list, showing, user

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome3 'normal look' disabled in F16 how to re-enable? Kaya Saman Using Fedora 5 29th January 2012 04:04 PM
[SOLVED] Enable Gnome3? mrjoeyman Using Fedora 9 1st November 2011 10:18 PM
How To Enable Gnome3 Extensions tox Guides & Solutions (No Questions) 6 1st June 2011 08:54 PM
To enable SMTP AUTH for Postfix (F-core 5) marpik Using Fedora 1 29th August 2006 01:28 PM
User auth in apache Fear Using Fedora 0 20th June 2005 11:00 PM


Current GMT-time: 15:42 (Thursday, 18-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat