Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20th February 2012, 01:08 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfirefox
How to set the default GRUB2 font and splash screen in Fedora

When I installed F16 on my laptop, the installer set up a coarse default font and a blank background. You have to use a manual method the set up the font and background splash. The following works for a wide screen. If you have a non-wide screen, adjust the numbers accordingly, and change the "wide" subdirectory to "standard".

Make a GRUB2 font using (ignore the screen messages - the font is still made)
Code:
grub2-mkfont --output=/boot/grub2/DejaVuSansMono.pf2 --size=24 /usr/share/fonts/dejavu/DejaVuSansMono.ttf
Edit /etc/default/grub and insert the following lines:
Code:
GRUB_FONT=/boot/grub2/DejaVuSansMono.pf2
GRUB_GFXMODE=1280x800
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/wide/verne.png
Rebuild the cfg file using
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
------------------Edited Jun 9, 2012--------------------

Note that F17 implements an alternative method of setting the grub2 theme. If you wish to use the new method, comment out GRUB_FONT and GRUB_BACKGROUND and uncomment GRUB_THEME. It points to a text file theme.txt which contains the variables you need to adjust. After adjusting, rebuild the cfg file as described above.

Last edited by plasmonics; 9th June 2012 at 01:07 PM. Reason: Software Upgrade
Reply With Quote
  #2  
Old 21st February 2012, 05:24 PM
kkshethin Offline
Registered User
 
Join Date: Dec 2009
Location: India
Posts: 318
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

thanks, i will try
Reply With Quote
  #3  
Old 23rd February 2012, 11:12 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,767
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

I've tried this and it worked well. I give it an 8 out of 10. There are some minor issues but nothing critical.

Thank you Plasmonics. I've been waiting for someone to figure this out. Since I like to have a menu background I've researched exaustively but the avalable (yes, I've seem them all) GRUB2 documentation, while good, is far from complete and quite lacking in a lot of areas.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #4  
Old 23rd February 2012, 03:21 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,844
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

Quote:
Originally Posted by plasmonics View Post
When I installed F16 on my laptop, the installer set up a coarse default font and a blank background. You have to use a manual method the set up the font and background splash. The following works for a wide screen. If you have a non-wide screen, adjust the numbers accordingly, and change the "wide" subdirectory to "standard".

Make a GRUB2 font using (ignore the screen messages - the font is still made)
Code:
grub2-mkfont --output=/boot/grub2/DejaVuSansMono.pf2 --size=24 /usr/share/fonts/dejavu/DejaVuSansMono.ttf
Edit /etc/default/grub and insert the following lines:
Code:
GRUB_FONT=/boot/grub2/DejaVuSansMono.pf2
GRUB_GFXMODE=1280x800
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/wide/verne.png
Rebuild the cfg file using
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
This will not work if the / partition is encrypted and there is no separate /usr partition - right? Can the image also be copied to /boot like the font?

Last edited by nonamedotc; 23rd February 2012 at 03:22 PM. Reason: added
Reply With Quote
  #5  
Old 23rd February 2012, 03:29 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxchrome
Re: How to set the default GRUB2 font and splash screen in Fedora

Quote:
Originally Posted by nonamedotc
Can the image also be copied to /boot like the font?
Yes. This is mine: GRUB_BACKGROUND=/boot/grub/farcry_3-1440x900.jpg
Reply With Quote
  #6  
Old 23rd February 2012, 03:32 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,844
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

Ah ! Excellent! Time to make the splash screen colorful
Reply With Quote
  #7  
Old 23rd February 2012, 07:48 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

The image file can be in any directory. It also doesn't have to be png.

The font can also be any ttf. I gave that example, because DejaVu is my default for many applications.


-----------------------
Correction (2/24/2012): It supports only tga, jpg, and png. grub2-mkconfig warns if the graphics format is unsupported.

Last edited by plasmonics; 24th February 2012 at 10:15 AM.
Reply With Quote
  #8  
Old 24th March 2012, 10:17 PM
synic Offline
Registered User
 
Join Date: Mar 2005
Location: Brisbane, Australia
Age: 43
Posts: 266
linuxopera
Re: How to set the default GRUB2 font and splash screen in Fedora

I'm having trouble with this. I've placed an image in /boot/grub/blue_energy_tornado_grub_splash.jpg but when I run grub2-mkconfig I get nothing..
Quote:
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Fedora"
GRUB_DEFAULT=0
GRUB_GFXMODE=1366x768
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND=/boot/grub/blue_energy_tornado_grub_splash.jpg
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8"
and

Quote:
[root@Faeland ~]# grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.3.0-4.fc16.x86_64
Found initrd image: /boot/initramfs-3.3.0-4.fc16.x86_64.img
Found linux image: /boot/vmlinuz-3.1.0-7.fc16.x86_64
Found initrd image: /boot/initramfs-3.1.0-7.fc16.x86_64.img
No volume groups found
done
[root@Faeland ~]#
What am I doing wrong?

EDIT:

Off topic but what about the Fedora loading screen; that comes up after grub but before the login screen? That takes longer. Anyone point me in the right direction for changing that one?

Thanks
__________________
Discourse and Diatribe

Last edited by synic; 24th March 2012 at 10:21 PM.
Reply With Quote
  #9  
Old 24th March 2012, 10:23 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxchrome
Re: How to set the default GRUB2 font and splash screen in Fedora

Quote:
Originally Posted by synic
What am I doing wrong?
You're failing to follow all the instructions. Go back up to post#1 of this thread and read it.
It won't work without the font file.
Reply With Quote
  #10  
Old 24th March 2012, 10:24 PM
synic Offline
Registered User
 
Join Date: Mar 2005
Location: Brisbane, Australia
Age: 43
Posts: 266
linuxopera
Re: How to set the default GRUB2 font and splash screen in Fedora

Ah... you HAVE to have the font title.

EDIT:

KOOOOOL Hell Yes..

Thanks.
__________________
Discourse and Diatribe

Last edited by synic; 24th March 2012 at 10:30 PM.
Reply With Quote
  #11  
Old 25th March 2012, 12:46 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

There is a code fragment in the bash script /etc/grub.d/00_header that looks for the font file. If it is not defined, it does not load the graphics part.

This is also the standard behaviour in another (non-Fedora) distro that I use.
Reply With Quote
  #12  
Old 25th March 2012, 07:33 PM
synic Offline
Registered User
 
Join Date: Mar 2005
Location: Brisbane, Australia
Age: 43
Posts: 266
linuxopera
Re: How to set the default GRUB2 font and splash screen in Fedora

Quote:
Originally Posted by plasmonics View Post
There is a code fragment in the bash script /etc/grub.d/00_header that looks for the font file. If it is not defined, it does not load the graphics part.

This is also the standard behaviour in another (non-Fedora) distro that I use.
That's what I wanted to know. Weird that Grub2 would require this feature in order to be customisable.
__________________
Discourse and Diatribe
Reply With Quote
  #13  
Old 3rd June 2012, 10:35 AM
callado Offline
Registered User
 
Join Date: Dec 2009
Posts: 4
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

Works well with Fedora 17 with the beefy-miracle image. I have two questions:
I used the same font and size as in #1, but the vertical borderlines are not continuous, they are broken between the lines. Should I use other font or how could I fix that?
How can I change the main title at the top?
Reply With Quote
  #14  
Old 3rd June 2012, 12:14 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfirefox
Re: How to set the default GRUB2 font and splash screen in Fedora

The vertical lines remain broken with DejaVu. This is true with Debian/grub2 as well. I believe that the border decorations are written into the font definition file. You can try reducing the font size. You can also experiment with other fonts in /usr/share/fonts. Not all of them work. In the end, I switched back to DejaVu.

I think the title is in /etc/defaults/grub.
Reply With Quote
  #15  
Old 8th June 2012, 11:56 AM
elias12 Offline
Registered User
 
Join Date: May 2012
Location: germany
Posts: 49
linuxchrome
Re: How to set the default GRUB2 font and splash screen in Fedora

Nice Thank you

Furthermore you do not want anything if you do a fresh install simply use the following steps to enable background.

Please open /etc/default/grub and uncomment the line "GRUB_THEME". Here an example for my config:
Code:
GRUB_TIMEOUT=30
GRUB_DISTRIBUTOR="Fedora"
GRUB_DEFAULT=saved
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=de rd.luks=0 LANG=en_US.UTF-8 rhgb quiet"
GRUB_THEME="/boot/grub2/themes/system/theme.txt"
In the "theme.txt" is all you need to install a theme. Sure, you can change the background by simple change the background with your favourite one. This is a standard-entry after the fresh FD17 install.

Don't forget to update grub as shown by @plasmonics
Reply With Quote
Reply

Tags
default, fedora, font, grub2, screen, set, splash

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is that hideous GRUB splash screen the current GRUB default? Mariusz W Reviews, Rants & Things That Make You Scream 10 29th May 2011 01:29 AM
Huge font/DPI on Splash Screen Crusnik01 Using Fedora 2 13th July 2008 12:19 PM
how do i get a splash screen for fedora 7? $Linux Installation, Upgrades and Live Media 0 10th October 2007 09:51 PM
Fedora 4 Splash Screen? carlwill Using Fedora 1 22nd October 2005 01:15 AM
How to make Splash screen default to gnome? Trendkill Using Fedora 10 4th April 2005 01:56 PM


Current GMT-time: 15:07 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Baqubah Photos on Instagram - Saubara Travel Photos - Tha Mai Photos