Fedora Linux Support Community & Resources Center
  #1  
Old 6th April 2012, 05:38 AM
adwaitnd Offline
Registered User
 
Join Date: Mar 2012
Posts: 2
windows_7firefox
additional drivers during install and grub2 file not found error after install

Hi everyone,
I am trying to install Fedora 16 on my laptop for a long time using a number of methods.
This has been my first experience with Fedora and it has been a lot scarier than Mint and Ubuntu, but I still want to get it working well.

The first problem I have is that the live-cd is unable to recognise my ethernet controller (realtek gigabit pci-e) so I cannot make upgrades during install. How do I include and install the drivers on the live installer (I use a USB drive for the liveCD). Realtek provides a .tar.gz of the driver on their website.

Also my access to the internet is restricted thru an authenticated proxy server, so where should these settings be configured? (since I could not get LAN itself working, figuring this out was impossible).

I still went thru the install without the internet connection and after rebooting got a "grub: file not found" error. After running scared and searching for any hints, I discovered that the whole problem is because the default prefix in grub2 is (hd0,7)/boot/grub while all the grub files are in (hd0,7)/boot/grub2. I can recover after loading the linux.mod from /boot/grub2 so I know the grub2 works but it just points to the wrong place. What do I use to rectify this problem? (If you suggest a grub2 reinstall, please tell me how to do it)

I also work at 2 places: one with the authenticated proxy and one without (limited download and bandwidth at the open internet connection place), so even after getting the whole install done, I would need an easy way to run atleast yum and the add/remove programs thru a authenticated proxy as well as a way to disable the proxy feature when required.

Surprisingly I had the same problems with all possible installers of fedora 16 (live desktop, KDE, LXDE, XFCE, DVD without live). The grub2 problem is also surprisingly across all the installers (which must mean that everyone has it when they first install fedora, right?).

What I want in the end is a fedora system which I can keep for a long time, so it would be better if somethings are properly installed rather than just making them work, hence PAE, ethernet & wireless (which are not detected by live or the basic installation), graphics drivers, proxy settings are some things that are required. And most of these require an internet connection during the installation itself.

Some details about the system:
Intel core i7 740QM, 4GB RAM, Nvidia Geforce GT 435M graphics, Realtek gigabit PCI-E Ethernet, (Wireless is something I never figured out) Intel Centrino controls the WiFi in Windows.

640 GB HDD divided as 1)100GB NTFS for Windows 2) 429 GB NTFS for storage 3)rest for where the linux should go is presently divided as 750MB (/dev/sda7) ext4 for /boot, 4GB swap and remaining(/dev/sda8) ext4 for the linux

I may have very high hopes for the install, but I think it should be possible since all these do happen very peacefully on other distros like Mint and Ubuntu.

---------- Post added at 04:38 AM ---------- Previous post was at 03:30 AM ----------

I was just wondering if the GRUB2 errors were because of selecting the first sector of /dev/sda7 instead of the MBR (/dev/sda) to install GRUB2? Since the GRUB2 installation is flimsy, I didnt want to mess up the main bootloader (how would I recover this if I have the same problems?)

Would installing it in MBR avoid all these problems?
Reply With Quote
Reply

Tags
additional, drivers, error, file, grub2, install, proxy

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub2 install error. TNWestTex Using Fedora 3 24th January 2012 12:00 AM
after network install, Error 15: file not found ln3wb13 Installation, Upgrades and Live Media 5 23rd July 2008 03:39 PM
Can't install additional packages: CD not found in drive. darkmatter Using Fedora 0 28th June 2005 09:44 PM


Current GMT-time: 04:37 (Wednesday, 03-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat