Fedora Linux Support Community & Resources Center
  #1  
Old 10th April 2012, 06:55 PM
sgage Offline
Registered User
 
Join Date: Nov 2010
Posts: 50
linuxfirefox
Nautilus forgets its settings...

I have had this come up a couple of times so far in Fedora 16: Nautilus forgets its settings after I've set it to list view by default and to show hidden files. For a while (a day or two) all is well, but then it suddenly starts up with icon view, no hidden files. I set the preferences again, but next time it starts up, same thing. It also forgets its window size.

The only way that I've been able to find to fix this is to delete the dconf database (~/.config/dconf/user), which of course wipes out all kinds of other customization. Reinstalling nautilus does not help.

Anyway, it just happened again - it might have been associated with trying to add a bookmark.

Has anyone else seen this behavior?
Reply With Quote
  #2  
Old 10th April 2012, 08:15 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,330
linuxfirefox
Re: Nautilus forgets its settings...

I have seen the window state not being honored after a reboot, and always starts maximized. Once i minimize it, then it honors the setting until I reboot again.

I have double checked to make certain that org.gnome.nautilus.window-state maximized is set to be off and it will still come up maximized the first time I start nautilus after a reboot.

I haven't looked into much other than filing a bug report since I am getting ready to throw Gnome into the bit-bucket anyway due to numerous other issues.
Reply With Quote
  #3  
Old 28th May 2012, 01:03 AM
Proxin Offline
Registered User
 
Join Date: May 2012
Location: United States
Posts: 23
linuxfirefox
Re: Nautilus forgets its settings...

I've had a similar issue with Gnome 3 on Fedora 16- I have the time displaying as AM/PM, while the default Fedora setting turns this to military time.
Occassionally, I'll look at the clock and it will say something like "15:48" instead of "3:48 PM" which I specifically set it to. Same thing happens with trackpad touch click; I have it enabled, but gnome decides to forget that and revert to default settings once in a while.
It really frustrates me because there is one setting that is essential to me... I'm running this on a laptop, and I went out of my way to set the "close lid" action to be "nothing", instead of turning my computer to sleep mode each time the lid is closed.
So when I get this glitch, I'll have to completely reboot so I can even close the lid of my laptop. Very annoying.

One temporary fix is to press alt+f2 and type 'r' to restart gnome shell. This fixes the time format for me, but not the sleep mode thing. I end up having to reboot each time this happens.
I really hope someone can help with these issues.

Last edited by Proxin; 28th May 2012 at 01:28 AM.
Reply With Quote
  #4  
Old 28th May 2012, 05:45 AM
cazo Offline
Registered User
 
Join Date: Sep 2005
Location: Redneck Riviera
Posts: 363
linuxchrome
Re: Nautilus forgets its settings...

I've noticed the same issue as Proxin, until I realized that it happened when I launched gedit as root (using 'su -' in a terminal window, then running gedit from there). Certain programs seem to cause /usr/libexec/gnome-settings-daemon (I think that's the one) to start up for 'root', and then gnome-shell seems to use root's default settings. As root, I made several changes using gsettings, like:
Code:
gsettings set org.gnome.desktop.interface clock-format 12h
which seems to have taken care of most of the problems. I don't recall if killing root's /usr/libexec/gnome-settings-daemon made things like the clock format go back, since I also learned not to launch those programs as root anymore

Every once in a while, some programs also lose their settings (like window size). Killing my normal user's /usr/libexec/gconfd-2 (which usually respawns itself) normally takes care of it for me. One way I've found to tell it's time to kill is one window (usually gnome-terminal) will take up the background of the "Activities" view, instead of being 'tiled' like the others. I'm not sure if my description is very clear (unless you've seen it too), but I don't have a screenshot of that to post (I try to get one the next time I see it).

It may or may not be relevant, but I normally just 'suspend' (sometimes 'hibernate') my laptop instead of logging out and/or powering down. At least, until there's another kernel (or other important) update.
Reply With Quote
  #5  
Old 28th May 2012, 07:24 AM
Proxin Offline
Registered User
 
Join Date: May 2012
Location: United States
Posts: 23
linuxfirefox
Re: Nautilus forgets its settings...

Quote:
Originally Posted by cazo View Post
I've noticed the same issue as Proxin, until I realized that it happened when I launched gedit as root (using 'su -' in a terminal window, then running gedit from there). Certain programs seem to cause /usr/libexec/gnome-settings-daemon (I think that's the one) to start up for 'root', and then gnome-shell seems to use root's default settings. As root, I made several changes using gsettings, like:
Code:
gsettings set org.gnome.desktop.interface clock-format 12h
which seems to have taken care of most of the problems. I don't recall if killing root's /usr/libexec/gnome-settings-daemon made things like the clock format go back, since I also learned not to launch those programs as root anymore

Every once in a while, some programs also lose their settings (like window size). Killing my normal user's /usr/libexec/gconfd-2 (which usually respawns itself) normally takes care of it for me. One way I've found to tell it's time to kill is one window (usually gnome-terminal) will take up the background of the "Activities" view, instead of being 'tiled' like the others. I'm not sure if my description is very clear (unless you've seen it too), but I don't have a screenshot of that to post (I try to get one the next time I see it).

It may or may not be relevant, but I normally just 'suspend' (sometimes 'hibernate') my laptop instead of logging out and/or powering down. At least, until there's another kernel (or other important) update.

Looks like that's the cause for me as well- launching gedit from a 'su -' terminal prompt. I tried using your gsettings recommendation but that didn't fix it for me... same with going into standby mode.
Does anybody have a panacea fix for us with this problem?
Reply With Quote
Reply

Tags
forgets, nautilus, settings

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
nautilus is not remembering settings COKEDUDE Using Fedora 5 14th September 2011 07:28 AM
nautilus settings in kde F.User_4_Life Using Fedora 4 18th June 2008 07:37 PM
OpenOffice.org forgets changes to settings mpolo Using Fedora 0 13th August 2005 10:11 AM
Gnome in FC3 "forgets" my settings eiffleduarte Using Fedora 0 25th January 2005 11:23 AM


Current GMT-time: 04:07 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Pueblo Nuevo Travel Photos - Kasongo - Obrenovac