Fedora Linux Support Community & Resources Center
  #1  
Old 12th April 2012, 07:44 PM
g8jvm Offline
Registered User
 
Join Date: Aug 2010
Posts: 256
linuxfirefox
wireless not reconnecting after suspend

Hi
laptop Dell N5030 , on FC16 x86_64

When booting up, it finds the wireless network without a problem.
But after suspend, closing the lid, I'm repeatedly ased for the password to connect, sometimes it will accept, but often its quicker to reboot.
Is anything known of this problem ?
It has got worse recently and its up to date on updates, so maybe something there.
Ideas or suggestions ?, I have already googled , but not much relevant,

TIA
Richard

---------- Post added at 07:20 PM ---------- Previous post was at 12:57 PM ----------

A bit more info.
When returning from hibernation it ntakes at least two manual attemps to login to the wireless network,
but it will eventually connnect. but it takes a long time.

from a suspended period it will not play, its saying needs authentication, but its minutes before a password is requested., and that has no effect, again and again and again.
the wireless router is a good signal, I've tried changing the WPA flavours and still no change.

But my little android phone logs in to the wirless network no matter what I do to it.

This was working , until a recent update, possibly a new kernel, not sure , but its a PITA.

TIA
Richard

---------- Post added at 07:44 PM ---------- Previous post was at 07:20 PM ----------

Regressing back to kernel 3,3,0-8 clears the problem !
Culprit lastest kernel ??
Reply With Quote
  #2  
Old 13th April 2012, 11:47 AM
esbennn Offline
Registered User
 
Join Date: Sep 2010
Location: Dk
Posts: 100
linuxopera
Re: wireless not reconnecting after suspend

I have been having this same problem for the past few days.
I think it started after i did an update on april 8., but that upgrade didn't seem to contain any network related packages. Like you, i have noticed that it only happens after suspend, not after reboot.

I have also discovered, that if I connect to some other network, it connects fine to that, and then I am once again able to connect to the first (my) network.
Using the laptop as a hotspot like this:

also seems to 'reset' the wireless connection, allowing me to connect to my router afterwards.

Could it be that it's related to something else than networkmanager, say Gnome?

I've checked dmesg and /var/log/messages after errors, but haven't found anything 'useful'.

I too would much appreciate any help on this.
Reply With Quote
  #3  
Old 13th April 2012, 12:40 PM
g8jvm Offline
Registered User
 
Join Date: Aug 2010
Posts: 256
linuxfirefox
Re: wireless not reconnecting after suspend

I'm finding the problem goes when reverting back to kernel 3.3.0-8, from 3.3.1, that points to the kernel
I think.
Reply With Quote
  #4  
Old 13th April 2012, 04:54 PM
esbennn Offline
Registered User
 
Join Date: Sep 2010
Location: Dk
Posts: 100
linuxopera
Re: wireless not reconnecting after suspend

Sounds legit. Damn annoying, though.
Guess we'll just have to wait for a kernel update and see how it turns out.
Reply With Quote
  #5  
Old 16th April 2012, 09:39 PM
Rafal Offline
Registered User
 
Join Date: Apr 2012
Location: Cyprus
Posts: 1
linuxfirefox
Re: wireless not reconnecting after suspend

Hello
Thank you for this thread. I have just moved from Mandriva to Fedora 16 x86_64 on my Portégé Z830-10H. After updates I started to fight with wireless reconnection problem after suspend or hibernation. I confirm, that going back to previous kernel (from the installation DVD) solve the problem.
Rafal
Reply With Quote
  #6  
Old 17th April 2012, 01:23 AM
loleary Offline
Registered User
 
Join Date: Jun 2008
Location: St Louis, MO, USA
Posts: 23
linuxfirefox
Re: wireless not reconnecting after suspend

Has anyone reported this as a bug? I couldn't seem to find a related Bugzilla. Seems like a bad idea to asume the Kernel team or Fedora project will stumble across this thread.
----
Larrry
https://plus.google.com/112645929986009801513
Reply With Quote
  #7  
Old 17th April 2012, 09:42 AM
g8jvm Offline
Registered User
 
Join Date: Aug 2010
Posts: 256
linuxfirefox
Re: wireless not reconnecting after suspend

I havn't, the last I put in against a kernel I got flamed for,
It will always be anything else except the kernel.
Unless of course it effects one of the kernel team

Richard
Reply With Quote
  #8  
Old 17th April 2012, 04:23 PM
Dutchy Online
Registered User
 
Join Date: Aug 2011
Posts: 1,012
linuxfirefox
Re: wireless not reconnecting after suspend

Quote:
Originally Posted by esbennn View Post
I have also discovered, that if I connect to some other network, it connects fine to that, and then I am once again able to connect to the first (my) network.
Using the laptop as a hotspot like this:
Another workaround for Atheros:
Code:
# modprobe -r ath9k && modprobe ath9k
Reply With Quote
  #9  
Old 18th April 2012, 11:38 AM
hieronymous Offline
Registered User
 
Join Date: Jan 2012
Location: auckland
Posts: 77
linuxfirefox
Re: wireless not reconnecting after suspend

Hi

See https://bugzilla.redhat.com/show_bug.cgi?id=810678
Reply With Quote
  #10  
Old 19th April 2012, 11:03 AM
esbennn Offline
Registered User
 
Join Date: Sep 2010
Location: Dk
Posts: 100
linuxopera
Re: wireless not reconnecting after suspend

@ Dutchy - thanks for the workaround
@ hieronymous - thanks for posting to bugzilla.

A comment in the bug report states that this should be fixed with kernel 3.3.2.

Can anyone confirm this? 3.3.2 is available in the repo
Reply With Quote
  #11  
Old 19th April 2012, 11:18 AM
hieronymous Offline
Registered User
 
Join Date: Jan 2012
Location: auckland
Posts: 77
linuxfirefox
Re: wireless not reconnecting after suspend

Hi

Yes, kernel 3.3.2 is working for me (ath9k driver).
Reply With Quote
  #12  
Old 19th April 2012, 12:14 PM
esbennn Offline
Registered User
 
Join Date: Sep 2010
Location: Dk
Posts: 100
linuxopera
Re: wireless not reconnecting after suspend

Quote:
Originally Posted by hieronymous View Post
Hi

Yes, kernel 3.3.2 is working for me (ath9k driver).
Awesome, that's god news
Reply With Quote
Reply

Tags
reconnecting, suspend, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F13 Dropping Internet Connection and not Reconnecting seanelvidge Servers & Networking 1 28th September 2010 06:33 PM
F13: No wireless after suspend using iwl3945 dillinga Hardware & Laptops 2 21st June 2010 01:04 AM
Network Manager keeps reconnecting WPA wireless connection bjorau Servers & Networking 10 11th February 2009 10:49 PM
Bluetooth not reconnecting at boot ESC201 Servers & Networking 1 5th January 2009 01:12 AM
USB device (joystick) keeps disconnecting and reconnecting Prion Using Fedora 1 18th November 2004 02:22 AM


Current GMT-time: 18:10 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat