Fedora Linux Support Community & Resources Center
  #1  
Old 23rd May 2012, 03:31 PM
jarrett Offline
Registered User
 
Join Date: Oct 2005
Posts: 26
linuxchrome
Wine install on F17, protected multilib

Hi,
I'm trying to install wine on F17 however I am running into some problems with protected multilib versions.
Code:
Error: Protected multilib versions: fontconfig-2.8.0-6.fc17.i686 != fontconfig-2.8.0-7.fc17.x86_64
Error: Protected multilib versions: libdrm-2.4.33-1.fc17.i686 != libdrm-2.4.33-3.fc17.x86_64
Error: Protected multilib versions: libpciaccess-0.13-2.fc17.i686 != libpciaccess-0.13.1-1.fc17.x86_64
Error: Protected multilib versions: glib2-2.32.1-1.fc17.i686 != glib2-2.32.3-1.fc17.x86_64
Error: Protected multilib versions: libxcb-1.8-2.fc17.i686 != libxcb-1.8.1-1.fc17.x86_64
Error: Protected multilib versions: libgphoto2-2.4.11-3.fc17.i686 != libgphoto2-2.4.14-1.fc17.x86_64
Error: Protected multilib versions: openldap-2.4.30-2.fc17.i686 != openldap-2.4.31-2.fc17.x86_64
Error: Protected multilib versions: 2:libogg-1.2.2-4.fc17.i686 != 2:libogg-1.3.0-1.fc17.x86_64
yum update says nothing needs updating.
repos enabled:
f17, f17 updates, rpm fusion free, rpm fusion free updates, rpm fusion nonfree, rpm fusion nonfree updates.

Help?

PS: I finally found my way back to Fedora after not using it for a couple of years. I like the Gnome 3 shell thing. Been using Arch with KDE since last time I had fedora running. Cheers!
Reply With Quote
  #2  
Old 23rd May 2012, 04:08 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: Wine install on F17, protected multilib

you probably installed some of the packages before F17 disabled the updates-testing repo, so you got newer versions than are available in the standard fedora and updates repo.

Try enabling the updates-testing repo and run it again.

Code:
yum --enablerepo=updates-testing install wine
Reply With Quote
  #3  
Old 23rd May 2012, 04:23 PM
jarrett Offline
Registered User
 
Join Date: Oct 2005
Posts: 26
linuxchrome
Re: Wine install on F17, protected multilib

Quote:
Originally Posted by DBelton View Post
you probably installed some of the packages before F17 disabled the updates-testing repo, so you got newer versions than are available in the standard fedora and updates repo.

Try enabling the updates-testing repo and run it again.

Code:
yum --enablerepo=updates-testing install wine
yah, that did the trick, thank you!!
Reply With Quote
  #4  
Old 23rd May 2012, 04:35 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: Wine install on F17, protected multilib

Also, unless you enable the updates-testing repo, you won't get many updates at all until after the F17 release. The only updates getting pushed into the stable repo are the critical blocker bug fixes, all the other updates are going to be in updates-testing until after the release.

I usually go back and re-enable the updates-testing repo after the update disables it right before a release.
Reply With Quote
  #5  
Old 23rd May 2012, 04:40 PM
jarrett Offline
Registered User
 
Join Date: Oct 2005
Posts: 26
linuxchrome
Re: Wine install on F17, protected multilib

On that note, when the final version is released do I need to update my repo sources?
Reply With Quote
  #6  
Old 23rd May 2012, 04:47 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: Wine install on F17, protected multilib

if you manually edit your repo files to enable updates-testing, then you would need to manually edit it again when the final version is released if you wish to go back and disable it. The update has already happened that disabled it, future updates should leave it how you have it now.

But other than that, there is no reason you should need to update your repo files just because the final version is released.

(Rpmfusion has also disabled their updates-testing repos with an update as well, if you have those installed)
Reply With Quote
  #7  
Old 23rd May 2012, 04:59 PM
jarrett Offline
Registered User
 
Join Date: Oct 2005
Posts: 26
linuxchrome
Re: Wine install on F17, protected multilib

alright, thanks buddy!
Reply With Quote
Reply

Tags
f17, install, multilib, protected, wine

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dependencies resolution errors: multilib cheesie F15 Development 18 14th May 2011 07:31 PM
How to build multilib RPM package in X86-64 helloworld1 Using Fedora 1 5th December 2009 08:47 PM
Fedora 7 multilib. Thetargos Using Fedora 4 26th June 2007 11:35 AM
NVIDIA Livna driver and multilib. Thetargos Using Fedora 3 12th March 2007 06:28 PM
Is Fedora protected?? mickeyboy Using Fedora 5 10th November 2006 11:41 AM


Current GMT-time: 04:24 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Erbil - Iraq Travel Photos - Same - Esmeraldas - Ecuador Travel Photos on Instagram - Santana De Parnaiba Instagram Photos