Fedora Linux Support Community & Resources Center
  #1  
Old 8th June 2012, 05:23 AM
rurikc Offline
Registered User
 
Join Date: Jan 2010
Posts: 65
linuxfirefox
PulseAudio: Card not detected for all but one user

Hi,

I have a F16 install with two users.

Une user sees the "internal audio analog stereo" in pavucontrol and can play sounds.

The other user and root see only the Dummy device and there is no playback (i.e. there is but on the Dumy device).

I am currently puzzled

Any suggestions appreciated.

Cheers.
Reply With Quote
  #2  
Old 12th June 2012, 06:29 AM
rurikc Offline
Registered User
 
Join Date: Jan 2010
Posts: 65
linuxfirefox
Re: PulseAudio: Card not detected for all but one user

Continuing ...

It seems that only one user may control one audio device at a time ...

So, how can I enable other (local) users to connect to my (local) pulse audio server ?

I see a ~/.pulse-cookie but how do I use it ?

Cheers.
Reply With Quote
  #3  
Old 12th June 2012, 02:56 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: PulseAudio: Card not detected for all but one user

If you mean that you want both to use pulseaudio at once, maybe this Google search ( https://encrypted.google.com/search?...l=&gs_l=&pbx=1 ) helps?
(not saying that you don't now how to search, but just in case)
Reply With Quote
  #4  
Old 12th June 2012, 11:19 PM
rurikc Offline
Registered User
 
Join Date: Jan 2010
Posts: 65
linuxfirefox
Re: PulseAudio: Card not detected for all but one user

Thanks for the reply.

Interestingly I thought about searching for multiple users but not for two ... what do you know

Anyway I came across this solution that so far works for me:

Main user

Copy

Code:
/etc/pulse/default.pa
to

Code:
~/.pulse/default.pa
Add:

Code:
load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1
Second User

Create

Code:
~/.pulse/client.conf
and add

Code:
default-server = 127.0.0.1
With this configuration, when the second user launches an application that uses pulseaudio, it will connect to the main user's pulseaudio instance.

Reference: http://forums.fedoraforum.org/showthread.php?t=190954
Reply With Quote
Reply

Tags
card, detected, pulseaudio, user

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Removed pulseaudio, no soundcard detected now! dataghost Hardware & Laptops 5 27th December 2010 03:09 PM
[Fedora 9 - No sound] Detla 44 not detected by pulseaudio Zeppe|in Hardware & Laptops 9 19th August 2008 12:01 PM
pulseaudio won't start as normal user a thing Using Fedora 1 28th July 2008 05:08 AM
displaying detected USB devices like an SD card reader and card KB1LQC Hardware & Laptops 1 27th June 2008 07:01 AM
ipw2200 wireless card detected as ethernet card tmort Hardware & Laptops 49 17th January 2007 11:00 PM


Current GMT-time: 05:54 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Rockingham Photos on Instagram - Kaimori Travel Photos on Instagram - Karabaglar Photos on Instagram