Fedora Linux Support Community & Resources Center
  #1  
Old 15th June 2012, 04:17 AM
maximus456 Offline
Registered User
 
Join Date: Jun 2012
Location: chicago
Posts: 2
linuxfirefox
protected multilib, wine

trying to install wine, but i get a massive error message.
been looking for a way arround this for days
here it is:
[CODE]
Error: Protected multilib versions: flac-1.2.1-8.fc16.i686 != flac-1.2.1-6.fc12.x8
Error: Protected multilib versions: gd-2.0.35-14.fc16.i686 != gd-2.0.35-13.fc16.x8
Error: Protected multilib versions: mesa-dri-filesystem-7.11.2-3.fc16.i686 != mesa.fc16.x86_64
Error: Protected multilib versions: libusb1-1.0.9-0.6.rc1.fc16.i686 != libusb1-1.0
Error: Protected multilib versions: pixman-0.24.4-1.fc16.i686 != pixman-0.22.2-1.f
Error: Protected multilib versions: freetype-2.4.6-5.fc16.i686 != freetype-2.4.6-3
Error: Protected multilib versions: libdrm-2.4.33-1.fc16.i686 != libdrm-2.4.26-3.f
Error: Protected multilib versions: gnutls-2.12.14-2.fc16.i686 != gnutls-2.12.7-2.
Error: Protected multilib versions: cyrus-sasl-lib-2.1.23-27.fc16.i686 != cyrus-sax86_64
Error: Protected multilib versions: 1:libvorbis-1.3.3-1.fc16.i686 != 1:libvorbis-1
Error: Protected multilib versions: glibc-2.14.90-24.fc16.7.i686 != glibc-2.14.90-
Error: Protected multilib versions: 2:libpng-1.2.49-1.fc16.i686 != 2:libpng-1.2.46
Error: Protected multilib versions: llvm-libs-2.9-10.fc16.i686 != llvm-libs-2.9-4.
Error: Protected multilib versions: libjpeg-turbo-1.2.0-1.fc16.i686 != libjpeg-tur
Error: Protected multilib versions: glib2-2.30.3-1.fc16.i686 != glib2-2.30.1-1.fc1
Error: Protected multilib versions: mesa-libGLU-7.11.2-3.fc16.i686 != mesa-libGLU-
Error: Protected multilib versions: gstreamer-plugins-base-0.10.35-3.fc16.i686 != -0.10.35-1.fc16.x86_64
Error: Protected multilib versions: libstdc++-4.6.3-2.fc16.i686 != libstdc++-4.6.2
Error: Protected multilib versions: libXi-1.4.5-1.fc16.i686 != libXi-1.4.3-3.fc16.
Error: Protected multilib versions: mesa-libGL-7.11.2-3.fc16.i686 != mesa-libGL-7.
Error: Protected multilib versions: libXext-1.3.0-1.fc16.i686 != libXext-1.2.0-2.f
Error: Protected multilib versions: zlib-1.2.5-6.fc16.i686 != zlib-1.2.5-4.fc16.x8
Error: Protected multilib versions: libtasn1-2.12-1.fc16.i686 != libtasn1-2.7-2.fc
Error: Protected multilib versions: libgcc-4.6.3-2.fc16.i686 != libgcc-4.6.2-1.fc1
Error: Protected multilib versions: libselinux-2.1.6-6.fc16.i686 != libselinux-2.1
Error: Protected multilib versions: libuuid-2.20.1-2.3.fc16.i686 != libuuid-2.20.1
Error: Protected multilib versions: expat-2.1.0-1.fc16.i686 != expat-2.0.1-11.fc15
Error: Protected multilib versions: alsa-plugins-pulseaudio-1.0.25-3.fc16.i686 != o-1.0.24-2.fc15.x86_64
Error: Protected multilib versions: orc-0.4.16-5.fc16.i686 != orc-0.4.16-4.fc16.x8
Error: Protected multilib versions: alsa-lib-1.0.25-1.fc16.i686 != alsa-lib-1.0.24
Error: Protected multilib versions: mesa-dri-drivers-7.11.2-3.fc16.i686 != mesa-drx86_64
Error: Protected multilib versions: openldap-2.4.26-7.fc16.i686 != openldap-2.4.26
Error: Protected multilib versions: 2:libogg-1.3.0-1.fc16.i686 != 2:libogg-1.2.2-3
[CODE]
thanks for any help
Reply With Quote
  #2  
Old 15th June 2012, 04:36 AM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,709
linuxfirefox
Re: protected multilib, wine

These are conflicts between 32-bit and 64-bit versions of the same libraries. Check this thread out and see if that helps.

This happens once in a while ... At times, I have resolved some of these by removing the conflicting libraries first and reinstalling them - too cumbersome if there are too many of these. Do look at the thread mentioned above.

Welcome to the forum.

---------- Post added at 10:36 PM ---------- Previous post was at 10:35 PM ----------

Quote:
Originally Posted by maximus456 View Post
trying to install wine, but i get a massive error message.
been looking for a way arround this for days
here it is:
[CODE]
Error: Protected multilib versions: flac-1.2.1-8.fc16.i686 != flac-1.2.1-6.fc12.x8
Error: Protected multilib versions: gd-2.0.35-14.fc16.i686 != gd-2.0.35-13.fc16.x8
Error: Protected multilib versions: mesa-dri-filesystem-7.11.2-3.fc16.i686 != [ ... ]
[CODE]
thanks for any help
Is the text indicated a typo? it says fc12?!?!
Reply With Quote
  #3  
Old 18th June 2012, 04:56 AM
maximus456 Offline
Registered User
 
Join Date: Jun 2012
Location: chicago
Posts: 2
linuxfirefox
Re: protected multilib, wine

looks like in that other thread they were having problems with duplicate packages, but they didn't say how to check what packages were duplicates. (well, there was, but it did't list anything). so if it is a conflict between 64 and 32, how do i check for what's causing the problem?
thanks
Reply With Quote
Reply

Tags
multilib, protected, protected multilib, wine

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wine install on F17, protected multilib jarrett F17 Development Forum 6 23rd May 2012 03:59 PM
dependencies resolution errors: multilib cheesie F15 Development 18 14th May 2011 06:31 PM
How to build multilib RPM package in X86-64 helloworld1 Using Fedora 1 5th December 2009 07:47 PM
Fedora 7 multilib. Thetargos Using Fedora 4 26th June 2007 10:35 AM
NVIDIA Livna driver and multilib. Thetargos Using Fedora 3 12th March 2007 05:28 PM


Current GMT-time: 03:07 (Saturday, 26-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat