Fedora Linux Support Community & Resources Center
  #1  
Old 17th June 2012, 11:26 PM
allan_r Offline
Registered User
 
Join Date: Oct 2006
Posts: 39
linuxfirefox
fedora slow boot

Fedora seem to be taking some time to boot, it pauses for awhile on :
"Daemon for monitoring attached scanners....."
Is there a srevice I can disabe to stop this?

Thanks.
Reply With Quote
  #2  
Old 17th June 2012, 11:31 PM
IonIvan Offline
Registered User
 
Join Date: Oct 2011
Posts: 7
linuxchrome
Re: fedora slow boot

systemctl disable colord-sane.service
Reply With Quote
  #3  
Old 18th June 2012, 03:09 AM
allan_r Offline
Registered User
 
Join Date: Oct 2006
Posts: 39
linuxfirefox
Re: fedora slow boot

I tried that, it still get run at boot up.
Reply With Quote
  #4  
Old 19th June 2012, 02:16 AM
JamesNZ Offline
Registered User
 
Join Date: Aug 2010
Location: Wellington, New Zealand
Age: 16
Posts: 902
linuxchrome
Re: fedora slow boot

Run as root:
Code:
systemd-analyze blame
That gives you a list of services started at boot and how long they take to complete. If you see some services you don't need then you can disable them either with systemctl disable <serviceName>, or systemctl mask <serviceName>. If you use the mask option then the service will be symlinked to /dev/null, which makes it impossible for fedora to use it
__________________
"For what is a man profited if he gains the whole world, but loses his own soul?"

- Jesus
Reply With Quote
  #5  
Old 20th June 2012, 01:28 AM
allan_r Offline
Registered User
 
Join Date: Oct 2006
Posts: 39
linuxfirefox
Re: fedora slow boot

[root@localhost allan]# systemd-analyze blame
60201ms home-allan-server.mount
60165ms home-allan-storage.mount
9768ms udev-settle.service
9533ms fedora-loadmodules.service
5242ms systemd-vconsole-setup.service
4991ms proc-fs-nfsd.mount
4526ms udev-trigger.service
3997ms media.mount
3968ms sys-kernel-debug.mount
3949ms dev-mqueue.mount
3935ms sys-kernel-security.mount
3916ms dev-hugepages.mount
3700ms fedora-readonly.service
3562ms var-lib-nfs-rpc_pipefs.mount
3546ms udev.service
2911ms systemd-remount-api-vfs.service
2906ms remount-rootfs.service
1734ms sys-kernel-config.mount
1179ms fedora-storage-init.service
1002ms systemd-sysctl.service
836ms systemd-readahead-replay.service
820ms systemd-readahead-collect.service
541ms NetworkManager.service
470ms mdmonitor-takeover.service
457ms avahi-daemon.service
417ms nfs-server.service
396ms chronyd.service
383ms rsyslog.service
358ms fedora-storage-init-late.service
350ms console-kit-log-system-start.service
288ms systemd-logind.service
281ms iscsid.service
281ms netfs.service
273ms sandbox.service
269ms iptables.service
267ms ip6tables.service
261ms libvirtd.service
247ms auditd.service
246ms mcelog.service
237ms gpm.service
229ms irqbalance.service
228ms sshd-keygen.service
208ms acpid.service
205ms dbus.service
184ms abrt-vmcore.service
181ms abrt-ccpp.service
181ms systemd-tmpfiles-setup.service
167ms lvm2-monitor.service
122ms home-allan-sda.mount
119ms nfs-idmap.service
118ms nmb.service
87ms smb.service
80ms console-kit-daemon.service
53ms boot.mount
50ms fedora-wait-storage.service
45ms libvirt-guests.service
44ms rtkit-daemon.service
40ms rpcbind.service
38ms home.mount
32ms xinetd.service
18ms systemd-user-sessions.service
0ms sys-fs-fuse-connections.mount
Reply With Quote
  #6  
Old 23rd June 2012, 08:15 AM
JamesNZ Offline
Registered User
 
Join Date: Aug 2010
Location: Wellington, New Zealand
Age: 16
Posts: 902
linuxchrome
Re: fedora slow boot

The biggest ones seem to be home-allan-server.mount and home-allan-storage.mount. I'm not sure what those do, so you can run 'systemctl status <name.service> to get their description. If you do not have an LVM or RAID setup then you can disable these services:
fedora-storage-init.service
fedora-storage-init-late.service
lvm2-monitor.service

You can also disable iscsi.service if you don't boot from a network.

HTH
__________________
"For what is a man profited if he gains the whole world, but loses his own soul?"

- Jesus
Reply With Quote
  #7  
Old 2nd July 2012, 08:41 PM
allan_r Offline
Registered User
 
Join Date: Oct 2006
Posts: 39
linuxfirefox
Re: fedora slow boot

It was my NFS mounts that was causing the delay, I'm gonna take a look at my mount options and see why.
My NFS server is down right now so it will be a few days before I can check it out, but will let you know what I find if any.
Reply With Quote
Reply

Tags
boot, fedora, slow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Very Slow Boot on Fedora 16 suryaharis Using Fedora 1 18th March 2012 09:41 AM
My fedora 15 very slow to boot vinnyparker Installation, Upgrades and Live Media 9 22nd August 2011 12:40 PM
Fedora 11: Slow boot time mattyjim Using Fedora 10 6th December 2009 10:52 PM
fedora 8 very slow boot Orang Using Fedora 4 2nd September 2008 04:37 PM
Fedora Core 6 Slow Boot slowcivic2k Using Fedora 3 5th March 2007 10:04 PM


Current GMT-time: 07:00 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat