Fedora Linux Support Community & Resources Center
  #1  
Old 19th June 2012, 03:38 AM
zoroid Offline
Registered User
 
Join Date: Jun 2012
Location: Sydney
Posts: 6
linuxfirefox
Skype no microphone

FIXED Skype MICROPHONE with

yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter

then in skype went to OPTIONS then SOUND DEVICES then open pulseaudo volume control set the mikes to rear mikes and set the volume on the webcam a logitec device and it now recording works!!!!!
Boy wot a saga
Zoroid[COLOR="Silver"]

Fixed on my machine as below
Hope it works for others
Cheers
Zoroid

Hi, using Fedora 17 KDE 32 bit on intel core duo 3.0 ghz nvidia and asus board 4g ddr3.

skype installed OK but refused to find my rear mike, and no voice at all.
I note in Kmix there are no capture devices at all and no sign of microphone settings.
Skype normally configures this but no luck.at all.
I tried uninstalling and then reinstalling pulseaudio but no joy either.

Fedora is most reluctant to accept my password requiring 30 seconds or more to eventually proceed.

Multimedia is difficult and Kaffeine will not play at all saying----- " Cannot find input plugin for MRL "dvd:///dev/sr0"
despite having libdvdcss2 and w32codecs. and No package videodvd available. so kaput.

Took Fedora KDE for a spin as I dislike Gnome 3, and find it more difficult than Debian KDE so far.

But guess we are a work in progress.

Regards

Zoroid

Last edited by zoroid; 26th June 2012 at 01:44 AM.
Reply With Quote
  #2  
Old 19th June 2012, 05:17 AM
jbuckley2004 Online
Registered User
 
Join Date: Dec 2008
Location: Maryland
Posts: 261
linuxfirefox
Re: Skype no microphone

Zoroid, I had a similar problem that I think I solved.
First, I had to go to system settings/multimedia to change my input from front to rear mic.

Then, in Skype, I had to go to options/sound devices and change the microphone setting (it was under phonon for me; it may be different for you).

Now, I'm not sure why, because it was set to "default" and the default device used to be the correct one. Yesterday I had to go through the entire list before I discovered the correct one. After that I was able to make a test call and hear my own voice back.

But I'm not satisfied that the setting is really correct. The quality was not as I remember. Oh, yes, I had to go to kmix and up the volume level there too for the capture device, and like you, I was surprised to see only the two entries instead of the dozen or so I used to see in F14, F15 and F16.

The 30 second delay in logging in seems to be a new (and unrelated) problem. That one just showed up for me yesterday also.
Reply With Quote
  #3  
Old 19th June 2012, 12:58 PM
zoroid Offline
Registered User
 
Join Date: Jun 2012
Location: Sydney
Posts: 6
linuxfirefox
Re: Skype no microphone

Certainly this is quite a long standing problem in Fedora,
and the short half life of releases perhaps mitigate against any fix soon.
Chris Smart of Koroora in Oz fixed it before perhaps better ask him how he did it as it worked on this same machine.

The old posts below did not fix the Fedora 17 Skype microphone issue either but thanx for trying.

pulseaudio-libs libv4l were present but-----

One of the alsa-plugins-pulseaudio as described in one old post was missing but my hopes were dashed as this failed after install also.
Best of luck
zoroid

Last edited by zoroid; 19th June 2012 at 01:08 PM.
Reply With Quote
  #4  
Old 19th June 2012, 02:03 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,503
linuxchrome
Re: Skype no microphone

There's one solution that worked for me in an OLD Ubuntu install, and I think it's worked once or twice here, but not sure.
http://ubuntuforums.org/showpost.php...97&postcount=9

It's also failed to help other people, but worth trying.
Reply With Quote
  #5  
Old 20th June 2012, 12:52 PM
zoroid Offline
Registered User
 
Join Date: Jun 2012
Location: Sydney
Posts: 6
linuxfirefox
Re: Skype no microphone

Hi, sm54
no such package sorry to say
thanx for trying
growing tired of this quest
think fedora 17 can't pick up the hardware
best
zoroid


Quote:
Originally Posted by smr54 View Post
There's one solution that worked for me in an OLD Ubuntu install, and I think it's worked once or twice here, but not sure.
http://ubuntuforums.org/showpost.php...97&postcount=9

It's also failed to help other people, but worth trying.
Reply With Quote
  #6  
Old 25th June 2012, 10:45 AM
zoroid Offline
Registered User
 
Join Date: Jun 2012
Location: Sydney
Posts: 6
linuxfirefox
Re: Skype no microphone

Oh well this mike problem in Skype
will most likely infect Fedora 18 rawhide as well unfortunately.
Perhaps Redhat has it too.
I thought ALSA might be under pulseaudio, but there does not appear to be an ALSA package to be had.
Ho Hum
Zoroid

---------- Post added at 07:33 PM ---------- Previous post was at 07:08 PM ----------

FIXED Skype MICROPHONE with

yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter

then in skype went to OPTIONS then SOUND DEVICES then open pulseaudo volume control set the mikes to rear mikes and set the volume on the webcam a logitec device and it now recording works!!!!!
Boy wot a saga
Zoroid[COLOR="Silver"]

---------- Post added at 07:39 PM ---------- Previous post was at 07:33 PM ----------

---------- Post added at 07:45 PM ---------- Previous post was at 07:39 PM ----------

Fixed on my machine as below
Hope it works for others
Cheers
Zoroid

Last edited by zoroid; 25th June 2012 at 10:43 AM.
Reply With Quote
  #7  
Old 25th June 2012, 02:37 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,503
linuxopera
Re: Skype no microphone

Glad that you got it fixed. As the originator of the thread, you can mark it SOLVED if you want, by clicking on the thread tools link at the top.
I'm sure this will help others as time goes on.
Reply With Quote
  #8  
Old 26th June 2012, 01:52 AM
zoroid Offline
Registered User
 
Join Date: Jun 2012
Location: Sydney
Posts: 6
linuxfirefox
Re: Skype no microphone

Hope it works for others
Cheers
zoroid


Quote:
Originally Posted by smr54 View Post
Glad that you got it fixed. As the originator of the thread, you can mark it SOLVED if you want, by clicking on the thread tools link at the top.
I'm sure this will help others as time goes on.
Reply With Quote
  #9  
Old 29th June 2012, 09:32 PM
bonar Offline
Registered User
 
Join Date: Aug 2007
Posts: 4
linuxfirefox
Re: Skype no microphone

mine still cannot work with mic..
already done this :-

Quote:
################################################## #######################################
yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter

The Result :-

Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Package pulseaudio-0.9.21-7.fc14.i686 already installed and latest version
Package alsa-plugins-pulseaudio-1.0.24-2.fc14.i686 already installed and latest version
Package pulseaudio-esound-compat-0.9.21-7.fc14.i686 already installed and latest version
Package pulseaudio-libs-0.9.21-7.fc14.i686 already installed and latest version
Package pulseaudio-libs-glib2-0.9.21-7.fc14.i686 already installed and latest version
Package pulseaudio-module-zeroconf-0.9.21-7.fc14.i686 already installed and latest version
Package pulseaudio-libs-zeroconf-0.9.21-7.fc14.i686 already installed and latest version
Package xmms-pulse-0.9.4-8.fc12.i686 already installed and latest version
Package pulseaudio-module-gconf-0.9.21-7.fc14.i686 already installed and latest version
Package wine-pulseaudio-1.3.24-1.fc14.i686 already installed and latest version
Package xine-lib-1.1.19-2.fc14.2.i686 already installed and latest version
Package pulseaudio-utils-0.9.21-7.fc14.i686 already installed and latest version
Package pulseaudio-module-bluetooth-0.9.21-7.fc14.i686 already installed and latest version
No package gst-mixer available.
Package padevchooser-0.9.4-0.11.svn20070925.fc13.i686 already installed and latest version
Package paman-0.9.4-4.fc12.i686 already installed and latest version
Package paprefs-0.9.9-6.fc13.i686 already installed and latest version
Package pavucontrol-0.9.10-1.fc13.i686 already installed and latest version
Package pavumeter-0.9.3-4.fc12.i686 already installed and latest version
Nothing to do


################################################## #######################################


I can't select other than the pulseaudio server (local)..
Fedora 14..
Reply With Quote
  #10  
Old 29th June 2012, 11:15 PM
bonar Offline
Registered User
 
Join Date: Aug 2007
Posts: 4
linuxfirefox
Re: Skype no microphone

I solved it using this thread -> http://forums.fedoraforum.org/showth...=1#post1588587

Quote:
amixer -c 0 set 'Input Source' 'Digital Mic'
amixer -c 0 set 'Digital Mic' 20dB
thanks..

mine's sound even better with -> amixer -c 0 set 'Digital Mic' 10dB

Last edited by bonar; 29th June 2012 at 11:18 PM.
Reply With Quote
  #11  
Old 3rd July 2012, 07:04 PM
bonar Offline
Registered User
 
Join Date: Aug 2007
Posts: 4
linuxfirefox
Re: Skype no microphone

For Fedora 15 -> Laptop Alienware M17 R3

put this line under modprobe :-

vi /etc/modprobe.d/dist.conf

Quote:
options snd-hda-intel model=auto
options snd-hda-intel power_save=0
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss

then there are new amixer scontrols named 'Internal Mic'

amixer -c1 scontrols


Quote:
Simple mixer control 'Master',0
Simple mixer control 'Headphone',0
Simple mixer control 'Speaker',0
Simple mixer control 'PCM',0
Simple mixer control 'Front',0
Simple mixer control 'Mic',0
Simple mixer control 'Mic Jack Mode',0
Simple mixer control 'IEC958',0
Simple mixer control 'IEC958 Default PCM',0
Simple mixer control 'IEC958 Playback Source',0
Simple mixer control 'IEC958 Playback Source',1
Simple mixer control 'IEC958',1
Simple mixer control 'IEC958',2
Simple mixer control 'IEC958',3
Simple mixer control 'Beep',0
Simple mixer control 'Capture',0
Simple mixer control 'Digital',0
Simple mixer control 'Internal Mic',0
Reply With Quote
Reply

Tags
microphone, skype

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Skype Video/Microphone Not Working mikemike787878 Hardware & Laptops 10 15th May 2013 03:03 PM
Skype microphone volume in F16 MuadNu Using Fedora 4 20th June 2012 05:34 PM
Yet another Skype microphone issue! darkscot Hardware & Laptops 12 18th July 2011 02:41 PM
Skype & microphone / mics theoracle Using Fedora 10 18th January 2010 09:11 AM
FC4 microphone, skype Laura Hardware & Laptops 3 5th October 2005 02:04 PM


Current GMT-time: 06:45 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat