Fedora Linux Support Community & Resources Center
  #1  
Old 19th July 2012, 06:15 AM
ro6ot Offline
Registered User
 
Join Date: Jul 2011
Posts: 12
linuxfirefox
[SOLVED] Can't mount NFS after Fedora 17 upgrade

My client is running Fedora 17 and my NFS server is also running Fedora 17. All work well before upgrading both systems from 16 to 17. Anyone see anything obvious?? For troubleshooting purposes, I have iptables stopped.

From the client I run 'sudo mount -v -t nfs 192.168.1.10:/home/ro6ot/docs /mnt/docs/'

the output is:
mount.nfs: timeout set for Wed Jul 18 22:03:22 2012
mount.nfs: trying text-based options 'vers=4,addr=192.168.1.10,clientaddr=192.168.1.101 '
mount.nfs: mount(2): Connection refused

on the server..

exportfs shows:
/home/ro6ot/docs
192.168.1.101

systemctl status nfs-server.service
nfs-server.service - NFS Server
Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; disabled)
Active: active (exited) since Wed, 18 Jul 2012 21:40:58 -0600; 29min ago
Process: 1965 ExecStartPost=/usr/lib/nfs-utils/scripts/nfs-server.postconfig (code=exited, status=0/SUCCESS)
Process: 1963 ExecStart=/usr/sbin/rpc.nfsd $RPCNFSDARGS ${RPCNFSDCOUNT} (code=exited, status=0/SUCCESS)
Process: 1960 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=0/SUCCESS)
Process: 1954 ExecStartPre=/usr/lib/nfs-utils/scripts/nfs-server.preconfig (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/nfs-server.service

systemctl status nfs-lock.service
nfs-lock.service - NFS file locking service.
Loaded: loaded (/usr/lib/systemd/system/nfs-lock.service; disabled)
Active: active (running) since Wed, 18 Jul 2012 21:42:59 -0600; 47s ago
Process: 2040 ExecStart=/sbin/rpc.statd $STATDARG (code=exited, status=0/SUCCESS)
Process: 2034 ExecStartPre=/usr/lib/nfs-utils/scripts/nfs-lock.preconfig (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/nfs-lock.service
├ 2041 /sbin/rpc.statd
└ 2043 /usr/sbin/sm-notify

cat /etc/sysconfig/nfs
#
# Define which protocol versions mountd
# will advertise. The values are "no" or "yes"
# with yes being the default
#MOUNTD_NFS_V2="no"
#MOUNTD_NFS_V3="no"
#
#
# Path to remote quota server. See rquotad(8)
#RQUOTAD="/usr/sbin/rpc.rquotad"
# Port rquotad should listen on.
#RQUOTAD_PORT=875
# Optinal options passed to rquotad
#RPCRQUOTADOPTS=""
#
#
# Optional arguments passed to in-kernel lockd
#LOCKDARG=
# TCP port rpc.lockd should listen on.
LOCKD_TCPPORT=32803
# UDP port rpc.lockd should listen on.
LOCKD_UDPPORT=32769
#
#
# Optional arguments passed to rpc.nfsd. See rpc.nfsd(8)
# Turn off v2 and v3 protocol support
#RPCNFSDARGS="-N 2 -N 3"
# Turn off v4 protocol support
#RPCNFSDARGS="-N 4"
# Number of nfs server processes to be started.
# The default is 8.
#RPCNFSDCOUNT=8
# Stop the nfsd module from being pre-loaded
#NFSD_MODULE="noload"
# Set V4 grace period in seconds
#NFSD_V4_GRACE=90
#
#
# Optional arguments passed to rpc.mountd. See rpc.mountd(8)
#RPCMOUNTDOPTS=""
# Port rpc.mountd should listen on.
MOUNTD_PORT=892
#
#
# Optional arguments passed to rpc.statd. See rpc.statd(8)
#STATDARG=""
# Port rpc.statd should listen on.
STATD_PORT=662
# Outgoing port statd should use. The default port is random.
#STATD_OUTGOING_PORT=2020
# Specify callout program
#STATD_HA_CALLOUT="/usr/local/bin/foo"
#
#
# Optional arguments passed to rpc.idmapd. See rpc.idmapd(8)
#RPCIDMAPDARGS=""
#
# Set to turn on Secure NFS mounts.
#SECURE_NFS="yes"
# Optional arguments passed to rpc.gssd. See rpc.gssd(8)
#RPCGSSDARGS=""
# Optional arguments passed to rpc.svcgssd. See rpc.svcgssd(8)
#RPCSVCGSSDARGS=""
#
# To enable RDMA support on the server by setting this to
# the port the serve

Last edited by ro6ot; 20th July 2012 at 04:28 AM. Reason: solved, editing title
Reply With Quote
  #2  
Old 19th July 2012, 06:43 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,989
linuxfirefox
Re: Can't mount NFS after Fedora 17 upgrade

No - post the actual output - your editted version is no help

Quote:
exportfs shows:
/home/ro6ot/docs
192.168.1.101
Note that nfsv4 is now the default so the server share point is typicallycalle '/' the root of the share, not thh host path "/home/..." That is not the current problem.

Step1 - make sure you can mount from the server to the server.
Step2 - with the server firewall disabled try frm the client.
Observe the traffic w/ wireshark if you must.to determine ports.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #3  
Old 19th July 2012, 06:56 AM
ro6ot Offline
Registered User
 
Join Date: Jul 2011
Posts: 12
linuxsafari
Re: Can't mount NFS after Fedora 17 upgrade

That is the actual output of 'exportfs'. Could that be part of the problem?

I'll try your steps and post what happens. Thanks!
Reply With Quote
  #4  
Old 20th July 2012, 04:27 AM
ro6ot Offline
Registered User
 
Join Date: Jul 2011
Posts: 12
linuxfirefox
Re: Can't mount NFS after Fedora 17 upgrade

With iptables stopped I tried to mount from the server to the server with the command below and I get the same error I get from the client. I'm also posting the contents of '/etc/exports' and the results of 'exportfs' to see if it's any help. Thanks in advance

[root@machine ro6ot]# mount -v -t nfs 192.168.1.10:/home/ro6ot/docs /mnt/docs/
mount.nfs: timeout set for Thu Jul 19 20:01:12 2012
mount.nfs: trying text-based options 'port=2049,vers=4,addr=192.168.1.10,clientaddr=192 .168.1.10'
mount.nfs: mount(2): Connection refused

[root@machine ro6ot]# cat /etc/exports
/home/ro6ot/docs 192.168.1.0/24(rw,fsid=0,insecure,no_root_squash,anonuid=1000, anongid=1000)

[root@machine ro6ot]# exportfs
/home/ro6ot/docs
192.168.1.0/24

[root@machine ro6ot]# systemctl status iptables.service
iptables.service - IPv4 firewall with iptables
Loaded: loaded (/usr/lib/systemd/system/iptables.service; disabled)
Active: inactive (dead) since Thu, 19 Jul 2012 19:46:28 -0600; 18min ago
Main PID: 776 (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/iptables.service

Jul 19 19:46:28 machine iptables.init[2145]: iptables: Flushing firewall rules: [ OK ]
Jul 19 19:46:28 machine iptables.init[2145]: iptables: Setting chains to policy ACCEPT: filter [ OK ]
Jul 19 19:46:28 machine iptables.init[2145]: iptables: Unloading modules: [ OK ]

---------- Post added at 08:27 PM ---------- Previous post was at 08:07 PM ----------

I fixed the issue by removing nfs.utils, deleting the contents of /etc/exports/, and starting over following the guide:

http://docs.fedoraproject.org/en-US/...uring_NFS.html
Reply With Quote
  #5  
Old 19th August 2012, 07:18 PM
lensman3 Offline
Registered User
 
Join Date: Dec 2009
Location: Centennial, Colorado USA
Posts: 128
linuxchrome
Re: Can't mount NFS after Fedora 17 upgrade

Had the same problem with this. A two month on a F17 install and then installed F17 on my wife's computer and nfs wouldn't connect. The problem was iptables. The install doesn't update the firewall on the server. I added the the following:

-A INPUT -m state --state NEW -m tcp -p tcp --dport 2049 -j ACCEPT
-A INPUT -m state --state NEW -m udp -p udp --dport 2049 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 51466 -j ACCEPT
-A INPUT -m state --state NEW -m udp -p udp --dport 33442 -j ACCEPT

in /etc/sysconfig/iptables

Your ports may change if you tweak /etc/sysconfig/nfs standard ports. Use "rpcinfo -p" to get the used port numbers.

All the helps seem to have a "stupidity" for starting nfs the first time:
"systemctl restart nfs-server.service". This uses the command restart. The first time it needs to be "systemctl enable nfs-server.service" to set up the proper "ln -s" hooks. Then "systemctl start nfs-service" so that is starts without having to reboot.

Last edited by lensman3; 19th August 2012 at 07:27 PM. Reason: Should be enable then start for the first time.
Reply With Quote
  #6  
Old 7th January 2013, 04:02 AM
kbkblee Offline
Registered User
 
Join Date: Oct 2004
Posts: 5
linuxfirefox
Re: Can't mount NFS after Fedora 17 upgrade

Did you do the following two things on the server?

1. autofs -r
2. service nfs-server restart
Reply With Quote
Reply

Tags
fedora, mount, nfs, upgrade

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Upgrade to F15, nfs dirs don't mount during boot pjhacnau Using Fedora 9 8th June 2011 03:10 AM
nfs mount problem after upgrade to Fedora 14 mrcampbell Servers & Networking 9 8th February 2011 09:26 PM
Upgrade to fedora 12 failed: VFS: unable to mount root fs d0cd0c Installation, Upgrades and Live Media 1 21st November 2009 12:16 AM
Can't mount one ext3 fs after upgrade to FC5 oradev EOL (End Of Life) Versions 1 11th June 2006 09:25 PM


Current GMT-time: 18:51 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Kemer Photos on Instagram - Herford Photos on Instagram - Schorndorf Travel Photos on Instagram