Fedora Linux Support Community & Resources Center
  #1  
Old 15th December 2004, 05:31 PM
farley Offline
Registered User
 
Join Date: Nov 2004
Posts: 13
FC3 Distorted / Crackling Sound Problem Possible Solution

I have had a consistent problem with distorted and crackling sound in FC3 using gnome. In searching these forums it appears others are experiencing the same problem. I tried all of the proposed solutions, rebooting after each attempt, including compiling and installing the ALSA drivers from scratch. None of these solutions fixed my sound problem. What finally worked for me was to uncheck "Enable sound server startup" in the Sound preferences panel.

To do this:
Applications->Preferences->Sound
Select the General Tab
Uncheck "Enable sound server startup" if it is checked.
Click "Close"

I rebooted after I did this but you might just need to log out and log back in.
My sound is now clear with no distortion.

It may be possible that it was some combination of all the things I changed but I can state positvely that the sound only cleared up after I unchecked the sound server startup option.
Reply With Quote
  #2  
Old 15th December 2004, 06:49 PM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 45
Posts: 8,256
Thanks for tip. I dont never user sound server startup just enable sound is enough for most of us.
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
  #3  
Old 15th December 2004, 06:54 PM
Nachum Offline
Registered User
 
Join Date: Dec 2004
Posts: 1
Hello!

Where i cam get manuel of FC3


Tanks
Reply With Quote
  #4  
Old 15th December 2004, 07:16 PM
deviant03 Offline
Registered User
 
Join Date: Nov 2004
Location: New York City
Posts: 29
farley, just curious what soundcard are you using? By default that option was already unchecked for me under sound but I am still getting "scratchy" audio (both kaffeine and xmms) with my nforce2 (Asus A7N8X) onboard audio. Its not a huge problem but I definitely notice a degradation in sound quality (ie. when heavy bass kicks in) compared to win xp.

Last edited by deviant03; 15th December 2004 at 07:19 PM.
Reply With Quote
  #5  
Old 15th December 2004, 09:08 PM
sej7278 Offline
Registered User
 
Join Date: Sep 2004
Posts: 2,008
I have the same thing with my IWill KK266-R's onboard CMedia 8737, was the same with SUSE 9.1 and FC2. My laptop works fine with FC3 though.

Maybe I'll try my old Santa Cruz or SoundBlaster 128 cards....

I seem to recall having this issue with some old Mandrake 9 and it may have been the sound server (arts starting as well as ALSA).

Turning off the Surround Sounds helps a bit (card doesn't support surround!) and it also seems to make a difference what mixer app you use.
Reply With Quote
  #6  
Old 16th December 2004, 02:56 AM
farley Offline
Registered User
 
Join Date: Nov 2004
Posts: 13
deviant03 - I am using the integrated sound hardware on my Gigabyte GA-8I848P-G motherboard. The specs for the board say it is "Realtek ALC850 7.1-Channel Codec".
Reply With Quote
  #7  
Old 16th December 2004, 03:24 AM
crackers Offline
Retired Community Manager
 
Join Date: Feb 2004
Location: Seattle, WA, USA
Age: 57
Posts: 3,423
Quote:
Originally Posted by deviant03
Its not a huge problem but I definitely notice a degradation in sound quality (ie. when heavy bass kicks in) compared to win xp.
You'll probably need to adjust your equalizer settings (this is what I had to do with XMMS) as the Alsa driver is very good at boosting the lower end of the spectrum and I was over-driving the speakers. If you're not using something that's got an equalizer attached to it, you might need to massage, using the mixer of your choice, the combination of inputs (for audio files, this is the "Wave" input), the Master, and the PCM (actual volume control) and the volume/tone knob on the speakers until you stop over-driving.
__________________
Linux User #28251 (April '93)
Professional Java Geek :cool:
Reply With Quote
  #8  
Old 18th December 2004, 10:46 PM
deviant03 Offline
Registered User
 
Join Date: Nov 2004
Location: New York City
Posts: 29
Derf.. lowering the volume in xmms did the trick thanks crackers. Alsa seems to sound pretty damn good now after some "critical listening"
Reply With Quote
  #9  
Old 21st December 2004, 12:33 AM
kennon Offline
Registered User
 
Join Date: May 2004
Location: Central California
Posts: 36
I noticed that if I go into the ALSA mixer and turn the PCM volume slider way down it significantly decreases/eliminiates the distortion without lowering the volume too much.
__________________
All those moments will be lost in time...like tears in the rain...
Reply With Quote
  #10  
Old 24th January 2005, 11:48 AM
Gwadj Offline
Registered User
 
Join Date: Jan 2005
Posts: 1
Quote:
Originally Posted by kennon
I noticed that if I go into the ALSA mixer and turn the PCM volume slider way down it significantly decreases/eliminiates the distortion without lowering the volume too much.
I also lowered PCM volume from about 98% to 48% and it helped a lot! Also lowering the 3D Control Sigmatel volume helped. Now my bass is pumping so loud that I couldn't believe it! Furnitures are jumping and neighbors are calling the police!
Reply With Quote
  #11  
Old 25th January 2005, 03:16 AM
crackers Offline
Retired Community Manager
 
Join Date: Feb 2004
Location: Seattle, WA, USA
Age: 57
Posts: 3,423
And things are right with the world...

Nothing like pumping out "American Idiot" at full Spinal Tap volume!
__________________
Linux User #28251 (April '93)
Professional Java Geek :cool:
Reply With Quote
  #12  
Old 25th January 2005, 11:34 AM
neilius Offline
Registered User
 
Join Date: Aug 2004
Location: London, UK
Age: 31
Posts: 47
You know what's cool about ALSA? It goes up to 11! You see, most sound driver models only go up to 10, and you're playing away at ten, but want to go further... Where can you go from there? Well you can't, but ALSA goes up to 11! Is that louder I hear you ask? Well, it's one louder isn't it?
Reply With Quote
  #13  
Old 25th January 2005, 03:49 PM
astronoman
Guest
 
Posts: n/a
I had this same problem w/CDs. If for any reason you still want the sound server started, use this
Quote:
/sbin/hdparm -u1 /dev/hdc
Got it from the MPlayer documentation. I had no need to mess w/equalizer settings.
Reply With Quote
Reply

Tags
crackling, distorted, fc3, problem, solution, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F11 Sound Crackling in Media Players kevross_33 Using Fedora 5 15th September 2009 04:42 PM
Choosing sound in FC5 to stop crackling code_astronomer Using Fedora 0 3rd April 2006 02:06 AM
Fuzzy crackling sound snowfox333 Using Fedora 1 13th August 2005 05:46 PM


Current GMT-time: 18:59 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat