Fedora Linux Support Community & Resources Center
  #1  
Old 5th January 2005, 11:41 AM
dickinsd Offline
Registered User
 
Join Date: Nov 2004
Location: Bristol, UK
Posts: 470
Wireless not working after kernel update

Hello guys.

I think I know the answer to this - I hope I don't

Basically I spent a little while getting my wireless card working on my laptop (FC3)

Last nightI donwloaded the new kernel now my wireless card no longer works.

is there anything I need to do to get it in tiptop shape again?

With FC3 you have to download the kernel source your self, I am assuming my updated kernel will not have its source code, I think your answer is basically going to be along the lines of making me have to do everything I did in the first place to get the damn thing to work.

I have a horrible feeling your gonne say I need to get the kernel source, and build that, then go through all the other junk related to getting my card working - I have my own tips for doing this and I know they work, but if I have t do it all again, and the kernel source stuff, I think I am going to cry.

I really think that is far too much work.

let me know

Dave
Reply With Quote
  #2  
Old 5th January 2005, 02:30 PM
dickinsd Offline
Registered User
 
Join Date: Nov 2004
Location: Bristol, UK
Posts: 470
just a follow up,

when I said I downloaded a new kernel, I mean that I donwloaded the kernel update through up2date.

When the system is booting up, I get a little error telling me that eth1 mac address is not what the system expected (something along them lines)

If I go to the Network icon under system settings: I am told that eth1 is inactive. if I try to activate it, I get the same error about MAC address.

If I try to add a new wireless device, my card is not there.

This is pretty much the same as it was when I first installed FC3, and it took me a while to figure out.

I am fairly convinced that if I download the kernel, and follow my own guide it willwork again, however I seem to remember having a lot of trouble getting the source code downloaded and installed - something I definately wish I had made a note of!

Can someone please give me a step by step command list for getting and installing the latest kernel code from a FC3 repository - I would appreciate this a lot.

Thank you

Dave
Reply With Quote
  #3  
Old 5th January 2005, 02:44 PM
sly Offline
Registered User
 
Join Date: Jan 2005
Location: Florida :(
Age: 34
Posts: 4
i have the same issue: new kernel update - wireless down. i think you're right. have to get the source and recompile ndiswrapper on my case. i will not bother w/ this now cuz i don't wanna go thru all that **** again.
__________________
sly
(561)601-4303
dsyc@go.ro
73 6c 79
Reply With Quote
  #4  
Old 5th January 2005, 05:23 PM
mjman Offline
Registered User
 
Join Date: Oct 2004
Posts: 286
For some reason, for me, the new kernel does not work with ndiswrapper greater than version 0.10. Therefore, in order to make it work with the new kernel, i installed the sourcecode for the new kernel, then installed ndiswrapper v.0.10
Reply With Quote
  #5  
Old 5th January 2005, 07:52 PM
mrguytx Offline
Registered User
 
Join Date: Sep 2004
Location: Austin, TX
Posts: 40
if you are talking about the .10 kernel, the same happened to me, and I'm pretty sure it's because many of the wireless drivers that have been in the past FC kernel releases were left out in this early stage.

I would recommend going back to the .681 kernel until the final release of the FC3 .10 kernel. I did that and everything is working as it should be, I just had to reinstall my nvidia driver which now takes about 30 seconds since I've done it so many times.
Reply With Quote
  #6  
Old 5th January 2005, 08:01 PM
headclark Offline
Registered User
 
Join Date: Dec 2004
Location: South Florida
Posts: 45
.681 kernel has dvd-burning issues (just an FYI for those who go back).

I am running kernel 2.6.10-1084_FC4 with ndiswrapper 1.0...no probs.

Made rpm using ndiswrapper tar file (make rpm).
Reply With Quote
  #7  
Old 5th January 2005, 09:53 PM
greeners Offline
Registered User
 
Join Date: Sep 2004
Posts: 16
I can't believe this but I am NOT having wireless problems after the kernel update. I've got a Toshiba Satellite Pro 4600 which is using the orinoco_cs driver. I've had endless problem with this with FC2 and FC3 is the same; I have to disable ACPI. I don't think this is your problem though.

However I am wondering what the orinoco_cs update was all about. Where does one find out this sort of thing when you're a newbie (I'm a newbie).

Thanks,
Reply With Quote
  #8  
Old 7th January 2005, 12:28 AM
dickinsd Offline
Registered User
 
Join Date: Nov 2004
Location: Bristol, UK
Posts: 470
I am just using the kernel update that the redhat update thingy told me about.

Sorry, currenty on a windows box so can't check namesand details so I will e even more vague than normal :-(

I think the kernel version was something like 754 (I think) and definately only FC3 - I did not even know that FC4 was out?

As for the redhat update thingy - I am on about that little icon next to the clock that goes red when it finds new downloads.

To be honest I just decided to stick with kernel .681, it works - well almost I can't get my laptop to turn off properly any more and the battery meter dosnt' work, but then from what I saw of kernel .754 (I think) the power down still does not work, and I did not notice the battery meter updating itself, so for me, I am not sure what benefits I would have by changing to latest kernel.

For now I have just set my grub.conf to go for the previous kernel - the one that my wireless works fine with.

I would still like a line for line command list that would talk me through finding, downloading, installing and building the kernel source code if any one has it??

Cheerz

Dave
Reply With Quote
  #9  
Old 10th January 2005, 12:41 PM
telmo Offline
Registered User
 
Join Date: Nov 2004
Location: Braga -Portugal
Age: 38
Posts: 107
Quote:
Originally Posted by headclark
.681 kernel has dvd-burning issues (just an FYI for those who go back).

I am running kernel 2.6.10-1084_FC4 with ndiswrapper 1.0...no probs.

Made rpm using ndiswrapper tar file (make rpm).
Can you say where did you get the FC4 kernel please?
__________________
Keep it simple!
Reply With Quote
  #10  
Old 5th February 2005, 10:18 AM
bogy01 Offline
Registered User
 
Join Date: Feb 2005
Posts: 5
New kernel update

I have just upgraded to the newest kernel... (2.6.10-1.760_FC3) I ran make clean - make - make install in my ndiswrapper-0.12 directory and I am up and running again after a modprobe ndiswrapper. I also tried the final ndiswrapper-1 version but it did not work... the 0.12 one still does! Hope this helps!

Reply With Quote
Reply

Tags
kernel, update, wireless, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless not working after update piranhaz Servers & Networking 2 29th August 2009 10:31 AM
USB wireless adapter not working after update trailer8713 Servers & Networking 28 8th December 2008 02:31 AM
Wireless connection not working after update patrox Hardware & Laptops 1 4th March 2008 08:15 PM
Kernel update stops wireless card working. earobinson111 Using Fedora 11 23rd August 2004 03:58 PM


Current GMT-time: 08:26 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Lichtenburg Travel Photos on Instagram - Fatikchari Instagram Photos - Huancavelica Photos on Instagram