Fedora Linux Support Community & Resources Center
  #1  
Old 10th March 2005, 09:56 AM
kiang Offline
Registered User
 
Join Date: Oct 2004
Posts: 2
Error when setting up LDAP server on FC3??

I did choose 'Server' when installing FC3. I did the following steps after finishing :

1. rpm -ivh ftp://apt.nc.hcc.edu.tw/pub/apt/fedo...3.hcc.i386.rpm
2. apt-get update
3. apt-get -y dist-upgrade
4. apt-get install openldap-servers openldap-clients
## Upgrade to the latest version of FC3
5. rpm -ivh ftp://rpmfind.net/linux/dag/fedora/3...c3.rf.i386.rpm
## CPU is a tool for managing LDAP accounts
6. vi /etc/openldap/slapd.conf

database bdb
suffix "dc=my-domain,dc=com"
rootdn "cn=Manager,dc=my-domain,dc=com"

## change to : ##

database bdb
suffix "dc=my-own-domain,dc=com"
rootdn "cn=Manager,dc=my-own-domain,dc=com"
rootpw secret

7. wget http://www.padl.com/download/MigrationTools.tgz
8. tar -xzf MigrationTools.tgz
9. cd MigrationTools-46/
10. vi migrate_common.ph

# Default DNS domain
$DEFAULT_MAIL_DOMAIN = "padl.com";

# Default base
$DEFAULT_BASE = "dc=padl,dc=com";

## change to : ##

# Default DNS domain
$DEFAULT_MAIL_DOMAIN = "my-own-domain.com";

# Default base
$DEFAULT_BASE = "dc=my-own-domain,dc=com";

11. mkdir tmp
12. ./migrate_base.pl > tmp/base.ldif
13. ./migrate_hosts.pl /etc/hosts > tmp/hosts.ldif
14. ./migrate_group.pl /etc/group > tmp/group.ldif
15. ./migrate_passwd.pl /etc/passwd > tmp/passwd.ldif
16. cd tmp/
17. service ldap start
18. for i in *.ldif; do ldapadd -x -D "cn=Manager,dc=my-own-domain,dc=com" -w secret -f $i; done
19. vi /etc/openldap/ldap.conf

HOST 127.0.0.1
BASE dc=example,dc=com

## change to : ##

HOST 127.0.0.1
BASE dc=my-own-domain,dc=com
URI ldap://127.0.0.1

20. vi /etc/ldap.conf

host 127.0.0.1

# The distinguished name of the search base.
base dc=example,dc=com

## change to : ##

host 127.0.0.1

# The distinguished name of the search base.
base dc=my-own-domain,dc=com

21. vi /etc/pam.d/system-auth

## add following lines to the end : ##

# For LDAP

auth sufficient /lib/security/$ISA/pam_ldap.so use_first_pass
account [default=bad success=ok user_unknown=ignore service_err=ignore system_err=ignore] /lib/security/$ISA/pam_ldap.so
password sufficient /lib/security/$ISA/pam_ldap.so use_authtok
session optional /lib/security/$ISA/pam_ldap.so

22. vi /etc/nsswitch.conf

passwd: files
shadow: files
group: files

#hosts: db files nisplus nis dns
hosts: files dns

## change to : ##

passwd: files ldap
shadow: files ldap
group: files ldap

#hosts: db files nisplus nis dns
hosts: files ldap dns

23. chkconfig ldap on
24. reboot
25. vi /etc/cpu.conf

# Can also use LDAP_URI = ldaps://localhost:389 for TLS support
BIND_DN = cn=Manager,dc=mydomain,dc=com
BIND_PASS = secret
USER_BASE = ou=People,dc=mydomain,dc=com
# replace account with inetOrgPerson if you want first or last name
GROUP_BASE = ou=Group,dc=mydomain,dc=com

## change to : ##

# Can also use LDAP_URI = ldaps://localhost:389 for TLS support
BIND_DN = cn=Manager,dc=my-own-domain,dc=com
BIND_PASS = secret
USER_BASE = ou=People,dc=my-own-domain,dc=com
# replace account with inetOrgPerson if you want first or last name
GROUP_BASE = ou=Group,dc=my-own-domain,dc=com

26. cpu useradd test
27. cpu usermod -p test

---------------------------

I could finially login with the new account 'test'. But when I try to modify '/etc/nsswitch.conf' with...

passwd: ldap files
shadow: ldap files
group: ldap files

After restarting 'notebook', the boot process always stop at 'INIT: version 2.85'

Enviornment :

Linux version 2.6.10-1.741_FC3
SELinux: Disable
CPU: Intel(R) Pentium(R) M processor 1400MHz stepping 05
RAM: 512 MB
ASUS M2400N

Dump from phpldapadmin for account 'test' :

version: 1

# LDIF Export for: uid=test,ou=People,dc=my-own-domain,dc=com
# Generated by phpLDAPadmin ( http://www.phpldapadmin.com/ ) on March 10, 2005 4:46 pm
# Server: My LDAP Server (localhost)
# Search Scope: base
# Total Entries: 1

# Entry 1: uid=test,ou=People,dc=my-own-domain,dc=com
dn:uid=test,ou=People,dc=my-own-domain,dc=com
cn: test
objectClass: account
objectClass: posixAccount
objectClass: shadowAccount
objectClass: top
uidNumber: 101
gidNumber: 102
homeDirectory: /home/test
loginShell: /bin/bash
shadowLastChange: 11192
shadowMin: -1
shadowMax: 99999
shadowWarning: 7
shadowInactive: -1
shadowExpire: -1
shadowFlag: 134538308
uid: test
userPassword: {md5}CY9rzUYh03PK3k6DJie09g==

Anything wrong with my steps ??
Reply With Quote
Reply

Tags
error, fc3, ldap, server, setting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up Fedora Directoy Server as LDAP Address book server: how? mdragt Servers & Networking 0 17th September 2008 12:20 PM
Why is LDAP so complicated?!! LDAP server config question tornadof3 Servers & Networking 3 11th January 2008 02:04 PM
SAMBA+LDAP Can't contact LDAP server cobra_tiger Using Fedora 0 31st July 2006 03:35 PM


Current GMT-time: 06:24 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat