Fedora Linux Support Community & Resources Center
  #1  
Old 4th April 2005, 11:34 PM
fleece Offline
Registered User
 
Join Date: Apr 2005
Location: Atlanta, Georgia USA
Posts: 8
Network works at boot, then fails on load

I'm a Linux newbie. My network connectivity works immediately after boot and login under KDE, but quickly fails when I perform any major file transfers (>500KB) using SMB or prolonged web surfing using Firefox 1.0.2. I can ping my gateway 192.168.0.1 when it's working, but then once it fails, pings to 192.168.0.1 say "Destination network unreachable."

Running FC3 on a Compaq Armada 7800 laptop. System is up to date with latest versions from Red Hat Network by using yum. Kernel version is 2.6.10-1.770_FC3.

I'm connecting to my LAN using a PCMCIA CardBus NIC, a 3Com 3CXFE575CT. My FC3 system-config-network shows for hardware: "eth0 (3Com Corporation 3cCFE575CT CardBus [Cyclone])".

When I reboot, the same thing happens--works for a while, then fails. I'm also getting error messages about my soundcard not being detected, but I don't think that's related.

/usr/var/messages contains the following messages upon first failure and reappears repeatedly after failure until system is shutdown or rebooted:
Apr 4 13:05:26 localhost kernel: NETDEV WATCHDOG: eth0: transmit timed out
Apr 4 13:05:26 localhost kernel: eth0: transmit timed out, tx_status 00 status e000.
Apr 4 13:05:26 localhost kernel: diagnostics: net 0ce0 media a800 dma 000000a0 fifo 0800
Apr 4 13:05:26 localhost kernel: Flags; bus-master 1, dirty 1434(10) current 1450(10)
Apr 4 13:05:26 localhost kernel: Transmit list 0f123840 vs. cf123840.
Apr 4 13:05:26 localhost kernel: 0: @cf123200 length 8000002a status 0000002a
Apr 4 13:05:26 localhost kernel: 1: @cf1232a0 length 80000046 status 0c000046
Apr 4 13:05:26 localhost kernel: 2: @cf123340 length 800000c0 status 0c0000c0
Apr 4 13:05:26 localhost kernel: 3: @cf1233e0 length 80000046 status 0c000046
Apr 4 13:05:26 localhost kernel: 4: @cf123480 length 80000042 status 00000042
Apr 4 13:05:26 localhost kernel: 5: @cf123520 length 8000002a status 0000002a
Apr 4 13:05:26 localhost kernel: 6: @cf1235c0 length 8000002a status 0000002a
Apr 4 13:05:27 localhost kernel: 7: @cf123660 length 8000002a status 0000002a
Apr 4 13:05:27 localhost kernel: 8: @cf123700 length 8000002a status 8000002a
Apr 4 13:05:27 localhost kernel: 9: @cf1237a0 length 8000002a status 8000002a
Apr 4 13:05:27 localhost kernel: 10: @cf123840 length 80000042 status 00000042
Apr 4 13:05:27 localhost kernel: 11: @cf1238e0 length 80000042 status 00000042
Apr 4 13:05:27 localhost kernel: 12: @cf123980 length 80000054 status 0c000054
Apr 4 13:05:27 localhost kernel: 13: @cf123a20 length 8000002a status 0000002a
Apr 4 13:05:27 localhost kernel: 14: @cf123ac0 length 80000054 status 0c000054
Apr 4 13:05:27 localhost kernel: 15: @cf123b60 length 8000002a status 0000002a

Any ideas how to troubleshoot this? I don't know how to recompile the kernel so I'm trying to avoid that if possible.
Reply With Quote
  #2  
Old 7th April 2005, 04:03 PM
fleece Offline
Registered User
 
Join Date: Apr 2005
Location: Atlanta, Georgia USA
Posts: 8
Exclamation Update on 3c50x driver...

Update on previous post by me:

Looks like I have a compatibility issue with the 3Com 3CXFE575CT and the 3c50x kernel module driver. Apparently, from my web research, the 3c50x driver used for PCMCIA carbus hardware is unstable for slow machines, CPU of <500MHz, which is the case for me. The driver source needs to be recompiled with a DCARDBUS option, but is not updated for 2.6 kernel. It won't compile with the 2.6 kernel libraries. So, I'm out of luck. Guess I'll buy another NIC card.

Lesson learned...

DON'T BUY A PCMCIA CARD that needs the 3Com 3c50x driver if your machine has a CPU clocking below 500Mhz and you plan to run kernel versions 2.4 or later.
Reply With Quote
Reply

Tags
boot, fails, load, network, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
new to Linux eth0 fails to load at boot nic is rtl8139 Tgilyard Servers & Networking 8 30th December 2006 11:00 AM
FC6 x86_64 grub failed to load on /dev/hda, now dual boot fails GreyWizzard EOL (End Of Life) Versions 4 21st December 2006 07:01 AM
Loopback fails to load on kernel boot RaXeT Using Fedora 2 14th October 2005 03:52 PM
CUPS fails to load during boot. LaVacaLoca Using Fedora 4 13th May 2005 12:13 AM


Current GMT-time: 13:21 (Friday, 28-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Pulau bacan-Halmahera selatan-Maluku utara - Radisson Blu Daugava Hotel Instagram Photos - St. Andrew's Church Photos on Instagram