Fedora Linux Support Community & Resources Center
  #1  
Old 13th April 2005, 02:19 AM
nulli_secundus Offline
Registered User
 
Join Date: Apr 2005
Location: Australia
Posts: 80
Question Connection Refused - FC3

Hey all,

Just wondering if anyone has any insight into this problem I've got. It's probably quite simple, but not sure how to proceed.

I have a D-Link DSL-302G ADSL Modem connected via ethernet to a D-Link DI-624+ wireless broadband router, which connects my LAN together.

The problem I'm having is that when trying to access the ADSL Modem or the internet, I get connection refused messages when using my FC3 install.

It all works fine, however, in my Win XP install. My primary computer is connected via ethernet to a LAN port on the router, the rest connect wirelessly. The ADSL Modem is connected via ethernet to the WAN port on the Router.

The ADSL Modem operates on a 10 network, and the Router runs a 192 network.

When I had the ADSL Modem directly connected to my FC3 computer it has no connection problems, just doesn't seem to want to play with it through the router.

I assume i have to change some permissions or something to allow the 10 network to be seen aswell as the 192?

Any help would be much appreciated
Reply With Quote
  #2  
Old 13th April 2005, 06:50 AM
james_in_denver Offline
Registered User
 
Join Date: Oct 2004
Posts: 1,227
Probably the I.P. address you are using in "Fedora Core 3" is not on the right subnet for your cable modem box.

type in "/sbin/ifconfig", and print out/post that information, also you might want to boot your Windows partition to check the I.P. configuration.
__________________
Only dead fish go with the flow....

Hmmm, what did I miss?
Reply With Quote
  #3  
Old 13th April 2005, 07:50 AM
AndyGreen Offline
Registered User
 
Join Date: Apr 2005
Location: Northants, UK
Posts: 2,026
Not enough info.

"Connection refused" means that a computer was at the IP address you touched, but the port was "closed", ie, no process was running that was listening at that port.

On your Fedora box, paste us the output of

route -n

and tell us the local IP (eg, 192.168.0.1 or whatever) of your Fedora box and your ADSL box.

I didn't really understand what you are saying about having two subnets, the 10 and the 192.168 ones: something is going to have to be responsible for routing between the subnets. What is it in your setup?
__________________
Freelance RedHat Certified Engineer - http://northantsIT.com
Reply With Quote
  #4  
Old 14th April 2005, 07:44 AM
nulli_secundus Offline
Registered User
 
Join Date: Apr 2005
Location: Australia
Posts: 80
Hey guys,

Thanks for the responses, here is the info you suggested:

From Win XP (working):

C:\>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : augustus
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : F5D5000, PCI Card/Desktop Network PC
I Card
Physical Address. . . . . . . . . : 00-30-BD-09-57-6E
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.60
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 203.12.160.35
203.12.160.36
Lease Obtained. . . . . . . . . . : Thursday, April 14, 2005 4:25:54 PM
Lease Expires . . . . . . . . . . : Thursday, April 21, 2005 4:25:54 PM

-----------------------------------------------------------------------------------------

From FC3 (not working):

[augustus@localhost sbin]$ ./route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0

[augustus@localhost sbin]$ ./ifconfig
eth0 Link encap:Ethernet HWaddr 00:30:BD:09:57:6E
inet addr:192.168.0.60 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::230:bdff:fe09:576e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:163 errors:0 dropped:0 overruns:0 frame:0
TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:52552 (51.3 KiB) TX bytes:4065 (3.9 KiB)
Interrupt:9 Base address:0x8800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1993 errors:0 dropped:0 overruns:0 frame:0
TX packets:1993 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2695245 (2.5 MiB) TX bytes:2695245 (2.5 MiB)

[augustus@localhost sbin]$ ping router
PING router (192.168.0.1) 56(84) bytes of data.
64 bytes from router (192.168.0.1): icmp_seq=0 ttl=127 time=0.320 ms
64 bytes from router (192.168.0.1): icmp_seq=1 ttl=127 time=0.293 ms
64 bytes from router (192.168.0.1): icmp_seq=2 ttl=127 time=0.299 ms

--- router ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 0.293/0.304/0.320/0.011 ms, pipe 2

[augustus@localhost sbin]$ ping 10.1.1.1
connect: Network is unreachable

-----------------------------------------------------------------------------------

My FC3 IP address is assigned by DHCP on the router, and is pretty much always 192.168.0.60, and is the same on windows.

The address of the Router is 192.168.0.1, and the address of the Modem is 10.1.1.1

In the Router, on the WAN page (the router is configured via html), I have the settings like so:

IP Address (for the Router on the Modem's network): 10.1.1.3
Subnet Mask: 255.0.0.0
ISP Gateway Address: 10.1.1.1
Primary DNS: 203.12.160.35
Secondary DNS: 203.12.160.36

The Modem is connected through the WAN port on the router. The Router provides DHCP for the LAN, and the Modem is doing the NAT.

Interesting to see that FC3 says the modem is "unreachable".

If you'd like more info, just ask, as I could really use the help Thanks!
Reply With Quote
  #5  
Old 14th April 2005, 07:57 AM
AndyGreen Offline
Registered User
 
Join Date: Apr 2005
Location: Northants, UK
Posts: 2,026
It's not just telling you that the modem is unreachable, it's telling you it doesn't know how to get to the whole 10.*.*.* world.... *Network* is unreachable. The reason for this is shown up in the route -n output

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0

The first line is saying, hey, if you want to get to a 192.168.0.* destination, throw the packet down eth0. The second line is added automatically by Fedora and is to do with zeroconf, it's not important.

But you should have a third line at least, which says what to do with all the OTHER IP addresses you might want to contact, ie, everything on the Internet. This is the so-called "default route" where packets are sent if no explicit route exists earlier in the routing table.

Try this

route add default gw 10.1.1.1 eth0

This is going to add an entry to your routing table telling Fedora to direct all other packets to 10.1.1.1 using eth0.

You might also want

route add -net 10.0.0.0 netmask 255.0.0.0 eth0

which should let you touch machines on the 10.*.*.* network that are not on the Internet and are not 10.1.1.1

If all that made some good difference, the first guy you should have been able to add through

system-config-network

Doubleclick on the eth0 device on the first tab, and fill in "Default Gateway Address" as 10.1.1.1

Then click on the Route tab and Add...

10.0.0.0
255.0.0.0
10.1.1.1
__________________
Freelance RedHat Certified Engineer - http://northantsIT.com
Reply With Quote
  #6  
Old 14th April 2005, 09:18 AM
nulli_secundus Offline
Registered User
 
Join Date: Apr 2005
Location: Australia
Posts: 80
Thanks for the feedback Andy,

I did as you suggested and got the following respone:

[root@localhost sbin]# ./route add default gw 10.1.1.1 eth0
SIOCADDRT: Network is unreachable

Adding the net 10.0.0.0 netmask 255.0.0.0 eth0 gave no errors, but did not let me talk to 10.1.1.1

Using system-config-network - I have the IP address set to be automatically obtained from DHCP (which is 192.168.0.1), so does not allow the Default Gateway option. It appears to only be an option of a static IP.

Question: What is SIOCADDRT?
Reply With Quote
  #7  
Old 14th April 2005, 09:23 AM
AndyGreen Offline
Registered User
 
Join Date: Apr 2005
Location: Northants, UK
Posts: 2,026
I think SIOCADDRT is the short name of the error returned by the networking stuff.

I guess I should have given you those two route commands the other way around. route is saying... "gateway is 10.something? But I have no idea how to get to 10.something, there is nothing in my route table about that."

Actually I bet that the second route command DID allow you to talk to your router. The problem is that your router, set for 10.something, has no route listed for what to do with 192.168 traffic to send the reply back. See if you can set a static route for 192.168.something in the router config.
__________________
Freelance RedHat Certified Engineer - http://northantsIT.com
Reply With Quote
Reply

Tags
connection, fc3, refused

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rsh connection refused ankurpachauri Servers & Networking 1 7th September 2009 09:35 AM
VNC Connection refused (111) cpri Using Fedora 10 22nd January 2007 09:24 AM
Connection Refused vijay_kumar749 Servers & Networking 3 22nd November 2005 06:13 PM
FTP connection refused. CICA Servers & Networking 3 7th September 2005 10:15 AM
Connection refused until in network connection JJS Servers & Networking 5 2nd November 2004 08:27 PM


Current GMT-time: 21:41 (Friday, 19-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram