Fedora Linux Support Community & Resources Center
  #1  
Old 25th May 2005, 09:46 AM
Vimal Kumar Offline
Registered User
 
Join Date: May 2005
Posts: 5
Folder contents could not be displayed, Samba Nautilus FC3 and XP

On FC3 I've set up Samba to access my XP laptop. I've used smbmount to mount my xp shares and I can access the xp shares this way. When I use nautilus until 2 days back I could open up the Windows Network, see my workgroup and my XP machine, but when I double click on the machine it throws me this error "Sorry, the folder contents could not be displayed. You do not have permissions to Windows network//Vimal".

I have a user on the FC3 box with the same user name and password as my XP "administrator" user.

Today , I double click the "Computer" icon, I get a window with "Windows Network" icon, when I double click this, I get an empty window (0 items)
However when I type smb://Xpmachine name/Share I'm prompted for user name, domain and password, and lets me in when I enter these.It works the same no matter which FC3 username I use.


Looks like samba is fine but something's screwed up with nautilus.

Also I don't know what caused the change between 2 days back and today. I did uncomment the "encrypt = yes" line today, but I think it happened even before I made this change.
Reply With Quote
  #2  
Old 26th May 2005, 05:56 PM
Vimal Kumar Offline
Registered User
 
Join Date: May 2005
Posts: 5
Hasn't anybody configured Samba to work with XP on FC3
__________________
gvimalku
Reply With Quote
  #3  
Old 26th May 2005, 07:34 PM
brandor Offline
Registered User
 
Join Date: May 2005
Posts: 534
You're getting more than I am. I'd like to be able to hit windows shares from FC3 but I haven't found any way to do it other than using smbclient or mounting with smbfs.

It'd be nice if I could just use the windows share option in the dialog for connect to server... maybe someday they'll get it right.
Reply With Quote
  #4  
Old 26th May 2005, 08:08 PM
thraldur Offline
Registered User
 
Join Date: Apr 2005
Posts: 38
I just created an auth.smb file and edited /etc/fstab so I could see my Windows shares.

This is what I added to fstab:
//192.168.253/hd1 /mnt/network/celeron/hd1 smbfs nosuid,nodev,noexec,credentials=/etc/samba/auth.smb,uid=sempron0,gid=sempron0,fmask=664,dmask =755 0 0
//192.168.0.251/hd1 /mnt/network/matrix/hd1 smbfs nosuid,nodev,noexec,credentials=/etc/samba/auth.smb,uid=sempron0,gid=sempron0,fmask=664,dmask =755 0 0
//192.168.0.246/hd1 /mnt/network/compaq/hd1 smbfs nosuid,nodev,noexec,credentials=/etc/samba/auth.smb,uid=sempron0,gid=sempron0,fmask=664,dmask =755 0 0

(By the way, beginning with // and ending with 0 is one line. It displays differently because the line gets wrapped to the next line - //...all the way to 0 is one line in fstab)

The first part of each line shows the location of the shares, e.g. //192.168.0.246/hd1 . I would enter the hostnames but for some reason this would not work for me. The next part is the mountpoint, e.g. /mnt/network/compaq/hd1 . I had to create the directories /mnt/network/celeron/hd1, /mnt/network/sempron/hd1, etc. before I could mount to them.

credentials=... shows where the user and pass for each share is stored - /etc/samba/auth.smb. You need to create this file (gedit /etc/samba/auth.smb) and add to it the user and password needed to access the share:

username=user
password=pass

Remember to leave a blank line at the end of this file.

uid and gid is the user id and group id for the shares (I think... I am not sure about this one.)

After doing all this, test it as root (su -) with the command: service netfs restart to see if the samba shares are mounted correctly.

If Fedora fails to boot after doing all this, enter interactive startup and make sure netfs is not started, then troubleshoot after you've booted.

If this succeeds, then straight after you boot you are able to browse your samba shares right away.

P.S. If any of this is wrong somebody please correct me, thank you.
Reply With Quote
  #5  
Old 27th May 2005, 03:54 AM
gavinw6662 Offline
Registered User
 
Join Date: Feb 2005
Age: 35
Posts: 1,281
i have the same problem, i remember with FC2 that was a problem too, and if I am not entirely mistaken, someone had mentioned it being a nautilus problem.
Reply With Quote
  #6  
Old 27th May 2005, 08:14 AM
thraldur Offline
Registered User
 
Join Date: Apr 2005
Posts: 38
It's to do with the firewall. Open Applications->System Settings->Security Level and in other ports add:

137:udp, 137:tcp, 139:udp, 139:tcp, 445:udp, 445:tcp

More details here: https://bugzilla.redhat.com/bugzilla....cgi?id=133478
Reply With Quote
  #7  
Old 28th May 2005, 08:12 PM
Vimal Kumar Offline
Registered User
 
Join Date: May 2005
Posts: 5
thraldur
I have my fstab setup the same way. Let me repeat - I am able to mount and access the shares using smb. My problem is that I am unable to do this using the nautilus window. I am able to see my Windows machine in the Network folder, but when I double click on the machine name, I get: "the folder contents could not be displayed. You do not have the permissions necessary to view the contents of "Windows Network: machine".

I have no problem mounting the xp share using smbmount and accesing the files this way. Only Nautilus appears to be broken.
__________________
gvimalku
Reply With Quote
  #8  
Old 28th May 2005, 08:59 PM
thraldur Offline
Registered User
 
Join Date: Apr 2005
Posts: 38
Well it could be the firewall bug - see my earlier post (#6), try opening those ports. Otherwise I guess I can't help, sorry.
Reply With Quote
  #9  
Old 29th May 2005, 02:40 AM
Vimal Kumar Offline
Registered User
 
Join Date: May 2005
Posts: 5
Thanks, but I already have these ports opened up.
__________________
gvimalku
Reply With Quote
  #10  
Old 29th May 2005, 09:58 AM
thraldur Offline
Registered User
 
Join Date: Apr 2005
Posts: 38
Quote:
Originally Posted by Vimal Kumar
Today , I double click the "Computer" icon, I get a window with "Windows Network" icon, when I double click this, I get an empty window (0 items)
Hey, now that check my Fedora computer, it seems I have the same problem, which is quite strange - since when I first checked some time ago, nothing was wrong. I think one of the system updates could have caused this, but I never noticed since I have launchers for all my mountpoints, and my network shares are mounted on startup, so I only have to double click on the launchers when I need to access them.

Also I noticed that when trying to mount network drives, using their hostnames also doesn't work: 'Sorry, couldn't display all the contents of "Windows Network: matrix".' But using their ip addresses work, so something is worng in that my Fedora computer can't recognise the host names of the Windows computers. However, after entering the Network folder, I can connect to a server by clicking File->Connect to Server, choosing Windows share, and typing the ip address.

I'm going to format and install Fedora Core 4 after it comes out, and see if the bug gets fixed with that.
Reply With Quote
  #11  
Old 31st May 2005, 04:20 AM
Flyboy917 Offline
Registered User
 
Join Date: Jan 2005
Location: Wichita, KS
Posts: 373
Is the folder you are sharing inside a folder you are not? i.e. /homes/user/sambashare? If homes and user don't have guest permisions, but /sambashare does, you will not be able to access it.
File permisions are not recursive by default. Go and set all the folders in the chain to sticky 1777.
If that works, go back an set up recursive file permissions properly.
That solved my problem with the same issue.

Flyboy
Reply With Quote
  #12  
Old 4th June 2005, 05:38 PM
Vimal Kumar Offline
Registered User
 
Join Date: May 2005
Posts: 5
do you have the entries in /etc/hosts
__________________
gvimalku
Reply With Quote
  #13  
Old 9th February 2009, 02:28 AM
ohiomike Offline
Registered User
 
Join Date: Feb 2009
Posts: 1
I just fought with the same problem on one of my machines (4 worked, 1 didn't).
I turns out I had a typo in the hosts file (110 instead of 101) for the machine that is the
master browser on the network.
Reply With Quote
Reply

Tags
contents, displayed, fc3, folder, nautilus, samba

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vcard icons not displayed in nautilus. leamas Using Fedora 0 30th November 2008 12:58 PM
Nautilus scripts, mostly bash, as root open nautilus in current folder. leadgolem Programming & Packaging 18 28th January 2008 08:21 AM
safe to delete contents of the /tmp folder ?? terry_g Using Fedora 5 27th July 2006 11:58 PM
is there a way to modify perissions for the entire contents of a folder? exactopposite Using Fedora 3 21st March 2006 06:13 AM
Help...Locked home folder!!!Can't read Contents ilnakos Using Fedora 1 6th June 2005 12:33 PM


Current GMT-time: 00:58 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Tirebolu Travel Photos - Banjaran Instagram Photos - Haibara