Fedora Linux Support Community & Resources Center
  #1  
Old 9th June 2005, 06:31 AM
Debaser13 Offline
Registered User
 
Join Date: Jun 2005
Location: Ventura, California
Posts: 34
editing the /boot/grub/grub.conf file

I recently updated the kernel to my FC3 OS and now it defaults to the new kernel. I would prefer the grub loader to default back to Windows XP. Before I edit this file I have read in the book that the line:
boot = /dev/hda
default = 0

The default = 0 indicates that first linux partition is booted by default. Do I delete that line and move it to were the Windows partition line is? How do I correctly edit this file so my system defaults to Windows?
Reply With Quote
  #2  
Old 9th June 2005, 08:59 AM
mverbele Offline
Registered User
 
Join Date: Jun 2005
Location: belgium brussels
Posts: 27
nope the default indicates the boot option line
with default on 1 it takes the 2e title and default is put to windooz

(hd0,0) =partition1
(hd0,1)= partition2
...
default=0 =title1
default=1 = titl"2
...

Code:
default=1
title Fedora Core (2.6.11-1.27_FC3)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.11-1.27_FC3 ro root=/dev/hda2
        initrd /boot/initrd-2.6.11-1.27_FC3.img
title windooz
        rootnoverify (hd0,0)
        chainloader +1
title Fedora Core (2.6.11-1.14_FC3)
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.11-1.14_FC3 ro root=/dev/hda2
        initrd /boot/initrd-2.6.11-1.14_FC3.img
Reply With Quote
  #3  
Old 10th June 2005, 12:41 AM
Debaser13 Offline
Registered User
 
Join Date: Jun 2005
Location: Ventura, California
Posts: 34
I tried editing the grub.conf file and grub still boots to FC3. Here's what my grub.conf file looks like. Can somebody tell how to edit this file correctly so grub can default to Windows?

#boot=/dev/hda
default=0 = Windows XP Pro
default=1 = Fedora Core (2.6.11-1.27_FC3)s
timeout=10
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.11-1.27_FC3)
root (hd0,1)
kernel /vmlinuz-2.6.11-1.27_FC3 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.11-1.27_FC3.img
title Fedora Core (2.6.9-1.667)
root (hd0,1)
kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.9-1.667.img
title Windows XP Pro
rootnoverify (hd0,0)
chainloader +1
Reply With Quote
  #4  
Old 10th June 2005, 12:48 AM
Tashiro Offline
Retired Community Manager
 
Join Date: May 2004
Posts: 1,149
Try only 1 default line, like this:
Code:
default=2
0= the first entry, Fedora Core (2.6.11-1.27_FC3)
1= the second entry, Fedora Core (2.6.9-1.667)
2= the third entry, Windows XP Pro
Code:
#boot=/dev/hda
default=2
timeout=10
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.11-1.27_FC3)
root (hd0,1)
kernel /vmlinuz-2.6.11-1.27_FC3 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.11-1.27_FC3.img
title Fedora Core (2.6.9-1.667)
root (hd0,1)
kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.9-1.667.img
title Windows XP Pro
rootnoverify (hd0,0)
chainloader +1
Tashiro
__________________
Respect the FedoraForum.org guidelines

Last edited by Tashiro; 10th June 2005 at 12:53 AM.
Reply With Quote
  #5  
Old 10th June 2005, 01:20 AM
Debaser13 Offline
Registered User
 
Join Date: Jun 2005
Location: Ventura, California
Posts: 34
Thanks Tashiro, it worked. Having re-edited the grub.conf file now I understand mverbele's reply. Now all I need to figure out is how to get my /media/cdrecorder to recognize a disk, and I'll be one happy FC3 user!!!
Reply With Quote
  #6  
Old 10th June 2005, 01:37 AM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
You have to put an entry in /etc/fstab... Here's mine for an example:
/dev/drive /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
the /dev/drive is the correct drive device corresponding to the cdrecorder. For me, it's /dev/hdc, but for you it might be different...
A nice way to fond out is to type this in a prompt:
nautilus /dev --no-desktop &
A nautilus window should pop up in the /dev/ directory. Look for a file called cdrecorder and right-click > Properties
It should show something like the photo I attached... Under the Link target section, whatever drive it lists is the correct one that you can replace with /dev/drive.
Firewing1
Attached Thumbnails
Click image for larger version

Name:	snapshot1.png
Views:	176
Size:	47.3 KB
ID:	5116  
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #7  
Old 10th June 2005, 05:34 AM
gavinw6662 Offline
Registered User
 
Join Date: Feb 2005
Age: 36
Posts: 1,281
for future, when you install a kernel from say up2date, or yum it defaults the top of your grub.conf, to make the windows the top option in grub, and boot to it if you don't make a choice (after the time out) then move the windows info to the top, that is what I do with my laptop so that my lady can use it:

default=0
timeout=20
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Windows (<------- Llike this)
rootnoverify (hd0,0)
chainloader +1
title Fedora Core (2.6.11-1.27_FC3)
root (hd0,1)
kernel /vmlinuz-2.6.11-1.27_FC3 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.11-1.27_FC3.img
Reply With Quote
  #8  
Old 10th June 2005, 06:23 AM
Debaser13 Offline
Registered User
 
Join Date: Jun 2005
Location: Ventura, California
Posts: 34
Thanks for the info. This is definately good to know for the future. It's funny you mention your lady. That's exactly why I have to have my machine default to Windows.

Thanks again!!!
Reply With Quote
  #9  
Old 10th June 2005, 07:02 AM
Debaser13 Offline
Registered User
 
Join Date: Jun 2005
Location: Ventura, California
Posts: 34
I followed your steps and I did get the same cdrom properties box. Here's what my fstab file looks like.

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
LABEL=/boot1 /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=SWAP-hda3 swap swap defaults 0 0
/dev/hdc /media/cdrecorder auto pamconsole,fscontext=system_u:object_r:removable_t ,ro,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,fscontext=system_u:object_r:removable_t ,exec,noauto,managed 0 0

Do I need to add /dev/drive before the /media cdrecorder to get my DVDburner to recognize when a disk is loaded?
Reply With Quote
  #10  
Old 10th June 2005, 05:00 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Quote:
Originally Posted by Debaser13
Do I need to add /dev/drive before the /media cdrecorder to get my DVDburner to recognize when a disk is loaded?
Don't know what you mean there... As for your fstab, is it OK if you attach it to a post so I can edit it for you? (To attach click "Go Advanced" when writing a post, and then scroll down the page. Click on "Manage atachments". Select /etc/fstab to upload, and then I'll post you back what I think is the correct version. Worst comes to worst, you can always restore it because your original /etc/fstab will be saved in this thread...
Thanks!
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #11  
Old 10th June 2005, 05:40 PM
Debaser13 Offline
Registered User
 
Join Date: Jun 2005
Location: Ventura, California
Posts: 34
Thanks for responding.

I just noticed that the attachment came back with a response invalid file type when I tried to upload fstab. I have to try this later.

Last edited by Debaser13; 10th June 2005 at 05:45 PM.
Reply With Quote
Reply

Tags
editing, file

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing "grub.conf" file ! jce2005 Using Fedora 3 6th June 2008 05:13 AM
Correct grub.conf file for dual boot on same SATA drive jeepfreak Installation, Upgrades and Live Media 17 9th April 2007 06:58 PM
I need help editing grub.conf Elv1n06 Using Fedora 2 27th March 2007 09:50 AM
Editing the GRUB.conf file matrixtna Installation, Upgrades and Live Media 1 24th September 2005 05:11 PM
apending "/boot/grub/grub.conf" file // need some help... I-1 Using Fedora 5 4th May 2005 01:27 PM


Current GMT-time: 06:25 (Monday, 22-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...KFC Travel Photos - Pearl Palace Heritage, Jaipur Photos - Gamboa, Bahia, Brazil Travel Photos