Fedora Linux Support Community & Resources Center
  #1  
Old 16th June 2005, 02:52 PM
red-bear Offline
Registered User
 
Join Date: Jun 2005
Posts: 38
Weird touchpad behaviour

Hello,
I have a laptop with Synaptics touchpad running FC4 and Gnome. The drivers for it are installed.
But often it behaves weirdly when I use Firefox. Sometimes when the pointer is hovering over the page and I move it, Firefox goes back. It is as if I pressed the back button, but all I did was to move the pointer.
Does anyone else have the same problem?
Reply With Quote
  #2  
Old 16th June 2005, 03:09 PM
sailor Offline
Administrator
 
Join Date: Mar 2004
Location: San Antonio, Texas - Home of the Alamo, the "Cradle of Texas Liberty"
Age: 56
Posts: 4,113
I have noted this behavior as well...the touchpads don't seem to be supported well...
There is a utility called Ksynaptic, which is a control panel for altering the various touchpad options
I used it in FC3 without much success...now I am in FC4 and have not tried it yet.
I usually use a usb optical mouse since I don't really like the touchpad...Radio Shack has a nice one for $20 which I use on both of my laptops.
__________________
**********************************************
sailor
San Antonio, Texas

Fedora 20 - Lenovo IdeaPad V570
**********************************************
Reply With Quote
  #3  
Old 19th June 2005, 12:40 AM
thomasjpr Offline
Registered User
 
Join Date: Jun 2005
Posts: 1
Yes, I'm having this exact problem on my Latitude D600. It seems to mostly affect Firefox in the manner that you've described. Very frustrating. The touchpad is also non-functional after a suspend to RAM.
Reply With Quote
  #4  
Old 20th June 2005, 02:28 PM
fearism Offline
Registered User
 
Join Date: Jun 2005
Posts: 12
hi, i think it is a solution for your problem located here
__________________
Travelmate 8100-serie
Intel M 2,0GHz
15.4" TFT LCD
100GB HDD
Ati Mobility Radeon X700
1GB DDR2 533

Boxed at @ Latest kernel fCore
Reply With Quote
  #5  
Old 22nd June 2005, 03:15 AM
ecman Offline
Registered User
 
Join Date: Jun 2005
Posts: 2
I am also having the same problem with FC4 on a Dell Inspiron 5000. I am also seeing the problem when browsing the file system and switching between desktops. I am going to try the drivers from the site mentioned above. I hope that works since an external mouse isn't an option when traveling.
Reply With Quote
  #6  
Old 23rd June 2005, 02:52 AM
ecman Offline
Registered User
 
Join Date: Jun 2005
Posts: 2
Well I gave it a try. It didn't work and now GUI for changing the mouse settings does not work. I found this driver "Synaptics TouchPad for XOrg/XFree86 4.x" at http://web.telia.com/~u89404340/touchpad/ but it seems rather complicated to install and configure. Maybe I'll give it a try this weekend or revert back to FC3. Has anyone else had any luck?
Reply With Quote
  #7  
Old 27th June 2005, 04:16 PM
tallfred Offline
Registered User
 
Join Date: Jun 2005
Posts: 4
Try adding

Option "TapButton1" "0"

to your /etc/X11/xorg.conf file. This should really be the default.
You will need to restart X. This used to be easiest with a
Ctrl-Alt-Backspace, but now with Fedora 4 it does not seem to
restart for me. I need to switch to a console then "telinit 3"
and "telinit 6" as root. Maybe just logging out is good enough.
Reply With Quote
  #8  
Old 27th June 2005, 04:21 PM
x94scorp Offline
Registered User
 
Join Date: Apr 2005
Posts: 34
I thought this was a feature- I've noticed that if I drag left or right at the very bottom of my touchpad, it will invoke the browser to go forward or back a page? I like it.
Reply With Quote
  #9  
Old 28th June 2005, 06:54 PM
Cloud[01] Offline
Registered User
 
Join Date: Jun 2005
Posts: 1
recent touchpads have on the right the possibility to scroll UP and DOWN.
Some of them at the bottom the possiblity to scroll LEFT and RIGHT

The Synaptics drivers use this capability and the behaviour in firefox is like hitting the back and forward button

some may like it, someother don't... Don't what to change tough...

Cloud
Reply With Quote
  #10  
Old 30th June 2005, 12:55 AM
sailor Offline
Administrator
 
Join Date: Mar 2004
Location: San Antonio, Texas - Home of the Alamo, the "Cradle of Texas Liberty"
Age: 56
Posts: 4,113
I used the suggestion: Option "TapButton1" "0" in the xorg.conf and didn't see much change ...I then tried adding psmouse.proto=exps to the kernel boot parameters in grub.conf, which appeared to have an effect.
The touchpad is not doing phantom taps anymore...but the scroll button no longer works(not a big issue with me) The edges of the touchpad no longer have scroll or back/forward function either.
I think overall it has made the touchpad a little easier to use.
__________________
**********************************************
sailor
San Antonio, Texas

Fedora 20 - Lenovo IdeaPad V570
**********************************************

Last edited by sailor; 1st July 2005 at 03:38 PM.
Reply With Quote
  #11  
Old 30th June 2005, 02:24 AM
peekpt Offline
Registered User
 
Join Date: Jun 2005
Posts: 7
Ok I did a quick image so you guys understand how it works:



cheers
Reply With Quote
  #12  
Old 1st July 2005, 03:36 PM
sailor Offline
Administrator
 
Join Date: Mar 2004
Location: San Antonio, Texas - Home of the Alamo, the "Cradle of Texas Liberty"
Age: 56
Posts: 4,113
Yeah I have noted the functions along the edge of the screen..with my big fingers they better left non-functioning...far too often I was accidentally scrolling or changing screens while typing
__________________
**********************************************
sailor
San Antonio, Texas

Fedora 20 - Lenovo IdeaPad V570
**********************************************
Reply With Quote
  #13  
Old 23rd July 2005, 07:12 AM
iLLNESS Offline
Registered User
 
Join Date: Jul 2005
Posts: 5
wow
that diagram really helps

although... the side scroller on the touchpad is retarted... why would there be a scroller on the touchpad when th actually scroller is an inch away...
the menu button is kinda pointless too... once again the button is an inch away...

the back/forward thing is cool.. but **** is it ever sensitive.. maybe if it wasnt so sensitive itd be a nice feature...
Reply With Quote
  #14  
Old 30th July 2005, 09:09 PM
tommy@cakemaker
Guest
 
Posts: n/a
Thumbs down

The (Option "VertScrollDelta") "100" in xorg.conf tells your the movement you have to do to scrooll. Try it. I am trying to get this my self, the fc4 std config of the synaptics driver sucks.
Reply With Quote
  #15  
Old 30th July 2005, 09:17 PM
tommy@cakemaker
Guest
 
Posts: n/a
In the attchement you can see tne commands for the synaptics setup in the xorg.conf file.
Reply With Quote
Reply

Tags
behaviour, touchpad, weird

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Network Behaviour dudds Servers & Networking 2 30th December 2006 12:07 AM
smbd weird behaviour megabyte2021 Security and Privacy 1 10th September 2006 08:25 AM
Weird behaviour ratovan Using Fedora 1 11th April 2006 06:00 AM
Weird OpenGL behaviour Noodle Using Fedora 7 10th January 2005 04:07 PM


Current GMT-time: 02:47 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Requena Travel Photos - Igra Photos - Victoria