Fedora Linux Support Community & Resources Center
  #1  
Old 31st August 2005, 10:04 PM
d97jerry Offline
Registered User
 
Join Date: Aug 2005
Location: Gothenburg, Sweden
Age: 36
Posts: 3
wlan trouble on acer aspire 3000

Hi everyone!
I'm new to Fedora/Linux, so please forgive me for any ignorance i might show.

I've installed FC4 on my new Acer Aspire 3003WLMi, and most things work just fine, except for wireless networking. I use ndiswrapper and the bcmwl5 driver. It has worked twice the latest days, without me doing anything purposely, but disappears after reboot.

I have:
Upgraded to 2.6.12-1.1447_FC4
Compiled and installed the latest ndiswrapper from the CVS.

Code:
#ndiswrapper -i bcmwli.inf
#ndiswrapper -l 
bcmwl5          driver present, hardware present
#modprobe ndiswrapper
#dmesg |grep ndiswrapper
ndiswrapper version 1.3rc1 loaded (preempt=no,smp=no)
ndiswrapper: driver bcmwl5 (Broadcom,12/22/2004, 3.100.46.0) loaded
PCI: Found IRQ 4 for device 0000:00:0b.0
PCI: Sharing IRQ 4 with 0000:00:02.1
ndiswrapper: using irq 4
wlan0: ndiswrapper ethernet device 00:14:a4:24:db:c3 using driver bcmwl5, configuration file 14E4:4318:1468:0312.5.conf

#lspci -n |grep 14e3:4318
 00:0b.0 Class 0280: 14e4:4318 (rev 02)
#lspci |grep 00:0b.0
00:0b.0 Network controller: Broadcom Corporation: Unknown device 4318 (rev 02)

#iwconfig wlan0
Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"localhost.localdomain"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:00:00:00:00:00
          Bit Rate=54 Mb/s   Tx-Power:25 dBm
          RTS thr=2347 B   Fragment thr=2346 B
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Those two times it has suddently worked Access Point has changed to that of my AP, and ifup wlan0 gets everything up to speed, surfing etc works fine then. Apart from that, I can get no sign of life from the thing.
Suggestions? Could the IRQ sharing have anything to do with it?
Reply With Quote
  #2  
Old 3rd September 2005, 10:25 PM
r.konow Offline
Registered User
 
Join Date: Aug 2005
Posts: 8
Try using ndiswrapper -m, then ndiswrapper should put one o two lines in the /etc/modprobe.conf file, with all the info for wlan0. That way always when you start your computer, the module will be loaded

(Sorry for my english)

greetings,
Roberto Konow
Linux Community
Diego Portales University
Chile
Reply With Quote
  #3  
Old 3rd September 2005, 10:29 PM
r.konow Offline
Registered User
 
Join Date: Aug 2005
Posts: 8
By the way, i think i have the same chipset. I used the bcmw15a driver for my wlan device. The problem is, that i currently have a 802.11B wlan in my house, and i think the network card is configured (as shown in iwconfig) for a 802.11G. The card is B/G compatible so... any idea of how to change this configuration from G to B?

Thanks,
Roberto Konow
Linux Community
Diego Portales University
Chile
Reply With Quote
  #4  
Old 20th September 2005, 09:57 AM
d97jerry Offline
Registered User
 
Join Date: Aug 2005
Location: Gothenburg, Sweden
Age: 36
Posts: 3
I found my problem, the radio on the wlan card was turned off, and could be activated trough the use of acerkh.
Don't think that the B/G type should make any difference, atleast for me 'iwlist scan' shows both B and G type AP:s in my building.
Reply With Quote
Reply

Tags
3000, acer, aspire, trouble, wlan

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless (BCM8314) Acer Aspire 3000 with Fedora 10? Lampie Servers & Networking 28 8th May 2009 07:38 PM
Acer Aspire 3000 screen goes black fear1874 Installation, Upgrades and Live Media 6 8th January 2009 04:47 PM
Acer Aspire 5720z and Fedora 9 wlan trouble HuntrRose Servers & Networking 5 6th June 2008 04:58 PM
Acer Aspire 3000 tech help ryanmurphy Using Fedora 1 10th March 2007 05:00 PM
Acer Aspire 3000 WiFi does not work camilo Hardware & Laptops 3 15th September 2005 08:13 PM


Current GMT-time: 13:01 (Thursday, 30-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Morozovsk Travel Photos - Oostkamp Photos on Instagram - Havelian Instagram Photos