Fedora Linux Support Community & Resources Center
  #1  
Old 14th February 2006, 06:55 PM
jhetrick62 Offline
Registered User
 
Join Date: Feb 2005
Location: Buffalo, Ny
Posts: 875
gnome volume applet won't control the volume

I have tried to no avail, to get the gnome volume applet to control my sound output, but it doesn't. All music and video player work nicely, but not all control the volume either such a Xine. Moving the volume control will make no difference and muting won't cut the sound out either in Xine or with gnome volume control applet.

When I use Amarok or Rythm Box, the volume controls on each application work perfectly, so I'm wondering if this is a gnome issue as the KDE apps seems to work right. The volume controls on the gnome CD player work also, but at no time does the gnome volume applet work for any of these.

Using a SB Live card. I have tweaked alsamixer and saved those settings, but nothing seems to work for this.
Any thoughts would be apprciated.

Thanks,
Jeff
Reply With Quote
  #2  
Old 14th February 2006, 09:01 PM
paul matthijsse Offline
Registered User
 
Join Date: Sep 2005
Location: Dieulefit, France
Posts: 721
Double click on your gnome sound applet icon and click Edit | Preferences in the menu. There you activate and deactivate lots of sound devices like microphone and speaker etc. Do not hesistate to activate unlogical options as well, because they may make your sound system work. I had to activate the Center audio channel to be able to use my microphone! But who cares about that? :-) Hope this helps.

Cheers, Paul.
Reply With Quote
  #3  
Old 14th February 2006, 09:27 PM
jhetrick62 Offline
Registered User
 
Join Date: Feb 2005
Location: Buffalo, Ny
Posts: 875
I did that Paul and it still didn't work. Thanks though.
Reply With Quote
  #4  
Old 15th February 2006, 12:35 AM
Dumbledore Offline
Registered User
 
Join Date: Jan 2006
Location: Austin, Texas (The red state's got a blue heart!)
Age: 22
Posts: 96
For mine, most of the audio goes through the Headphone control, instead of master volume or PCM. Try adjusting the Headphone slider on the playback tab (activate it first the way that was already said if it is not already there). You can change the preferences on Xine as to which slider will control it's volume by going into the controls (I don't have it installed, so I don't know the exact path, but just fool around with it).
__________________
If life gives you lemons, reprogram it so it takes money from Microsoft and deposites it in your bank account! :cool:
Reply With Quote
  #5  
Old 6th June 2007, 06:27 AM
joe.pelayo Offline
An ape descendant
 
Join Date: Dec 2006
Location: Mexico City
Age: 30
Posts: 3,104
What can you do if the GNOME Volume Applet does not even appear even if configured in Keyboard Shortcuts?
Is it a matter of installing/reinstalling something.

Thanks.
Joe.
__________________
Notebook: Acer Aspire 5536-5112.
AMD Athlon X2 QL64 @ 2.1GHz, 4GB DDR2 PC2-5300, ATI Radeon HD3200 (256MB), 250GB Toshiba HDD, HL-DT-ST DVDRAM GT20N
Fedora 16 x86_64

Netbook: Acer Aspire One A150
Intel Atom N270 @ 1.6GHz, 1.5 GB DDR2 PC2-4200, Intel Graphics (8MB?), 160GB Seagate HDD
Fedora 15 i686
Reply With Quote
  #6  
Old 6th June 2007, 10:17 PM
paul matthijsse Offline
Registered User
 
Join Date: Sep 2005
Location: Dieulefit, France
Posts: 721
Hey Joe, I suppose you know you can add the volume control to the task bar on the top of your screen, just put your mouse on it, right click and say Add new item, choose Volume Control. If that doesn't work, type in a terminal gnome-volume-control. If that doesn't work either, reinstall Fedora or switch to Ubuntu or even Windows, or find another hobby, or a nice girl friend! -

Paul.
Reply With Quote
  #7  
Old 7th June 2007, 01:48 AM
joe.pelayo Offline
An ape descendant
 
Join Date: Dec 2006
Location: Mexico City
Age: 30
Posts: 3,104
Quote:
Originally Posted by paul matthijsse
Hey Joe, I suppose you know you can add the volume control to the task bar on the top of your screen, just put your mouse on it, right click and say Add new item, choose Volume Control. If that doesn't work, type in a terminal gnome-volume-control. If that doesn't work either, reinstall Fedora or switch to Ubuntu or even Windows, or find another hobby, or a nice girl friend! -

Paul.
Hi Paul.

In fact I know of the volume icon in the task bar, it has always been there (please don't consider me such a dummy ). The thing that does not work in my laptop is the small dialog that appears in GNOME when you change the volume using the FN + UP (or DOWN) keys. Even if I configure those shortcuts under the Keyboard Shortcuts dialog, the darn thing won't change the volume (or mute it) when I use those keys combinations.

By the way, I already dual boot with Ubuntu 7.04 in this laptop and everything (including those shortcuts) work perfectly, even Beryl regardless of my crappy ATI card. So it is always possible I switch to Ubuntu as the main distro and FC as the back door distro. Windows is here only for legacy purposes.

Joe.
__________________
Notebook: Acer Aspire 5536-5112.
AMD Athlon X2 QL64 @ 2.1GHz, 4GB DDR2 PC2-5300, ATI Radeon HD3200 (256MB), 250GB Toshiba HDD, HL-DT-ST DVDRAM GT20N
Fedora 16 x86_64

Netbook: Acer Aspire One A150
Intel Atom N270 @ 1.6GHz, 1.5 GB DDR2 PC2-4200, Intel Graphics (8MB?), 160GB Seagate HDD
Fedora 15 i686
Reply With Quote
  #8  
Old 7th June 2007, 08:47 PM
paul matthijsse Offline
Registered User
 
Join Date: Sep 2005
Location: Dieulefit, France
Posts: 721
Hello Joe, I don't considered you a dumb newbie, I was just checking if something obvious was missing on your desktop.

Now for those keys, try other shortcut combos, as the Fn+VolUp button on laptops do not always work as they should (mainly bound to Windows of course). Depends if your OS in question recognizes and handles those keys as meant. On my Fedora computers I use the shortcut cntl-shift-numeric + and - to change the volume. Perhaps this works for you as well.

(PS -- and whispering now-- Not bad isn't it, that Ubuntu 7 thingy, I started using it as well! But psssst about this, as this is a "competing" forum/distro... -

Paul.
Reply With Quote
  #9  
Old 7th June 2007, 09:08 PM
joe.pelayo Offline
An ape descendant
 
Join Date: Dec 2006
Location: Mexico City
Age: 30
Posts: 3,104
Quote:
Originally Posted by paul matthijsse
Hello Joe, I don't considered you a dumb newbie, I was just checking if something obvious was missing on your desktop.

Now for those keys, try other shortcut combos, as the Fn+VolUp button on laptops do not always work as they should (mainly bound to Windows of course). Depends if your OS in question recognizes and handles those keys as meant. On my Fedora computers I use the shortcut cntl-shift-numeric + and - to change the volume. Perhaps this works for you as well.

(PS -- and whispering now-- Not bad isn't it, that Ubuntu 7 thingy, I started using it as well! But psssst about this, as this is a "competing" forum/distro... -

Paul.
Hello Paul.

I think I will try an alternate shortcut, however it remains a mystery for me some occasions when out of the sudden the shortcut worked (rebooted and no longer worked). I am tempted to believe there is screwed package somewhere, because I can assign the same key combinations to other tasks. Anyway that system's days are numbered (I want F7!).

I never mind to talk about Ubuntu here (or Fedora in the Ubuntu Forums), I think that is part of the freedom of speech (or whatever it is called), provided I don't insult or lie about them. I liked Debian 4.0 very much but unfortunately it does not support my graphics card for Beryl.

Thanks.
Joe.
__________________
Notebook: Acer Aspire 5536-5112.
AMD Athlon X2 QL64 @ 2.1GHz, 4GB DDR2 PC2-5300, ATI Radeon HD3200 (256MB), 250GB Toshiba HDD, HL-DT-ST DVDRAM GT20N
Fedora 16 x86_64

Netbook: Acer Aspire One A150
Intel Atom N270 @ 1.6GHz, 1.5 GB DDR2 PC2-4200, Intel Graphics (8MB?), 160GB Seagate HDD
Fedora 15 i686
Reply With Quote
  #10  
Old 7th June 2007, 09:38 PM
paul matthijsse Offline
Registered User
 
Join Date: Sep 2005
Location: Dieulefit, France
Posts: 721
Quote:
Originally Posted by joe.pelayo
I think I will try an alternate shortcut, however it remains a mystery for me [...]
I am daily in computers for over 20 years and I can positively confirm that there's a mysterious element in these boxes. One thing I learned is: don't try to understand weird behaviour that happens once in a while, that's usually a waste of time! Just find a work-around or something. In short: be as lazy as possible when you encounter computer problems! -

Paul.
Reply With Quote
  #11  
Old 7th June 2007, 10:08 PM
joe.pelayo Offline
An ape descendant
 
Join Date: Dec 2006
Location: Mexico City
Age: 30
Posts: 3,104
Quote:
Originally Posted by paul matthijsse
I am daily in computers for over 20 years and I can positively confirm that there's a mysterious element in these boxes. One thing I learned is: don't try to understand weird behaviour that happens once in a while, that's usually a waste of time! Just find a work-around or something. In short: be as lazy as possible when you encounter computer problems! -

Paul.
That's why I am trying different distros (PCLOS, Ubuntu, Debian) just to find the 'chosen' one for my laptop. My desktop has already chosen distro: Fedora.

Joe.
__________________
Notebook: Acer Aspire 5536-5112.
AMD Athlon X2 QL64 @ 2.1GHz, 4GB DDR2 PC2-5300, ATI Radeon HD3200 (256MB), 250GB Toshiba HDD, HL-DT-ST DVDRAM GT20N
Fedora 16 x86_64

Netbook: Acer Aspire One A150
Intel Atom N270 @ 1.6GHz, 1.5 GB DDR2 PC2-4200, Intel Graphics (8MB?), 160GB Seagate HDD
Fedora 15 i686
Reply With Quote
  #12  
Old 10th June 2007, 05:52 PM
spartas Offline
Registered User
 
Join Date: Sep 2006
Posts: 30
I'm having the same problem. My keyboard shortcuts for adjusting the volume controls do not work. I can adjust the volume just fine using the volume control applet. The shortcuts worked fine in FC6 and F7T4. The final version of F& is much better in a lot of areas than the previous two, except in the sound keyboard shortcuts.

Notes:
I did a full reinstall when migrating from test 4 to the final version of 7.

It's not just the volume shortcuts I'm having issues with. Ctrl+Alt+L doesn't lock the screen.
__________________
F14 x86_64
------------------
Intel Core 2 Duo 2.13 GHz Dual Core
Gigabyte 965P-DS3
nVidia 6800XT
3GB DDR2 667Mhz
Hardware Profile
Reply With Quote
  #13  
Old 10th June 2007, 06:52 PM
joe.pelayo Offline
An ape descendant
 
Join Date: Dec 2006
Location: Mexico City
Age: 30
Posts: 3,104
Quote:
Originally Posted by spartas
I'm having the same problem. My keyboard shortcuts for adjusting the volume controls do not work. I can adjust the volume just fine using the volume control applet. The shortcuts worked fine in FC6 and F7T4. The final version of F& is much better in a lot of areas than the previous two, except in the sound keyboard shortcuts.

Notes:
I did a full reinstall when migrating from test 4 to the final version of 7.

It's not just the volume shortcuts I'm having issues with. Ctrl+Alt+L doesn't lock the screen.
At least Ctrl+Alt+L does lock my screen (in FC6, I'll try in F7 later).

Considering that the volume shortcuts only worked when ALSA was working, I'll try to 'fix' ALSA in F7 (it does not work either) and then perhaps the shortcuts will work again. Unfortunately my orthodox method to fix ALSA (by installing it from source) may not be recognized by the shortcuts responsible applet (as seems to be the case in FC6). Anyway I will try.

Joe.

Joe.
__________________
Notebook: Acer Aspire 5536-5112.
AMD Athlon X2 QL64 @ 2.1GHz, 4GB DDR2 PC2-5300, ATI Radeon HD3200 (256MB), 250GB Toshiba HDD, HL-DT-ST DVDRAM GT20N
Fedora 16 x86_64

Netbook: Acer Aspire One A150
Intel Atom N270 @ 1.6GHz, 1.5 GB DDR2 PC2-4200, Intel Graphics (8MB?), 160GB Seagate HDD
Fedora 15 i686
Reply With Quote
  #14  
Old 11th June 2007, 10:51 PM
joe.pelayo Offline
An ape descendant
 
Join Date: Dec 2006
Location: Mexico City
Age: 30
Posts: 3,104
Hello everybody.

Well, today out of the sudden the volume shortcuts in the laptop started working (I rebooted and they still work). I should be happy because of this, but now that they work I realize about another problem here.

OK, I can happily use the volume shortcuts to see a small window which shows the volume level and can even mute it...in the screen because the truth is the actual volume is not changed at all! I'll explain, my sound card (Realtek, recognized somewhere as HDA Intel) has lots of 'options' (volume panels) where the only relevant one is that called 'Front' (there are also 'Center', 'Side', 'Mic', 'PCM', and many more). The point here is that regardless of the choice I make in the volume about which channel to control, the small little window I referred to before stubbornly wants to change PCM only and since the PCM volume control does nothing, the whole thing (shortcuts, the little window) is useless!

Is there something I can do to make that foolish little window (along with my shortcuts) understand I want it to change the 'Front' volume and not the 'PCM'?

Thanks.
Joe.
__________________
Notebook: Acer Aspire 5536-5112.
AMD Athlon X2 QL64 @ 2.1GHz, 4GB DDR2 PC2-5300, ATI Radeon HD3200 (256MB), 250GB Toshiba HDD, HL-DT-ST DVDRAM GT20N
Fedora 16 x86_64

Netbook: Acer Aspire One A150
Intel Atom N270 @ 1.6GHz, 1.5 GB DDR2 PC2-4200, Intel Graphics (8MB?), 160GB Seagate HDD
Fedora 15 i686
Reply With Quote
  #15  
Old 12th June 2007, 09:19 PM
paul matthijsse Offline
Registered User
 
Join Date: Sep 2005
Location: Dieulefit, France
Posts: 721
Hi, double click on the volume icon in your taskbar, then that window with several volume sliders appears. It has a menu as well, including an option for (something like) change sound device, if I remember well you can choose alsa and perhaps oss or the like. Try if changing something here helps. Also, elsewhere in that menu, activate as many as devices as possible, and see it that helps.

Paul.
Reply With Quote
Reply

Tags
applet, control, gnome, volume

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
volume control applet icon on gnome panel mdogruel Using Fedora 2 5th December 2010 01:31 AM
F11 Volume Control not remembering volume after logout of gnome JEO Using Fedora 4 18th August 2009 01:19 AM
how to restore gnome volume control applet in its original location? robatino Using Fedora 1 9th December 2008 11:09 PM
Gnome Volume control applet JuergenDD Using Fedora 0 18th September 2006 03:24 PM


Current GMT-time: 07:37 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat