Fedora Linux Support Community & Resources Center
  #1  
Old 16th February 2006, 10:35 AM
riksweeney Offline
Registered User
 
Join Date: Feb 2006
Posts: 8
Cannot run MPlayer fullscreen

Hi,

Toshiba M70 with ATI MRx700 GPU

I cannot run any movies in fullscreen using MPlayer. By this I mean that if I switch to fullscreen the movie doesn't stretch to fill the screen. I expect that this is a problem to do with my ATI driver.

I downloaded the ati-driver-installer-8.22.5-i386.run file from ati and installed that on my laptop and could then change the screen resolution, but I cannot stretch the image in MPlayer. XMAME also reports that "DGA requires root rights", but there is no entry in my xorg.conf file to do with DGA.

Does anyone know what the problem could be? Have I downloaded the wrong driver?

Thanks

Richard
Reply With Quote
  #2  
Old 16th February 2006, 12:28 PM
LocutusOfBorg Offline
Registered User
 
Join Date: Aug 2005
Posts: 684
It could be a problem of the mplayer video output driver: be sure to use xv

mplayer -vo xv -fs myfile.avi

if it works, put this lines

vo=xv
fs=yes

in your ~/.mplayer/config file.
If you use the gui, set the right vidoe output driver in the config window
__________________
I am Bill of Borg. Resistance izkx GPF 0x5654 8820 Application
RESIST.EXE has performed an illegal operation and will be shut down.
Reply With Quote
  #3  
Old 16th February 2006, 01:12 PM
riksweeney Offline
Registered User
 
Join Date: Feb 2006
Posts: 8
Quote:
Originally Posted by LocutosOfBorg
It could be a problem of the mplayer video output driver: be sure to use xv

mplayer -vo xv -fs myfile.avi

if it works, put this lines

vo=xv
fs=yes

in your ~/.mplayer/config file.
If you use the gui, set the right vidoe output driver in the config window
Thanks, I tried a few of the vo settings and found one that works a treat.

Thanks a lot!
Reply With Quote
  #4  
Old 25th June 2006, 05:49 AM
dewangpm Offline
Registered User
 
Join Date: Jul 2005
Posts: 140
Quote:
Originally Posted by riksweeney
Thanks, I tried a few of the vo settings and found one that works a treat.

Thanks a lot!
WHAT EXACTLY DID YOU TRY? IT WILL HELP ME. PLEASE TELL ME A DETAIL PROCEDURE. I AM VERY NEW SO HAVE TO TELL DETAILS.

PLEASE.

DEWANGPM
Reply With Quote
  #5  
Old 25th November 2007, 08:04 PM
johnnash Offline
Registered User
 
Join Date: Nov 2007
Posts: 19
Follow this here:
http://paulsdigitalworld.blogspot.co...ion-guide.html

Make sure you install everything (especially the codecs) and then switch the drivers in preferences. See if one works for you. If not, run mplayer in terminal, and post your error messages.
Reply With Quote
Reply

Tags
fullscreen, mplayer, run

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer -vo xv won't do antialias in fullscreen mod ildg Using Fedora 10 27th November 2007 04:04 AM
vlc fullscreen daven1986 Using Fedora 2 18th December 2006 12:18 AM
mplayer fullscreen problem jafar Using Fedora 1 6th January 2006 11:46 AM
Mplayer hide mouse cursor in fullscreen? madiyaan Using Fedora 0 20th September 2005 11:49 PM


Current GMT-time: 15:53 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Halong Bay Cruise Pier Photos - Le Meridien Zhengzhou