Fedora Linux Support Community & Resources Center
  #1  
Old 27th February 2006, 01:02 AM
cstager Offline
Registered User
 
Join Date: Feb 2006
Location: Austin, TX
Posts: 1
Memory Alloc returned NULL. install exited abnormally

I am helping my daughter build a computer from componants. We run the FC4 install with most functions as default. It runs fine through all configuration screens. After it starts it has an error as follows:
Memory Alloc (177975 bytes)returned NULL.
Install exited abnormally
sending termination signals.

Any ideas on what to try?

We scraped together most of them from others so we don't know if all parts are 100% but we have not found any specific hardware problems yet. It is an AMD Athalon 1 Ghz on a Asus A7V with 384 Mb of RAM.

Thanks,
Chuck
Reply With Quote
  #2  
Old 27th February 2006, 02:35 AM
jcliburn Offline
Registered User
 
Join Date: Nov 2004
Location: Mississippi, USA
Posts: 1,180
You're probably running out of memory. My FC4 x86_64 system with Firefox, Gnome/Metacity, and a single Gnome terminal window open consumes 850+ MB of RAM.

[jcliburn@osprey ~]$ cat /proc/meminfo
MemTotal: 1020064 kB
MemFree: 162048 kB
Buffers: 66348 kB
Cached: 479484 kB
SwapCached: 0 kB
Active: 526924 kB
Inactive: 220692 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 1020064 kB
LowFree: 162048 kB
SwapTotal: 2031608 kB
SwapFree: 2031608 kB
Dirty: 0 kB
Writeback: 0 kB
Mapped: 264864 kB
Slab: 74588 kB
CommitLimit: 2541640 kB
Committed_AS: 417504 kB
PageTables: 9156 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 36384 kB
VmallocChunk: 34359701603 kB
HugePages_Total: 0
HugePages_Free: 0
Hugepagesize: 2048 kB
Reply With Quote
  #3  
Old 27th February 2006, 02:54 AM
jcliburn Offline
Registered User
 
Join Date: Nov 2004
Location: Mississippi, USA
Posts: 1,180
Wow, my machine was using a LOT of memory, so I rebooted. Looks like about 240 MB in use right after boot (with Firefox, Gnome/Metacity, and one Gnome term open).

[jcliburn@osprey ~]$ cat /proc/meminfo
MemTotal: 1020064 kB
MemFree: 705160 kB
Buffers: 15572 kB
Cached: 140380 kB
SwapCached: 0 kB
Active: 137792 kB
Inactive: 104808 kB

HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 1020064 kB
LowFree: 705160 kB
SwapTotal: 2031608 kB
SwapFree: 2031608 kB
Dirty: 256 kB
Writeback: 0 kB
Mapped: 129400 kB
Slab: 38224 kB
CommitLimit: 2541640 kB
Committed_AS: 257432 kB
PageTables: 8592 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 36376 kB
VmallocChunk: 34359701603 kB
HugePages_Total: 0
HugePages_Free: 0
Hugepagesize: 2048 kB
Reply With Quote
  #4  
Old 27th February 2006, 03:00 AM
jcliburn Offline
Registered User
 
Join Date: Nov 2004
Location: Mississippi, USA
Posts: 1,180
Can you boot to runlevel 3 (to conserve memory by avoiding X)? Maybe not all your DIMMs are being recognized/used? If you can get to runlevel 3, cat /proc/meminfo to see how much RAM is available. Also, check to see if swap is enabled. An easy way to do that (and see memory usage too) is with the "top" command. The first 4 lines of the output will show memory and swap.

Code:
Tasks:  94 total,   1 running,  93 sleeping,   0 stopped,   0 zombie
Cpu(s):  5.0% us,  2.0% sy,  0.0% ni, 86.2% id,  6.5% wa,  0.0% hi,  0.2% si
Mem:   1020064k total,   316172k used,   703892k free,    15760k buffers
Swap:  2031608k total,        0k used,  2031608k free,   140192k cached
Reply With Quote
  #5  
Old 27th February 2006, 03:34 AM
jcliburn Offline
Registered User
 
Join Date: Nov 2004
Location: Mississippi, USA
Posts: 1,180
Well, I just reread your post, and it occurred to me you never finished the installation, so you can't do the things I suggested above. Sorry.

Verify that BIOS can see all 384 MB of RAM. If it does, insert Fedora disk 1 and type "memtest" at the very first prompt (the boot: prompt). That will initiate memtest86+. You should run it for hours (overnight, or as long as you can); it'll loop until you stop it.
Reply With Quote
Reply

Tags
abnormally, alloc, exited, install, memory, null, returned

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
YUM, PUP, RPM fail during removal of packages with memory alloc (4 bytes) return NULL sherwingws Using Fedora 8 9th June 2006 02:00 AM
FC4 install - exited abnormally marko EOL (End Of Life) Versions 2 2nd September 2005 03:19 AM
install exited abnormally Briscofan Installation, Upgrades and Live Media 0 6th August 2005 02:28 AM


Current GMT-time: 13:48 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Sechura Photos - Gyongyos Instagram Photos - Hikone Instagram Photos