Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #16  
Old 21st March 2006, 06:59 PM
bK_Coder Offline
Registered User
 
Join Date: Aug 2005
Posts: 7
Quote:
Originally Posted by Lorquas
i get a the same problem that Alexandr K gets by following your instructions,

Code:
# rpm -Uvh kmod-nvidia-1.0.8178-0.*$(uname -r)*.rpm xorg-x11-drv-nvidia-1.0.8178-0.lvn.5.i386.rpm
error: File not found by glob: kmod-nvidia-1.0.8178-0.*2.6.16-1.2064_FC5*.rpm
error: Failed dependencies:
        kmod-nvidia >= 1.0.8178 is needed by xorg-x11-drv-nvidia-1.0.8178-0.lvn.5.i386
everything else up to that worked fine..
same here... followed the guide, fixed the typos... I have no idea what's wrong...
Reply With Quote
  #17  
Old 21st March 2006, 07:00 PM
bK_Coder Offline
Registered User
 
Join Date: Aug 2005
Posts: 7
double-post... laggy net here today :S
Reply With Quote
  #18  
Old 21st March 2006, 07:12 PM
TjaBBe Offline
Registered User
 
Join Date: Feb 2006
Location: The Netherlands
Age: 31
Posts: 15
Quote:
Originally Posted by bK_Coder
same here... followed the guide, fixed the typos... I have no idea what's wrong...
Did you do
Code:
su
or
Code:
su -
like the guide says? (Mind the "-"). I have found that when I just did "su" the kmod-nvidia package fails to install... (Also if you use onlu "su" modprobe will not work... I suspect this is enforced by SELinux, is this correct?)

For myself, I have the same problems as Sigrun has... With SELinux disabled (or in Permissive mode) everything is fine, but with SELinux in enforcing mode I get:

Code:
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
I figured out, from nvidia's site, that SELinux requires a special module setting:

Quote:
What is SELinux and how does it interact with the NVIDIA driver ?


Security-Enhanced Linux (SELinux) is a set of modifications applied to the Linux kernel and utilities that implement a security policy architecture. When in use it requires that the security type on all shared libraries be set to 'shlib_t'. The installer detects when to set the security type, and sets it on all shared libraries it installs. The option --force-selinux passed to the .run file overrides the detection of when to set the security type.
Would this explain this problem, if so, what did I ( / we) do wrong or how can this be fixed. (Still working on it myself in the meantime) :-).
Reply With Quote
  #19  
Old 21st March 2006, 07:32 PM
bK_Coder Offline
Registered User
 
Join Date: Aug 2005
Posts: 7
Quote:
Originally Posted by TjaBBe
Did you do
Code:
su
or
Code:
su -
like the guide says? (Mind the "-"). I have found that when I just did "su" the kmod-nvidia package fails to install... (Also if you use onlu "su" modprobe will not work... I suspect this is enforced by SELinux, is this correct?)
su - (with the '-'), I always do this, it's a reflex SELinux disabled, I'm using reiserfs, and don't want to experience any performance loss...

Still no luck..
Reply With Quote
  #20  
Old 21st March 2006, 08:29 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Sorry, I keep having to mod the instructions as I find easier methods and the locations of things are changing quickly, I made a small howto. Please remove all RPM files an start fresh:
Code:
su -
rm /root/*.rpm /etc/yum.repos.d/*.rpm /root/nvidia/*.rpm
And then try the new instructions. I had made 2 small mistakes.
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #21  
Old 21st March 2006, 10:04 PM
TjaBBe Offline
Registered User
 
Join Date: Feb 2006
Location: The Netherlands
Age: 31
Posts: 15
Quote:
Originally Posted by Firewing1
Sorry, I keep having to mod the instructions as I find easier methods and the locations of things are changing quickly, I made a small howto. Please remove all RPM files an start fresh:
Code:
su -
rm /root/*.rpm /etc/yum.repos.d/*.rpm /root/nvidia/*.rpm
And then try the new instructions. I had made 2 small mistakes.
Firewing1
Thanks! There is just one more small mistake in the howto now, as I see it:

Code:
chkconfig nvidia-glx start
service nvidia-glx on
chkconfig should have on as parameter, and service should have start.
Reply With Quote
  #22  
Old 21st March 2006, 10:06 PM
TjaBBe Offline
Registered User
 
Join Date: Feb 2006
Location: The Netherlands
Age: 31
Posts: 15
Quote:
Originally Posted by Sigrun
I figured it out. It's an issue with SELinux. When I disable SELinux it works correctly and loads the GLX module without any problems. I guess tomorrow I'll try to take a look at the SELinux policies and try to figure out what is causing the problem. For now, it's time to finally get some sleep. Cheers.
To use this tutorial with SELinux as it is you should "Allow the use of shared libraries with Text Relocation" in the SELinux Policy. You can find it under "Compatibility".

Cheers!
Reply With Quote
  #23  
Old 21st March 2006, 10:39 PM
babylonrap Offline
Registered User
 
Join Date: Mar 2006
Location: Houston
Age: 42
Posts: 1
Still no go on SMP (HT)

I followed the instructions (without the typos) and still have not luck. I don't get anything, it just locks up with a black screen and have to do a hard reboot. But then again, I couldn't install 8178 on FC4 either got the same result I could only get 7667 to work.

Any suggestions?
Reply With Quote
  #24  
Old 21st March 2006, 10:40 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Quote:
Originally Posted by TjaBBe
chkconfig should have on as parameter, and service should have start.
lol... I guess that's what heppens when you write howto's at 12am, eh?
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #25  
Old 21st March 2006, 11:01 PM
vindvaki Offline
Registered User
 
Join Date: Apr 2005
Posts: 3
how about using the atrpms.net binaries?

Anyone know if the nvidia packages from Atrpms for FC5 work decently, and if so, is there any additional configuration needed? (for the packages see http://www.atrpms.net/dist/fc5/ under "nvidia-")
Reply With Quote
  #26  
Old 21st March 2006, 11:32 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Never use ATrpms packages as they replace Redhat ones
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #27  
Old 21st March 2006, 11:43 PM
conradwoo Offline
Registered User
 
Join Date: Mar 2006
Location: Toronto, Canada
Posts: 3
I'm kinda new to linux....sorry if this is a stupid question

How long does it take to usually complete the rpmbuild step? Right now, its stuck at "Building for target uname -m" and its been there for like 10-15 mins. I'm not sure if my hard drive should be making any of the usual r/w noises but its not, so I'm assuming that it's not doing anything?
Reply With Quote
  #28  
Old 21st March 2006, 11:57 PM
conradwoo Offline
Registered User
 
Join Date: Mar 2006
Location: Toronto, Canada
Posts: 3
Oops..guess I had to wait just a bit longer

However, after all that waiting , it didn't work...this is what i see:

Code:
[root@localhost nvidia]# rpmbuild --rebuild --target `uname -m` nvidia-kmod-*.src.rpm
Installing nvidia-kmod-1.0.8178-0.lvn.3.2.6.15_1.1881_FC5.src.rpm
warning: user thl does not exist - using root
warning: group cttest does not exist - using root
warning: user thl does not exist - using root
warning: group cttest does not exist - using root
warning: user thl does not exist - using root
warning: group cttest does not exist - using root
warning: user thl does not exist - using root
warning: group cttest does not exist - using root
Building target platforms: i686
Building for target i686
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.86748
+ umask 022
+ cd /usr/src/redhat/BUILD
+ sh /usr/src/redhat/SOURCES/kmodtool rpmtemplate nvidia 2.6.16-1.2064_FC5 ''
%package       -n kmod-nvidia
Summary:          nvidia kernel module(s)
Group:            System Environment/Kernel
Provides:         kernel-module = 2.6.16-1.2064_FC5
Provides:         kmod-nvidia = %{version}-%{release}
Requires:         kernel-%{_target_cpu} = 2.6.16-1.2064_FC5
Requires:         nvidia-kmod-common = %{version}
Requires(post):   /sbin/depmod
Requires(postun): /sbin/depmod
BuildRequires:    kernel-devel-%{_target_cpu} = 2.6.16-1.2064_FC5
%description   -n kmod-nvidia
This package provides the nvidia kernel modules built for the Linux
kernel 2.6.16-1.2064_FC5 for the %{_target_cpu} family of processors.
%post          -n kmod-nvidia
/sbin/depmod -aeF /boot/System.map-2.6.16-1.2064_FC5 2.6.16-1.2064_FC5 > /dev/null || :
%postun        -n kmod-nvidia
/sbin/depmod -aF /boot/System.map-2.6.16-1.2064_FC5 2.6.16-1.2064_FC5 &> /dev/null || :
%files         -n kmod-nvidia
%defattr(644,root,root,755)
/lib/modules/2.6.16-1.2064_FC5/extra/nvidia/

+ cd /usr/src/redhat/BUILD
+ rm -rf nvidia-kmod-1.0.8178
+ /bin/mkdir -p nvidia-kmod-1.0.8178
+ cd nvidia-kmod-1.0.8178
+ /usr/bin/bzip2 -dc /usr/src/redhat/SOURCES/nvidia-glx-kmod-data-1.0.8178.tar.bz2
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ for kvariant in '""'
+ cp -a nvidiapkg-x86 _kmod_build_
+ pushd _kmod_build_
/usr/src/redhat/BUILD/nvidia-kmod-1.0.8178/_kmod_build_ /usr/src/redhat/BUILD/nvidia-kmod-1.0.8178
+ echo 'Patch #0 (NVIDIA_kernel-1.0-8178-U012206.diff.txt):'
Patch #0 (NVIDIA_kernel-1.0-8178-U012206.diff.txt):
+ patch -p0 -s
+ popd
/usr/src/redhat/BUILD/nvidia-kmod-1.0.8178
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.3843
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nvidia-kmod-1.0.8178
+ for kvariant in '""'
+ ksrc=/usr/src/kernels/2.6.16-1.2064_FC5-i686
+ pushd _kmod_build_/usr/src/nv/
/usr/src/redhat/BUILD/nvidia-kmod-1.0.8178/_kmod_build_/usr/src/nv /usr/src/redhat/BUILD/nvidia-kmod-1.0.8178
+ ln -s -f Makefile.kbuild Makefile
+ make SYSSRC=/usr/src/kernels/2.6.16-1.2064_FC5-i686 module
./conftest.sh: line 19: cc: command not found
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.3843 (%build)


RPM build errors:
    user thl does not exist - using root
    group cttest does not exist - using root
    user thl does not exist - using root
    group cttest does not exist - using root
    user thl does not exist - using root
    group cttest does not exist - using root
    user thl does not exist - using root
    group cttest does not exist - using root
    Bad exit status from /var/tmp/rpm-tmp.3843 (%build)
[root@localhost nvidia]#
what went wrong?

Last edited by conradwoo; 22nd March 2006 at 12:02 AM.
Reply With Quote
  #29  
Old 22nd March 2006, 12:06 AM
Sigrun Offline
Registered User
 
Join Date: Mar 2006
Posts: 4
Quote:
Originally Posted by TjaBBe
To use this tutorial with SELinux as it is you should "Allow the use of shared libraries with Text Relocation" in the SELinux Policy. You can find it under "Compatibility".

Cheers!
That fixed it and I've now got everything working with SELinux enabled. Thanks for the help.
Reply With Quote
  #30  
Old 22nd March 2006, 01:37 AM
spankaccount Offline
Registered User
 
Join Date: May 2004
Age: 36
Posts: 4
Check kmod-nvidia-1.0.8178-0.*$(uname -r)*.rpm. I have an smp kernel so the actual name of the rpm is kmod-smp-nvidia...
Reply With Quote
Reply

Tags
cards, core, fedora, nvidia, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting ATi cards to work in Fedora Firewing1 Guides & Solutions (No Questions) 785 24th January 2010 07:30 PM
Is there a list of videro cards that work well with Fedora Core 7? mrappe Hardware & Laptops 2 14th September 2007 03:34 PM
can't get Fedora Core 6 to work with nvidia cards, help sf_basilix Installation, Upgrades and Live Media 16 18th January 2007 02:49 PM
Wireless cards work with Fedora core 5 axiom Using Fedora 0 27th July 2006 08:04 PM
Nvidia cards on Fedora Core 3 ravalox Fedora Core 3 Test Releases 8 7th November 2004 02:53 AM


Current GMT-time: 14:16 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat