PDA

View Full Version : unable to configure inbuilt webcam on tx1000 series laptop



khurman
31st December 2007, 04:46 AM
Hi, I am trying to configure webcam on my HP 1308 laptop and getting following error while installing UVC driver

[root@localhost trunk]# make
Building USB Video Class driver...
/bin/sh: line 0: cd: /lib/modules/2.6.23.9-85.fc8/build: No such file or directory
make: *** [uvcvideo] Error 1

please advise.. when i try to create directory ..../build i get a message that directory already exists.

glennzo
31st December 2007, 01:54 PM
Did you run ./configure first?

davechoy
31st December 2007, 10:03 PM
Hi,

I am having problems getting FC8x64 to recognise my WebCam. I tried to modprobe the UVCVideo webcan driver and get the following error....

[root@localhost davefed]# /sbin/modprobe uvcvideo
FATAL: Module uvcvideo not found.

And here is my lsusb output.....

[root@localhost davefed]# /sbin/lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 0c45:62c0 Microdia
Bus 001 Device 004: ID 08ff:1600 AuthenTec, Inc.
Bus 001 Device 002: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
Bus 001 Device 001: ID 0000:0000

I believe the Webcam is the Microdia device with ID 0x0c45:62c0. Using the v4l2-tool, it advices that the UVCvideo driver but as you can see above, the driver module is not available.

Thanks

Dave

khurman
4th January 2008, 01:09 PM
Did you run ./configure first?

Hi when i run the ./configure command I get error about file not being present.

The files in the folder are

ls -l
total 256
-rwxrwxrwx 1 root root 5946 2007-12-31 00:00 dynctrl.txt
-rwxrwxrwx 1 root root 732 2007-12-31 00:00 Makefile
-rwxrwxrwx 1 root root 6031 2007-12-31 00:00 uvc_compat.h
-rwxrwxrwx 1 root root 29826 2007-12-31 00:00 uvc_ctrl.c
-rwxrwxrwx 1 root root 51977 2007-12-31 00:00 uvc_driver.c
-rwxrwxrwx 1 root root 4291 2007-12-31 00:00 uvc_isight.c
-rwxrwxrwx 1 root root 11472 2007-12-31 00:00 uvc_queue.c
-rwxrwxrwx 1 root root 2674 2007-12-31 00:00 uvc_status.c
-rwxrwxrwx 1 root root 28449 2007-12-31 00:00 uvc_v4l2.c
-rwxrwxrwx 1 root root 26363 2007-12-31 00:00 uvc_video.c
-rwxrwxrwx 1 root root 23355 2007-12-31 00:00 uvcvideo.h

glennzo
4th January 2008, 01:29 PM
Configure should have been part of the package you downloaded, the .tar.gz file.

Here's a link to some supported cams, http://mxhaard.free.fr/spca5xx.html