PDA

View Full Version : CIFS and fstab problems



Gsundbrunn
21st February 2006, 02:08 PM
Hi,

i successfully upgraded my fc4 to fc5 - works fine - but I have two unsolved issues. Usually i mount my windows schares during boot with fstab and smbfs. I changed it to cifs but I always get the message: "the mountpoint /home/stefan/mnt/storage" does not exist. This is the related entry of my fstab:

//192.168.1.11/storage /home/stefan/mnt/storage cifs auto,owner,rw,username=stefan,workgroup=nettech,pa ssword=geheim,uid=500,gid=500 0 0

The directory /home/stefan/mnt/storage really exists. Any help is appreaciated!

Best regards

Stefan

Gsundbrunn
21st February 2006, 02:13 PM
Ah... Fixed it inbetween...

cifs does not support other directories than /mnt.

I created now /mnt/storage instead of /home/stefan/mnt/storage and it works fine. Interesting...

Regards

Stefan

Neuropa
25th March 2006, 11:21 AM
I have permissions problems with CIFS and fstab in FC5...

Server Fedora Core 4 - Samba installed, configured and running.
I have many users in my LAN, all registerd in "Samba Users" with password on the Server.
On the FC4 Server there are 2 shares with read/write permissions for all users.

From Windows clients I can access to the shares without problems.
From FC4 clients I can access too, with smbfs. This is the /etc/fstab entry:
//192.168.1.1/Shared /mnt/shared smbfs username=xxxxx,password=xxxxx,umask=2,dmask=777,fm ask=777 0 0

The new Fedora Core 5 client can't use smbfs, so I have modified /etc/fstab in this way:
//192.168.1.1/Shared /mnt/shared cifs auto,user,username=xxxxx,workgroup=xxxxx,password= xxxxx,uid=500,gid=500,rw 0 0

I can mount the partition, without errors, but I don't have write permissions!
When I create a new folder, this folder has read only permissions... so I can rename or delete it only from FC4 (or Windows) clients...
And even... if I create a text file in the share with an FC4 client, this file can't be read or modified by FC5!!

Can you help me, please? :confused:

Thanks...

tomekp
14th April 2006, 12:11 PM
try setting file_mode and dir_mode options also. example:
//192.168.1.1/Shared /mnt/shared cifs auto,user,username=xxxxx,workgroup=xxxxx,password= xxxxx,uid=500,gid=500,file_mode=0777,dir_mode=0777 ,rw 0 0
it works for me.