FedoraForum.org

FedoraForum.org (https://forums.fedoraforum.org/index.php)
-   Installation, Upgrades and Live Media (https://forums.fedoraforum.org/forumdisplay.php?f=6)
-   -   Bootloader Failing to Install (https://forums.fedoraforum.org/showthread.php?t=282176)

skutr3 13th July 2012 01:48 AM

Bootloader Failing to Install
 
Hi. I have attempted several times to install (fresh) F17 (dual-booting W7) from both DVD and LiveCD. At the end of every install, I get an error that reads, "The bootloader failed to install. The system may not be bootable." I restart the computer, and Windows boots. There is no more detail on the error message. I have tried using rescue on the DVD and using chroot to install GRUB
(Using
Code:

grub2-install /dev/sda)
.)
The output is along the lines of: This LDM doesn't have an embedding partition. Embedding is not possible. GRUB can only be installed on this setup using blocklists. However, blocklists are unreliable and their use is discouraged. I don't know what to do because I am new to this, and I sincerely apologize for the lack of information and knowledge. I appreciate any help. :)

stoat 13th July 2012 12:28 PM

Re: Bootloader Failing to Install
 
That may have happened because the first partition of your hard drive starts in sector 63, and core.img may be too large to go in its usual place between the master boot record and the first partition.

One thing you can try is to proceed with the "blocklist" thing. It may be discouraged, but it still works. It's discouraged because GRUB 2 will use the core.img in the filesystem instead, but the boot.img thingy that gets installed in the master boot record has to find it by its sector address. That is the unreliable part: the sector address of core.img in the filesystem is subject to change. But I say so what. IMO, boot loader breakage due to that reason will be rare (because we did this all the time with legacy GRUB and stage1/1.5/2). And if it does happen, you can fix it in a minute.

If you want to try this idea, then get back into that rescue mode with the DVD and use the --force option with that same grub2-install command you tried before (but without the parenthesis typo).

WARNING...

If you try this and it fails to boot Fedora, then nothing may boot. So before you do it, make sure that you have the means and the knowledge to repair the Windows boot loader in the master boot record.

Also, this blocklist thing will work only if Fedora is on that same hard drive. It will not work across different drives.

No promises for anything above this sentence.

There are other ways to deal with this issue.

hadrons123 13th July 2012 01:30 PM

Re: Bootloader Failing to Install
 
@stoat What you say sounds reasonable. i 'm not an expert at partitioniong layouts.

But I had the similar issue as the OP with just fedora installed on my hard disk. I tried to reinstall and everytime, fedora 17 couldnt be installed with a boot loader, but other distros got installed on the same hard disk with out an issue (multiple times). But some one in our forum suggested to backup the data, reformat the whole HDD with a new partition table and after doing that now I have fedora installed without any trouble.

@OP

you can try
Code:

fixmbr
by booting using a windows recovery disk and try fixing the mbr and retry the Fedora installation, But here I asssuming a case of corrupted MBR.

nonamedotc 13th July 2012 02:52 PM

Re: Bootloader Failing to Install
 
I thought this problem was over with TC3 DVD?! Anyway, I would also recommend installing reformatting and reinstalling if you have a windows install media also handy.

Also, see this thread. There was some discussion here ...

Oh ! and by the way - just in case restoring Windows 7 MBR

hadrons123 13th July 2012 03:37 PM

Re: Bootloader Failing to Install
 
@nonamedotc useful links!

I had a lot of trouble with TC3 DVD. I thought it started the trouble. But it looks like the OP has the same issue with final version too.

skutr3 13th July 2012 05:41 PM

Re: Bootloader Failing to Install
 
I tried to run,
Code:

grub2-install /dev/sda/ --force
. I got
Code:

error: cannot find a GRUB drive for /dev/sda/. Check your device.map.
. I cannot seem to find this file. Btw, thanks for your replies.

stoat 13th July 2012 05:47 PM

Re: Bootloader Failing to Install
 
grub2-install --force --recheck /dev/sda

skutr3 13th July 2012 05:53 PM

Re: Bootloader Failing to Install
 
Got the same output.

stoat 13th July 2012 07:57 PM

Re: Bootloader Failing to Install
 
Well, in the end, there are several other ways to boot a Linux kernel. In fact, I don't use any version of GNU GRUB any more. So something will eventually be able to boot this system. But I don't think that is what you're interested in (at least not yet). You simply want Fedora to install its boot loader. So do I, but I'm out of ideas for that.

Consider the other two guys' suggestion of reformatting and re-installing everything (if that is something you're willing to do). If you do that, and it's a BIOS system with a traditional MBR, then use something to format the Windows partition starting in sector 2048. Most any new utility will do it.

Also, I'm nearly certain that people have successfully used partition managers to move existing Windows partitions to sector 2048 when there wasn't room for core.img. But I don't even really know if that is the problem here.

Anyway, while you are waiting for someone with the definitive answer to come along, take a moment to describe the situation better for the record. Things like BIOS v. EFI, GPT v. msdos mbr, the existing partition layout, maybe the output of fdisk -l. Things like that may be helpful and may even be part of the problem.

skutr3 13th July 2012 08:17 PM

Re: Bootloader Failing to Install
 
I can tell you that it is MBR and uses BIOS. I am not at the machine at the moment, but when I get a chance, I will upload a screenshot of my current layout.

skutr3 13th July 2012 08:27 PM

Re: Bootloader Failing to Install
 
1 Attachment(s)
Here is the layout. I used the "replace existing Linux system" feature on the installer. As for the output of fdisk -l, I don't have a Linux system to run the command...Attachment 23424

d3spinoz4 14th July 2012 12:12 AM

Re: Bootloader Failing to Install
 
Hi Guys,

I don't know if this is the right thread but I installed fc17 fresh install (no dual boot) and at the end it gave me an error saying "error installing boot loader, system may not be bootable) after reboot it takes me to a grub prompt.

so far this is my partitioning using mbr and BIOS: /dev/sda1 = boot partiton, /dev/sda2 = swap, and /dev/sdb3 = /

I found this link http://fedoraproject.org/wiki/GRUB_2 where there is a fix in the "dreaded GRUB 2 boot prompt" section and I'm able to issue all the commands and get the system to boot but once logged in it says to run the grub2-mkconfig and install commands and I ran them but after a reboot it takes me back to the grub prompt.

I love fedora and I want to run 17 but due to my lack of linux and grub/grub2 knowledge I've hit a wall. what could I do to make it stay? I mean configure grub2 or install it right so it boots correctly all the time?

any help will be appreciated, Thanks!

stoat 14th July 2012 02:41 AM

Re: Bootloader Failing to Install
 
d3spinoz4,

Since you are able to manually boot your system, I recommend that you download the free and popular utility known as Boot Info Script, untar it, and run it in a Fedora terminal as root. It will output to a text file a very informative and useful description of all boot loaders it can find, where they are located, what they boot, and lots of other stuff. Return here and paste the whole output of that or attach the output text file. Maybe somebody will be able to identify something for you to try next.

d3spinoz4 16th July 2012 03:33 AM

Re: Bootloader Failing to Install
 
sorry for the late reply, here's the content of the RESULT.txt file:

Boot Info Script 0.61 [1 April 2012]


============================= Boot Info Summary: ===============================

=> Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of
the same hard drive for core.img. core.img is at this location and looks
in partition 99 for .

sda1: __________________________________________________ ________________________

File system: ext4
Boot sector type: -
Boot sector info:
Operating System:
Boot files:

sda2: __________________________________________________ ________________________

File system: swap
Boot sector type: -
Boot sector info:

sda3: __________________________________________________ ________________________

File system: ext4
Boot sector type: -
Boot sector info:
Operating System: Fedora release 17 (Beefy
Miracle) Kernel on an ()
Boot files: /etc/fstab

============================ Drive/Partition Info: =============================

Drive: sda __________________________________________________ ___________________

Disk /dev/sda: 300.0 GB, 300000000000 bytes
255 heads, 63 sectors/track, 36472 cylinders, total 585937500 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition Boot Start Sector End Sector # of Sectors Id System

/dev/sda1 * 2,048 4,196,351 4,194,304 83 Linux
/dev/sda2 4,196,352 20,768,767 16,572,416 82 Linux swap / Solaris
/dev/sda3 20,768,768 585,936,895 565,168,128 83 Linux


"blkid" output: __________________________________________________ ______________

Device UUID TYPE LABEL

/dev/sda1 d30fc270-92ae-4bb8-b988-55bd418e5b1c ext4
/dev/sda2 3af9d9c3-cfd1-4457-bb04-6db342917f90 swap
/dev/sda3 dfbf6d0c-4b93-40b0-bfbe-36024aea505a ext4

================================ Mount points: =================================

Device Mount_Point Type Options

/dev/sda1 /boot ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)
/dev/sda3 / ext4 (rw,relatime,user_xattr,barrier=1,data=ordered)


=================== sda1: Location of files loaded by Grub: ====================

GiB - GB File Fragment(s)

0.157062531 = 0.168644608 initramfs-3.3.4-5.fc17.x86_64.img 1
0.137207031 = 0.147324928 vmlinuz-3.3.4-5.fc17.x86_64 1

=============================== sda3/etc/fstab: ================================

--------------------------------------------------------------------------------

#
# /etc/fstab
# Created by anaconda on Fri Jul 13 14:46:43 2012
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=dfbf6d0c-4b93-40b0-bfbe-36024aea505a / ext4 defaults 1 1
UUID=d30fc270-92ae-4bb8-b988-55bd418e5b1c /boot ext4 defaults 1 2
UUID=3af9d9c3-cfd1-4457-bb04-6db342917f90 swap swap defaults 0 0
--------------------------------------------------------------------------------

=============================== StdErr Messages: ===============================

mdadm: No arrays found in config file or automatically

stoat 16th July 2012 02:17 PM

Re: Bootloader Failing to Install
 
I recommend running the grub2-mkconfig and grub2-install commands again.
Code:

su
grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda



All times are GMT +1. The time now is 10:29 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.