FedoraForum.org (https://forums.fedoraforum.org/index.php)
-   Using Fedora (https://forums.fedoraforum.org/forumdisplay.php?f=7)
-   -   fedora 8 & pulse audio - nonroot users have no sound (https://forums.fedoraforum.org/showthread.php?t=171083)

high 16th November 2007 10:47 PM

fixed my issue by enabling ConsoleKit service... ugh why is pulse depended on that :(

im the only user on my system and try to keep it minimal :)

strikeforce 17th November 2007 12:23 AM

ConsoleKit controls the permissions throughout your system thats why :) It's easier having that.

xaltednet 18th November 2007 07:56 AM

I have got mine working
I am running xps m1210 with intel sounds card running fedora 8+KDE

NOTE... neither my mic, webcam, our card reader was respoinding until i got my sound driver working

I added this to /etc/security/console.perms.d/50-default-perms
at the top:
<sound>=/dev/dsp* /dev/snd/*
at the bottom:
<console> 0666 <sound> 0600 root

I did not do this:
yum remove alsa-plugins-pulseaudio

as i wanted to get mine working via instructions from and then did an installation of
sudo yum install pavucontrol pavumeter paman padevchooser paprefs

then I rebooted and everything from here went downhill
so I then decided to
sudo yum remove pavucontrol pavumeter paman padevchooser paprefs

rebooted and and it all was working!!! Lesson learned... don't try and do too much before a reboot. Thought this might or might not help someone.

tylerwylie 19th November 2007 05:34 AM


Originally Posted by scottro
Anyway, here is my experience. Firstly, sound has been broken for some people as non-root for awhile. The usual solution, leaving pulseaudio out of the equation, is to edit /etc/security/console.perms.d/50-whatever it's called, and add

<sound>=/dev/dsp* /dev/snd/*

Then, at the bottom add

<console> 0666 <sound> 0600 root

This fixes the non-root issue if pulseaudio isn't involved.

This worked for me after removing pulseaudio, one thing is after you do this you might want to chmod 0666 /dev/snd/* or otherwise just reboot.

pedroivo 22nd November 2007 12:35 AM

i solved the problem adding my user to the groups:
pulse, pulse-"something" and pulse-"the other one"

don't know if this is the right thing to do, i'm new to linux...

to access the group edition gui:

K>Administration>Users and Groups (easy, as walking uh?)

click edit>preferences to tell the program that you want to see all system groups and users (or not, i just did)
then you click on your user name and then click the big "properties" icon. go to the tab groups, tick all groups related to audio (pulse, pulse-access, pulse-rt (i also ticked jackuser))

now i can hear all my mp3. ops! not supposed to talk about mp3 on fedora, it's against the distro's ideology...

if it works, please listen to good music only...

zak_neutron 25th November 2007 10:46 PM

4 Attachment(s)
I have been reading this thread with interest and while useful I still have a problem with PA :mad:

Problem: No sound at all apart from (Hillbilly guitar) Sound card detection app from Gnome menu!

No other app or web works!!! (I can see sound being played on Volume Meter on vlc - but no sound out of speakers)

I have one soundcard.

I have ConsoleKit running
I have avahi-daemon running
PA Server is running according to the Pulse Manager. However it cannot find any sinks or sources. See screenshots.

I have amended both the ~/.asoundrc and /etc/asound.conf to include:


pcm.!default {
type pulse
ctl.!default {
type pulse

pcm.pulse {
type pulse

ctl.pulse {
type pulse

System > Preferences > Hardware >Sounds - fails to even list pulseaudio server

I have yum removed "alsa-plugins-pulseaudio"

Please help.

craftyminion 26th November 2007 08:09 AM

OK. This has been hateful. I tried everything mentioned in this thread and nothing worked. I logged into KDE (I normally use Gnome) and it *****ed about there being no device and using the null device. Hoping against hope I started KMix and, lo!, the bugger works.

Youtube and everything.

Even in Gnome.

I'm not sure about Skype, I'll try that later.

Much thanks to the eggheads here who have calmly and patiently shared their knowledge and experience with the rest of us.

Edit: Well, Skype doesn't work. Playback in one ear, can't be heard on the other end. Le sigh.

The Crafty One

craftyminion 26th November 2007 10:24 PM

Alas, the whole thing was too odious. The Crafty One has returned to the comfort and safety of Fedora 7.

The Crafty One

zippy-cz 27th November 2007 09:13 AM

in my case the problem was this:

pulse audio when run from commandline posted error E: main.c: Failed to create '/tmp/pulse-makinka': Operace není povolena (means permission denied in czech).

All problem was in this tmp directory. I don't know why but root was owner. I remember messing around in root console from my sisters account (makinka) for a while but this should not happen. It must have been sideefect of somthing I have been doing. Anyway chown and chmod that directory solved it out for me.

I hope it will be useful for you

shermy451 1st December 2007 02:22 AM

I Found Waldo!!!!! Or one big Answer found.
I was running into the same problem, NO SOUND.
Something didn't look right in the default.pa file. The same thing was in mine too....

### Automatically load driver modules depending on the hardware available
.ifexists /usr/lib/pulse-0.9/modules//module-hal-detect.so
----------------------------That doesn't look right!!

load-module module-hal-detect
### Alternatively use the static hardware detection module (for systems that
### lack HAL support)
load-module module-detect

I took out the superfluous '/' in that line and the additional lines:

.ifexists /usr/lib/pulse-0.9/modules//module-x11-publish.so
.ifexists /usr/lib/pulse-0.9/modules//module-gconf.so

And rebooted (hush). And WOW! it found everything!!! sound works!!
Your thanks is all the reward I need, but if you feel you must, feel free to buy me a beer sometime.


mbratch 1st December 2007 03:09 AM


Originally Posted by high
im puzzled :confused: anyone else have the same issue?

I had all sorts of trouble with sound until I uninstalled all the pulse audio stuff. Then it all worked fine.

heliopaixao 3rd December 2007 12:04 AM

I noticed that file /etc/asound.conf does not pertain to any package then I have removed it. This fix my problem with vlc no having sound after upgrade from fedora7 to fedora8.

radekrat 3rd December 2007 10:40 AM

This is really annoying. The sound was working for me till Friday update. I tried everything in this thread and still PulseAudio-manager shows me "Failed to connect" and won't find any audio device. :confused:

I have myuser in all pulse* groups, I've changed /etc/security and also asound.conf ..

I have pulseaudio-0.9.7-0.17.svn20071017.fc8 and ConsoleKit-0.2.3-1.fc8


strikeforce 3rd December 2007 11:55 AM

Run the following command from console and tell me what the output is.


radekrat 3rd December 2007 01:09 PM


radek@localhost ~$ esd
bash: esd: command not found
radek@localhost ~$ alsamixer
*** PULSEAUDIO: Unable to connect: Connection refused

alsamixer: function snd_ctl_open failed for default: Connection refused

Where do I get esd from, yum install esd cannot find it

strikeforce 3rd December 2007 01:18 PM


I think.

it's one of those two.

radekrat 3rd December 2007 01:39 PM

esd doesn't say much, returns code 1

This is what I found in /var/log/messages

Dec  2 23:11:50 localhost pulseaudio[2346]: module-alsa-sink.c: Error opening PCM device hw:0: No such device
Dec  2 23:11:50 localhost pulseaudio[2346]: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0 sink_name=alsa_output.pci_8086_27d8_alsa_playback_0"): initialization failed.

strikeforce 3rd December 2007 01:47 PM

Can you post the output from the following.


/sbin/chkconfig --list | grep ConsoleKit
/sbin/chkconfig --list | grep avahi

Have you tried system-config-soundcard?

radekrat 3rd December 2007 02:21 PM

Both are running


root@localhost ~# service ConsoleKit status
console-kit-daemon (pid 1831) is running...
root@localhost ~# service avahi-daemon status
Avahi daemon is running

strikeforce 3rd December 2007 02:28 PM

Did you try system-config-soundcard?

radekrat 3rd December 2007 02:32 PM

Yep, and it works. I can hear the sound cos it's running as root

strikeforce 3rd December 2007 02:36 PM

System -> Preferences -> Hardware -> Sound

Are all of them setting to pulse audio except for the Device. On the Sound tab does it have the sound server ticked.

If they are try and reboot your machine.

radekrat 3rd December 2007 02:48 PM

all set on PulseAudioServer and still I don't think the server is running cos PulseAudio-manager can't connect to it. Also the Volume control in Gnome is not working -

The volume control did not find any elements and/or devices to control. This means either that you don't have the right GStreamer plugins installed, or that you don't have a sound card configured.

strikeforce 3rd December 2007 02:54 PM


Thats the package for gstreamer and pulse.

I would check that you have the plugins installed.

These are the pulse packages I have


[marc@Strike-Lap ~]$ rpm -qa | grep pulse

ggulik 3rd December 2007 05:00 PM

I'm watching this thread with great interest because I'm having all sorts of problems as well.

I have a Vaio notebook running the 32-bit F8 and sound is a disaster on it. Almost never does sound work and it's actually surprising when it does.

I have a x86_64 desktop on which Flash can do audio but nothing else can. When running RealPlayer with the ALSA output config I get the following errors:

ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
When I try to run gmplayer to play media I get the following errors:

[AO_ALSA] Unable to find simple control 'PCM',0

I have run all the tests listed above, both services mentioned ARE running:

[root@penguin log]# service ConsoleKit status
console-kit-daemon (pid 2686) is running...
[root@penguin log]# service avahi-daemon status
Avahi daemon is running

Any other suggestions?
This is VERY frustrating.

radekrat 3rd December 2007 09:49 PM

For me to. I have probably the same set of packages as you have and still the volume control and PulseAudio manager doesn't show any sound device.

strikeforce 3rd December 2007 10:23 PM

Try and install the following package then run the program.


yum install alsa-tools

Referring the post #105 install nspluginwrapper

zak_neutron 3rd December 2007 10:33 PM

Managed to get my pulseaudio working - after much hair loss and gnashing of teeth. Found some useful info on another forum - see here

I have to say permissions continues to be the main culprit.

In the above link, pay close attention to the solution put forward by David De Graff (mainly focussed in getting PA to work with XFCE)

I found the process for me to be 2 stage:

1. Get F8 to recognize my soundcard via alsa - again permissions!!!
This brought some of the gnome sound tools into play
2. Get PA configured to point towards your now recognised sound card

I really cannot remember (or just don't want to) all the actual steps that worked for me (nearly 2 full days!!), but Davids amended "/etc/udev/rules.d/40-alsa.rules" file and numerous reboots helped get me started to find my sound card. After this The Gnome System>Preferences>Hardware>Sounds could see the pulseadio sound server as an option

The alsa/sound card problem was understood from the difference between running "aplay -lL" as root and non root.

Don't give up, it is worth it in the end - although you can't help think for F8 that PA was a headline grabbing feature probably released a bit too soon!


strikeforce 3rd December 2007 10:40 PM

I'm quoting the part of the thread here.


OK, here's what I had to do to make it possible to start pulseaudio.

1) Edit /etc/udev/rules.d/40-alsa.rules to set MODE="0666" to all
"snd" files:
# do not edit this file, it will be overwritten on update

KERNEL=="controlC[0-9]*", NAME="snd/%k", MODE="0666"
KERNEL=="hwC[D0-9]*", NAME="snd/%k", MODE="0666"
KERNEL=="pcmC[D0-9cp]*", NAME="snd/%k", MODE="0666"
KERNEL=="midiC[D0-9]*", NAME="snd/%k", MODE="0666"
KERNEL=="timer", NAME="snd/%k", MODE="0666"
KERNEL=="seq", NAME="snd/%k", MODE="0666"
KERNEL=="mixer0", SYMLINK+="mixer"
KERNEL=="dsp0", SYMLINK+="dsp"
KERNEL=="audio0", SYMLINK+="audio"

I guess we just have to ignore the admonition not to edit this file;
there seems to be no other way to do it.

The clue that permissions were too restrictive came from running
aplay -lL
When root did it, the sound card was detected and displayed
reasonably; when non-root did it, no sound devices were found.
This contrasts with Fedora 7, where it works identically for all.

In the original Fedora 8 configuration we had:
# ll /dev/snd
total 0
crw-rw----+ 1 root root 116, 8 2007-11-17 10:09 controlC0
crw-rw----+ 1 root root 116, 4 2007-11-17 10:09 midiC0D0
crw-rw----+ 1 root root 116, 7 2007-11-17 10:09 pcmC0D0c
crw-rw----+ 1 root root 116, 6 2007-11-17 10:09 pcmC0D0p
crw-rw----+ 1 root root 116, 5 2007-11-17 10:09 pcmC0D1p
crw-rw----+ 1 root root 116, 3 2007-11-17 10:09 seq
crw-rw----+ 1 root root 116, 2 2007-11-17 10:08 timer

With only root able to access these file, it was impossible for an
ordinary user to start the pulseaudio daemon.

2) Edit /etc/passwd to set the home directory of user pulse to
/var/run/pulse, eg,
pulse:x:492:488:PulseAudio daemon:/var/run/pulse:/sbin/nologin

This is necessary to allow the --system option to work properly.
On startup, pulseaudio must create directories .gconf and .gconfd in
its home directory. This it cannot do when the home directory is /.

3) On my system, certain files in /var/run and directory
/tmp/gconfd-pulse/ had somehow become owned by user kismet:kismet.
I can't imagine how this happened, but it blocked use by pulseaudio,
which complained in /var/log/messages.
I removed these files and restarted pulseaudio with no more

4) Edit /etc/pulse/default.pa to comment out the x11 lines:
### Publish connection data in the X11 root window
## .ifexists /usr/lib/pulse-0.9/modules//module-x11-publish.so
## load-module module-x11-publish
## .endif

Attempting to load this module outside of X will make pulseaudio fail
to start. Its absence seems to be harmless.

5) Edit /etc/rc.d/rc.local to add these lines;
# Start the pulseaudio daemon
echo "/usr/bin/pulseaudio -D --system --log-target=syslog"
/usr/bin/pulseaudio -D --system --log-target=syslog
/usr/bin/aplay /usr/share/sounds/startup3.wav

With the above fixes, the --system option works properly when root
starts pulseaudio, extending to all users the full use of the sound
system. The last line confirms proper behaviour.

When xfce is started all users inherit the ability to run aplay and
other X sound programs such as xmms. Any console user can use aplay.
Crontab entries of any user can use aplay.

I simply cannot comprehend why Fedora 8 starts the pulseaudio daemon as
a gnome task. With the above fixes, it is perfectly possible to start
it in /etc/rc.d/rc.local. With only a bit more effort, it should be
possible to come up with a simple startup script in /etc/init.d so that
this daemon is treated the same as any other proper Linux daemon.

zak_neutron 3rd December 2007 10:48 PM

Thanks strikeforce - still a bit new to this forum posting! :eek:

zak_neutron 3rd December 2007 10:53 PM


2) Edit /etc/passwd to set the home directory of user pulse to
/var/run/pulse, eg,
pulse:x:492:488:PulseAudio daemon:/var/run/pulse:/sbin/nologin
- word of warning make sure your GID matches the pulse group F8 has created - on my system is wasn't 488 - but 498!!


strikeforce 3rd December 2007 10:54 PM

mine is

pulse:x:496:495:PulseAudio daemon:/:/sbin/nologin

QuantumKnot 4th December 2007 12:49 PM

I had the same problem after doing a yum update. When trying to start pulseaudio volume control, I got a connection refused message (despite both ConsoleKit and Avahi running). RhythmBox would just freeze when trying to play something.

As noted in an earlier post, I noticed suddenly these few lines in my /etc/modprobe.conf

alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7

So I commented them out, did a rm -rf in my /tmp directory and rebooted, and voila, pulseaudio is back alive again. :)

I'm not sure which fixed it but perhaps those strange lines in modprobe.conf is causing the problem.

BoyWonder410 5th December 2007 03:39 AM

it's not a feature if it breaks everything.... i dont know exactly what all sound problems i am having,
sound works fine in WINE, but, amarok, xine, mplayer et cetera dont have any sound
if PCM is set to 100% my speakers are increadibly staticy, which did not occur on fc7.... i'm not going to put a lot of effort into fixing this yt, no time...

jnissly 8th December 2007 06:43 PM


Originally Posted by high
im puzzled :confused: anyone else have the same issue?

As soon as I ran the 68 updates I needed yesterday, my non-root account also lost access to sound. I was getting a "Gstreamer" error.

Thanks to this article: http://linux.dsplabs.com.au/no-volum...on-ubuntu-p31/

I was able to determine that it was a privilege issue, so I did the following:

[jeremy@fedora ~]$ ls -la /dev/snd
total 0
drwxr-xr-x 2 root root 220 2007-12-08 10:33 .
drwxr-xr-x 14 root root 4940 2007-12-08 12:33 ..
crw-rw----+ 1 root root 116, 10 2007-12-08 10:33 controlC0
crw-rw---- 1 root root 116, 4 2007-12-08 10:33 controlC1
crw-rw----+ 1 root root 116, 9 2007-12-08 10:33 hwC0D0
crw-rw---- 1 root root 116, 3 2007-12-08 10:33 midiC1D0
crw-rw----+ 1 root root 116, 8 2007-12-08 10:33 pcmC0D0c
crw-rw----+ 1 root root 116, 7 2007-12-08 10:33 pcmC0D0p
crw-rw----+ 1 root root 116, 6 2007-12-08 10:33 pcmC0D2c
crw-rw----+ 1 root root 116, 5 2007-12-08 10:33 seq
crw-rw----+ 1 root root 116, 2 2007-12-08 10:33 timer

Since only root had permissions, ran this (as root):
[root@fedora ~]# chmod -R a+rwx /dev/snd
[root@fedora ~]# ls -la /dev/snd/
total 0
drwxrwxrwx 2 root root 220 2007-12-08 10:33 .
drwxr-xr-x 14 root root 4940 2007-12-08 12:33 ..
crwxrwxrwx+ 1 root root 116, 10 2007-12-08 10:33 controlC0
crwxrwxrwx 1 root root 116, 4 2007-12-08 10:33 controlC1
crwxrwxrwx+ 1 root root 116, 9 2007-12-08 10:33 hwC0D0
crwxrwxrwx 1 root root 116, 3 2007-12-08 10:33 midiC1D0
crwxrwxrwx+ 1 root root 116, 8 2007-12-08 10:33 pcmC0D0c
crwxrwxrwx+ 1 root root 116, 7 2007-12-08 10:33 pcmC0D0p
crwxrwxrwx+ 1 root root 116, 6 2007-12-08 10:33 pcmC0D2c
crwxrwxrwx+ 1 root root 116, 5 2007-12-08 10:33 seq
crwxrwxrwx+ 1 root root 116, 2 2007-12-08 10:33 timer

Now sound works, on a session-by-session basis. I need to re-run this every time I reboot.

Since my experience with Linux is moderate (6 months), I am not sure as to how to make this change permanent. Can anyone please advise me?

xaoslaad 9th December 2007 04:06 AM

Backup and replace your /etc/security/console.perms.d/50-default.perms with this one. I have made changes to it in the passed, and based on some quick reading I just did it appears some people have problems starting the server without these changes being made.


# device classes -- these are shell-style globs
<scanner>=/dev/scanner* /dev/usb/scanner*
<fb>=/dev/fb /dev/fb[0-9]* \
<dri>=/dev/nvidia* /dev/3dfx* /dev/dri/card*
<sound>=/dev/dsp* /dev/snd/*

# permission definitions
<console>  0600 <pilot>      0660 root.uucp
<console>  0660 <scanner>    0660 root.lp
<console>  0600 <fb>        0600 root
<console>  0600 <kbd>        0600 root
<console>  0600 <joystick>  0600 root
<console>  0700 <gpm>            0700 root
<console>  0600 <mainboard>  0600 root
<console>  0600 <rio500>    0600 root
<console>  0600 <pmu>        0600 root
<console>  0600 <bluetooth>  0600 root
<console>  0600 <irda>      0600 root
<console>  0600 <dvb>        0600 root
<console>  0666 <sound>      0600 root
<xconsole> 0600 /dev/console 0600 root.root
<console>  0600 <dri>            0600 root

Also replace your /etc/asound.conf with this one:

pcm.!default {
          type pulse
ctl.!default {
          type pulse

Then run the commands as root:

cp /root/.pulse-cookie /etc/pulse-cookie
chown pulse:pulse-access /etc/pulse-cookie
chmod 640 /etc/pulse-cookie

And replace your /etc/pulse/client.conf with this one:

# $Id: client.conf.in 1285 2006-08-19 01:18:57Z lennart $
# This file is part of PulseAudio.
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# General Public License for more details.
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for pulseaudio clients. Default values are
## commented out.  Use either ; or # for commenting

## Path to the pulseaudio daemon to run when autospawning.
; daemon-binary = /usr/bin/pulseaudio

## Extra arguments to pass to the pulseaudio daemon
; extra-arguments = --log-target=syslog --exit-idle-time=5

## The default sink to connect to
; default-sink =

## The default source to connect to
; default-source =

## The default sever to connect to
; default-server =

## Autospawn daemons?
; autospawn = 0

### Cookie file
cookie-file = /etc/pulse-cookie

### Disable shared memory data transfer
; disable-shm = 0

Reboot and see if all this gets you working on boot-up

elyes85 9th December 2007 01:57 PM

Problem With mp3, mpeg, ....files
Hi ! every body !! my Fedora 8 can't read mp3 files ... I think livna is the solution online, but want an other offline !! how can I do it ? :)

strikeforce 9th December 2007 02:38 PM

That is not relating to pulse audio thats a separate issue refer to http://fedorasolved.org or http:fedoraguide.info

xaltednet 10th December 2007 04:23 AM


Originally Posted by elyes85
Hi ! every body !! my Fedora 8 can't read mp3 files ... I think livna is the solution online, but want an other offline !! how can I do it ? :)

Not a pulse issue but visit:

lsatenstein 10th December 2007 04:52 AM

I am using pulse audio since it was released in F8. Never had a problem with it. Use it with xine, mplayer, all the audio players, etc.

My system -- intel mb d930 dual core cpu, 3.0 gig memory. It worked fine with 1 gig memory too.

How can I help you? My f8 is 64 bit version.

aniketv 10th December 2007 07:03 AM

Hello all,
I just wanted to know, if anyone has had succeeded in using skype v1.4 or v2.0beta with pulseaudio, and if yes how!
Because I had lotsa troubles with skype and pulse, rest all was working fine(mplayer,xine etc) . So I have disabled pulse currently, but i wanna use desperately coz i need to switch between snd cards frequently( BT headset and Onboard soundcard) , so pulse Is what I need !!!

ahvi 23rd January 2008 05:46 PM

For anybody having problems with sound in VLC, make sure /usr/lib/pulse-0.9/modules/module-esound-sink.so is displayed in Settings>Preferences>Audio>Output Modules>EsounD>Esound server

cable_txg 23rd January 2008 05:59 PM

I do have PulseAudio working fine for me. When installing FC4 - FC8 I believe I had to set my group to also belong to sound(PulseAudio in FC8). Here's my id:
uid=500(Cable_txg) gid=500(Cable_txg) groups=100(users),495(pulse-access),497(pulse),500(Cable_txg) context=system_u:system_r:unconfined_t:s0

Also from System->Administration->Users and Groups click on properties for any user name and under "Groups" tab, click on pulse and pulse-access to include user in that group.

Hope that works.... :D

elvenhack 27th January 2008 09:06 PM

Fedora 8 pulse audio as a system-wide daemon
For anybody trying to get Fedora 8 to run as a system-wide deamon as opposed to only starting up when someone logs into an X-server (ex: I'm setting up my machine as a headless jukebox, so I want to be able to ssh into it and start a song using mpg/ogg123 on the command line) here was the last crucial step for me. I'm sure this somehow bad for security but at least it works.

Go into /etc/pulse/default.pa and comment out the line
load-module module-x11-publish.

After doing this I was able to successfully run the following command as root:

# pulseaudio --system -D

Good luck!

escapeflowne 14th February 2008 02:03 PM

i have this problem with sound->in general pulseaudio plays sound fine. but after some reboots i hear no sound and when i run alsamixer in terminal it says pulseaudio:connection refused. the only solution i found was either remove alsa-plugins-pulseaudio or rm -rf /tmp/pulse-username as root ,pulseaudio -k and pulseaudio -D. so my question is -are these solutions real solutions or am i missing a simple trick ? i have consolekit and avahi-daemon running.

strikeforce 14th February 2008 10:25 PM

Console Kit is supposed to fix that since it is supposed to be giving you permissions.

The actual error comes from /tmp/pulse-username

jnissly 24th February 2008 03:23 AM


Originally Posted by scottro
Sigh, sound. I'll just say, remember, Fedora is considered a bleeding edge distro. Yeah, it should Just Work(TM) but when I get ticked, I tell myself, well, it's not one of those distros that aims to try to be an MS replacement. :)

Personally, I feel that even ALSA was an answer to a question no one asked, but, that's a rant for a different day. OSS worked with less effort.

Anyway, here is my experience. Firstly, sound has been broken for some people as non-root for awhile. The usual solution, leaving pulseaudio out of the equation, is to edit /etc/security/console.perms.d/50-whatever it's called, and add

<sound>=/dev/dsp* /dev/snd/*

Then, at the bottom add

<console> 0666 <sound> 0600 root

This fixes the non-root issue if pulseaudio isn't involved.


Thank you for posting this, it did the trick for me. I used to have to chown /dev/snd every time I booted.

bluestone 16th March 2008 04:25 PM

For my issue (no sound in Nexuiz: crime). I found some great tips from the links on this page regarding sound:


for me, he was right, only -- system-config-soundcard just needed the box unchecked regarding alsa being non-hardware specific.

I think...

Anyway, sound is working now.
I'll be shooting you all soon in Nexuiz!


shweta 28th May 2008 09:22 AM

I have the same problem. There's no sound, root or no root. Also pulse audio crashes. And when I try editting the etc/security file it says no privileges to do such a thing.

escapeflowne 29th May 2008 07:48 AM

1>what is the output of /sbin/lspci -v|grep -i audio ?
2>try removing the alsa-plugins-pulseaudio ?
3>try removing the /tmp/pulse-<username> folder,then pulseaudio -D.
4>if all else fails try mounting tmpfs on /tmp ?

Dr.Lee 16th January 2009 05:08 AM

Hi all,

I seem to have the same problem as you guys. For me, there's no sound, root or no root.
Did anyone succeeded in using skype 1.4? I hope someone can help me. I've been looking for an answer for quite a while now but it never seemed to work.Simulation pret immobilier

Thanks all!

JohnVV 16th January 2009 07:40 AM

as far as i know skype dose not work with pulse on fedora 8 ,may have been fixed in fedora 9 or 10 .or just remove pulse and reinstall alsa -- before the servers are taken offline ( 8 hit End of Life on jan 7)

Gabyrpg 8th April 2009 11:22 PM

Awesome post, thanks !

glhere 9th April 2009 12:41 AM

audio, mplayer, selinux messages
ok, so whether I set up pulseaudio or alsa I get no sound. One cannot be opened and the otherrefuses to connect.

SELinux message when attempting to watch online streaming video is

>The mplayer application attempted to load /usr/lib/codecs/drv4.so.6.0 which requires text relocation. This is a potential security problem. Most libraries do not need this permission. Libraries are sometimes coded incorrectly and request this permission.<

Seems trying to write to a file and execute it at the same time is a no-no, but this was supposedly corrected in kernels >2.6...

Anyone know about this?

Thanks for your time

JohnVV 9th April 2009 01:47 AM

glhere please start a new thread for this NEW problem.
and what dose your problem have to do with fedora 8 .

scottro 9th April 2009 02:25 AM

Folks to avoid confusion, I think I'm going to close this thread. The last new information is from January, and while that's relatively recent, I think that it might result in issues like the one in the last few posts, a newcomer posting a new issue because it's pulse related. The thread originated in 2007, so I think it served it's original purpose.

If any of you think that this is REALLY wrong, you can PM me, but I probably won't see it till tomorrow.


All times are GMT +1. The time now is 10:35 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.