Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Thread Tools Search this Thread Display Modes
Old 21st August 2006, 09:36 AM
rayyes Offline
Registered User
Join Date: Dec 2004
Location: Toronto, ON
Posts: 408
howto -=COMPIZ=- in 5 STEPS!

Ok guys I just finished installing FC5 and had to try out compiz. Oh man it is da BOMB! :P
Anyways it took me honestly 5 min to install so I decided to share with the community. Follow the below steps and you will be running compiz in no time.

*NOTE 1* ONLY tested with nvidia card, accelerated driver installed
*NOTE 2* ONLY tested on gnome. I'm a KDE guy, but gnome is more 'compiz-ready'

Edit: Tested on KDE too! see bottom
If you pass these 2 requirements, then read on:


Download all the required files from the following directory http://users.telenet.be/quenta/5/i386/ into a folder on your home drive. Use whatever you have to. I personally used Donwthemall extension for firefox https://addons.mozilla.org/firefox/201/
NOTE: if the site goes down, send me a PM, i have a copy which i can put up online.


Install the mesa-libGL sources:
yum install mesa-libGL-devel
This will install some other stuff too


Open a terminal and cd to the folder you downloaded the compiz stuff into.
Now is the fun part. You need to install the compiz rpm
rpm -ivh compiz-1.0.0-4.i386.rpm
but you need to install the prerequisites first. I forgot to make a note of the exact order but if i remember correctly its something like this(ie, run as root rpm -ivh packagename in the following order):
compiz-1.0.0-4.i386.rpm    <------------once this file is installed, you are pretty much done!

run this command:

you get something like:
]# gnome-xgl-info
G nVidia Corporation
0 kmod-nvidia is installed for the kernel release 1.2174_FC5
1 -accel glx:pbuffer -accel xv
run the following command (save any unsaved docs first)
gnome-xgl-switch --enable-xgl --auto
IF ALL GOES WELL, it should prompt you to restart GDM, and upon restart, you will get a sexy compiz-enabled desktop like mine!

Fire up kedit and paste the following
[Desktop Entry]
Exec=compiz --replace decoration wobbly fade switcher minimize cube rotate zoom scale move resize place & gnome-window-decorator &xmodmap -e "keycode 22 = BackSpace" &
Save the file as:
(replace USERNAME by YOUR username)
You've got a sexy desktop too!
KDE instructions stolen from the ubuntu forums, can't find the page anymore.

instructions based loosely on this page
Attached Thumbnails
Click image for larger version

Name:	snapshot1.jpg
Views:	336
Size:	215.3 KB
ID:	8930  
Peace - To the Middle East.

Last edited by jim; 4th September 2006 at 02:23 PM. Reason: correct command to start xgl
Reply With Quote
Old 2nd September 2006, 08:39 AM
bigboss2200 Offline
Wondering Where I Am
Join Date: Oct 2005
Posts: 309
yo man..

thanks for the tutorial.. i DID install compiz and i can see it in apps.. BUT.. when i type "gnome-xgl-info" i cant see anything..!! infact the terminal said that there is no such a command..!!! any suggestions..??

another question... i installed compiz first then mesa-libGL-devel "NOTE: i dont have an internet connection throw fedora, so i just searched for it in rpm.pbone.net and found mesa-libGL-devel-6.4.2-6.i386 .. ".. so, is it ok to install compiz first then mesa-libGL-devel..?

1 last thing, what is the best Kernel and nVidia version to use..? im currently using 2174 kernel with 8774 nVidia driver..

Reply With Quote
Old 4th September 2006, 06:46 AM
bigboss2200 Offline
Wondering Where I Am
Join Date: Oct 2005
Posts: 309
hey hey hey.. i cant just ignore what u have done in this great tutorial

man.. THANKS ALOT.. finally, i SUCCESSED in installing compiz and xgl.. thanks for this great tutorial man...

but i made some more steps

first i installed nVidia drivers "with kmod ofcourse", and i had a problem there coz nVidia driver is getting conflected with SULINUX list or something like that.. so i simply un-installed SULinux and installed nVidia driver

then i downloaded all the packages from the link u provided.. and install them (exept some packages )

finally.. the missing step.. after installing all packages, go to ur terminal and type:
" touch /etc/susconfig/xgl/status"
" gnome-xgl-switch --enable-xgl --auto" ..

and done


EDIT: take a look at my desktop now in the attachment
Attached Thumbnails
Click image for larger version

Name:	Screenshot.png
Views:	236
Size:	438.9 KB
ID:	9054  

Last edited by bigboss2200; 4th September 2006 at 06:57 AM.
Reply With Quote
Old 5th September 2006, 01:27 AM
H8-TRAIN Offline
Registered User
Join Date: Feb 2006
Posts: 32
ok i went through your steeps and got evrything installed properly with no eroors, restarted kde with your mentioned method [ctrl] [alt] backspace, and didnt see any difference sao i restarted my pc. I see the "configuration tool for compiz" and open it but have absolutely no idea what i am doing, I have no idea how to use compiz or if it is running correctly, dont know how to utilize the "cube" portion of compiz or how to make my windows look like they do in the compiz video i saw when moving them around. can some please help me make sure that i DO have compiz running correctly adn maybe a walkthrough on how to make good use of compiz.

Reply With Quote
Old 5th September 2006, 06:03 AM
bigboss2200 Offline
Wondering Where I Am
Join Date: Oct 2005
Posts: 309
hi H8..

I had the same issue that u have before.. but with gnome.. and i figured out what was wrong..

simply speaking, there r 2 possibilites:
1- is that u have installed the nVidia driver from "www.nvidia.com".. which will NOT work..
2- u didnt configure ur X window to start with compiz..

i have a suggestion for u..

y dont u try to use compiz with gnome..? if it "did" work then atleast u know that ur nVidia driver is ok and its only a matter of configurations that is left..

for me, after installing everything, i checked if everything is right "in gnome ofcourse" by typing:

then to start xgl, i typed:
gnome-xgl-switch --enable-xgl --auto

and i got my sexy desktop installed
Reply With Quote
Old 8th September 2006, 04:42 PM
angrykeyboarder Offline
Registered User
Join Date: Oct 2004
Location: Vancouver, Washington, U.S.A.
Posts: 20
#yum install mesa-libGL-devel
Repository 'bmpx-source' is missing name in configuration, using id
Repository 'bmpx-debuginfo' is missing name in configuration, using id
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
dries [1/17]
updates-testing [2/17]
bmpx-source [3/17]
kde-redhat-all [4/17]
flash [5/17]
kde-redhat [6/17]
bmpx-debuginfo [7/17]
core [8/17]
jpackage-fedora [9/17]
jpackage-generic-nonfree [10/17]
bmpx [11/17]
kde-redhat-testing-all [12/17]
jpackage-generic [13/17]
freshrpms [14/17]
kde-redhat-testing [15/17]
extras [16/17]
updates [17/17]
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do
Reply With Quote
Old 9th September 2006, 01:06 PM
rayyes Offline
Registered User
Join Date: Dec 2004
Location: Toronto, ON
Posts: 408
you're welcome! im glad you found the howto useful

hmmm...if you got no errors i would assume that you have nvidia drivers installed. honestly bigboss2200's suggestions are good and you should follow them. note: the cube effect is CTRL+ALT+[left or right arrow]. you can see a list of all the effects by searching on google.

i don't know, its possible that you already have this package installed?
try as root: rpm -q mesa-libGL-devel
if it returns a package name, then you have it installed.
otherwise, you probably need to enable some other repos
Peace - To the Middle East.
Reply With Quote
Old 11th September 2006, 12:02 AM
ryptyde Offline
Registered User
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,700
Thanks rayyes for getting me going in the right direction, I now have compiz setup and functional.

This may be of interest for those that want to revert back to a "normal" desktop once the novelty wears off.

]# gnome-xgl-switch
Usage: gnome-xgl-switch --enable-xgl --auto
gnome-xgl-switch --enable-xgl --set [xgl options]
gnome-xgl-switch --disable-xgl

edit: installed the "compiz-quinn" rpm and made it easier to make changes.Added the "cube" screenshot with dome and top images.

Here's a couple of images of "get-set compiz" in action, if you installed this you will have access to all of the
plugin commands via the "shortcut" menu.

Click image for larger view.

Last edited by ryptyde; 28th September 2006 at 12:45 AM.
Reply With Quote

compiz, howto, steps

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Current GMT-time: 16:27 (Saturday, 23-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat