Fedora Linux Support Community & Resources Center
Prev Previous Post   Next Post Next
Old 4th January 2008, 07:34 AM
fart_flower Offline
Registered User
Join Date: Jan 2008
Posts: 26
Refresh rate problem

My Acer AL2416W is stuck at 1920x1200x50Hz. What's the secret to getting 60Hz? There is currently no "60 Hz" option in the drop-down menu found at System > Preferences > Hardware > Screen Resolution, but it used to exist before installing the nVidia drivers. (The drivers are working fine, but no faster than 50 Hz.)

I have fiddled with the xorg.conf file with various "solutions" from Mr. Google, but the only one that made any difference was adding a "modeline" from gtf, which then gave me a choice between 50Hz and 51Hz.

Currently my xorg.conf file has been reset to it's immediate post nVidia drivers installation state, which noticeably lacks a "monitor" section:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"

Section "ServerFlags"
Option "AIGLX" "on"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24

Section "Extensions"
Option "Composite" "Enable"
Here's some more funky information:

Up until yesterday, I was using Ubuntu Gutsy Gibbon, but wanted to give Fedora a shot for various reasons. (CFS kernel feature being one of them.) In Gutsy Gibbon I had a similar (identical?) problem that affected the "smoothness" of compiz-fusion.

Ubuntu gave me the option of 50Hz and 60Hz in the drop-down menu, but I could never change them in Gnome. Sometimes the system would boot with 50 Hz, sometimes with 60 Hz. 50/50 random chance.

If it booted with a 50 Hz refresh rate, the drop-down menu would say it was selected, but I could never change it to 60 Hz. Instead, I would Ctrl+Alt+Backspace to reset X and hope for 60 Hz. If it was indeed 60 Hz, the drop-down menu would show 60 Hz was selected. Bizarre...

Furthermore, in both cases, my monitor's on-screen-display would alway claim I was receiving a 60 Hz signal. But when Ubuntu was running at 50 Hz, compiz effects were noticeably stuttering. However, when it decided to run at 60 Hz, effects were smooth like astro-glide on ice.

So now I'm giving Fedora a shot, but for the life of me, I can't get 60 Hz.

Any hints? I want smoothness, not stutteriness. (And before anyone suggests it, I'm very certain this is not a compiz settings problem.)
Reply With Quote

problem, rate, refresh

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz Refresh Rate Problem (CRT Monitor) Boricua Fedora Focus 8 8th July 2008 07:04 PM
Changing resolution causes refresh rate problem quadomatic Hardware & Laptops 1 22nd May 2008 05:15 PM
Need help with refresh rate problem b00st Using Fedora 2 9th June 2006 08:04 PM
Refresh Rate Problem edimoldovan Hardware & Laptops 5 7th April 2005 07:22 PM

Current GMT-time: 00:45 (Friday, 22-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat