Fedora Linux Support Community & Resources Center
Prev Previous Post   Next Post Next
  #1  
Old 27th January 2009, 08:14 AM
rbhkamal Offline
Registered User
 
Join Date: Jul 2007
Posts: 34
Added a new HDD and broke Grub - Error 15

[EDIT] Correction, Grub loads but gives me Error 15 [EDIT]

I bought a 640GB HD and wanted to swap it with a 80GB Harddrive which has two partitions: /dev/sdb1 (boot) LogVol01
/dev/sdb2 (LVM) LogVol00

After taking the steps below, grub doesn't seem to load from the new harddrive:
1- Used fdisk to create two partitions:
1.5GB /dev/sda1 (ext3) Primary + Boot flag
639GB /dev/sda2 (ext3) Primary

2- Used dd to clone the /boot partition from the old HD to the new one:
dd if=/dev/sdb1 of=/dev/sda1

3- Moved the extends from /dev/sdb2 to /dev/sda2
pvcreate /dev/sda2
vgextend VolGroup00 /dev/sda2
pvmove /dev/sdb2 /dev/sda2
vgreduce VolGroup00 /dev/sda2

4- Poweroff
5- Remove the old 80GB HD
6- Power-on and set my BIOS to boot from the new harddrive.

Now the computer seems to boot from the new harddrive however, I only get black screen with a blinking dash.

[EDIT] Correction, Grub loads but gives me Error 15 [EDIT]

What did I miss here?

Thank's for you help

Last edited by rbhkamal; 27th January 2009 at 08:37 AM.
Reply With Quote
 

Tags
added , broke , grub , hdd , load

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can other os be added to grub through fedora? sseipel133 Installation, Upgrades and Live Media 3 15th October 2009 12:48 PM
Interrupted preupgrade broke GRUB rgaelzer Installation, Upgrades and Live Media 1 20th August 2009 12:24 AM
Manually added fdi file to /etc/hal/fdi/policy is unable to load in Fedora 11 helloworld1 Using Fedora 0 30th June 2009 03:31 PM
grub help-- added vfat partition Wiles Using Fedora 1 19th December 2006 04:48 PM
Grub Didn't Load into MBR saberman Installation, Upgrades and Live Media 1 6th April 2006 04:03 AM


Current GMT-time: 07:59 (Sunday, 22-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat